Installing JWSDP on Solaris

Posted on 2011-03-17
Last Modified: 2014-10-18
Hi, I am trying to install JWSDP on Solaris. The installable is getting executed and in the last step, it asks for the installation directory:

Please specify a directory or press Enter to accept the default directory.
Installation Directory: [/home/Krisdir/jwsdp-1.5]

Press 1 for Next, 2 for Previous, 3 to Cancel or 4 to Redisplay [1] 1

I selected 1, and the program exited without installing anything. Any idea what is wrong? I tried with JWSDP1.5 and 2.0, and the same issue. So, it's not a problem with the distribution.

Thanks a lot.

Question by:LeoKris
  • 3
  • 3
LVL 68

Expert Comment

ID: 35156013
Could it be that you're not allowed to create /home/Krisdir/jwsdp-1.5 or to write to it?

What if you try to create the directory manually ( mkdir -p /home/Krisdir/jwsdp-1.5 ) or a file inside (touch /home/Krisdir/jwsdp-1.5/testfile )?

What do you get with  "ls -ld /home/Krisdir" and "ls -ld /home/Krisdir/jwsdp-1.5" ?



Author Comment

ID: 35156108
this is how am running the command:
sh ./ -console

Here is the output of the command (ls -ld KrisJava):

drwxrwxrwx   3 asapd018 metasolv     512 Mar 18 00:05 KrisJava/  (I am installing it under KrisJava dir)

I also tried "touch" command and it could create the file, so no access issues.

anything else I can try?


LVL 68

Expert Comment

ID: 35156207
Please issue

set -xv

and retry.

What do you see in the trace output? Any clue?
What is SQL Server and how does it work?

The purpose of this paper is to provide you background on SQL Server. It’s your self-study guide for learning fundamentals. It includes both the history of SQL and its technical basics. Concepts and definitions will form the solid foundation of your future DBA expertise.


Author Comment

ID: 35157920
Hi woolmilkporc,
                   I tried this but no luck. What is "set-xv" supposed to do?

The problem is that installation exits without any trace. No clue whatsoever.

I searched on Google and found other people too have got issues with this, but couldn't find a fix.


LVL 68

Expert Comment

ID: 35157954
set -xv  (with a space inbetween) starts a verbose trace of shell script execution.
Since your installation command ends in ".sh" I assumed that it's a shell script.

Maybe you could open it using "vi" and search for "Press 1 for Next" to check what the script would try to do after having received the "1".


Accepted Solution

LeoKris earned 0 total points
ID: 35163156
I made it work !!. I ran the command in "Ksh" and it works perfect :).  Not sure what problem setup had with "bash" shell.

Thanks wool for your help.


Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Strange space issue in Chrome browser 8 95
Oracle Finace 3 66
MarkLogic 1 67
replace column/record content in a *csv file based on a regular expression 6 52
Turn A Profile Picture Into A Cartoon Using Photoshop And Illustrator This tutorial will teach you how to make a cartoon style image out of a regular picture. I have tried to keep the tutorial as simple as possible. I used Adobe CS4 for this tuto…
Objective of This Article In 1990’s, when I was a budding software professional, I had a lot of confusion about which stream or technology, I had to choose to build my career. In those days, I had lot of confusion like whether to choose System so…
The purpose of this video is to demonstrate how to properly insert a Vimeo Video into a WordPress site or Blog. This will be demonstrated using a Windows 8 PC. Go to your WordPress login page. This will look like the following:…
The purpose of this video is to demonstrate how to integrate Mailchimp with WordPress, by placing a Mailchimp signup form on a WordPress Page or Post. This will be demonstrated using a Windows 8 PC. Mailchimp will be used. Log into your Mailchi…

932 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now