Server 2003, unable to delete folder

I have a folder that I'm not able to delete. The customer has a person who's responsible for the folders at this location, I'm pretty sure that he by mistake removed all groups from having access when removing inheritance.

When I attempt to open security settings for the folder I get the following error: "You do not have permission to view or edit the current permission settings for FOLDERNAME, but you can change the auditing settings." (Note: it does NOT say "take ownership or change auditing settings".)

If opening advanced options I do not see "Owner", it's not there, hence I can not take owership of the folder.

Attempting to access folder as a domain admin having "Full control" NTFS permission on the parent folder. (Checked effective permissions on parent folder, no issues.)

Attempted to reset ACL for the folder using cacls/icacls - access denied. Attempted to add myself as owner using mentioned comman line tools - access denied. Tested unlocker.exe as it's already installed on the server - access denied.

In case of relevance; the folder is located on a share belonging to a cluster resource that had been moved before I attempted to fix/delete the folder. Attempted to move resource before trying to delete folder - didn't change anything. Data physically stored on mirrored SAN disks.

As I have performed a restore of the data from the folder from before it were corrupted I have no need to "save" the folder, I just want to delete it.
IntrepidityAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
IntrepidityConnect With a Mentor Author Commented:
Data has been migrated and server taken out of production due to lack of capacity. Issue does no longer exist.
0
 
CombatGold1Commented:
Ah, I've had this problem too. I used the "takeown" command to give myself ownership of the folder so I could then change permissions on it (as I didn't want to delete it, but you have the same cause).

Open the command prompt and use this command to set the ownership to the Administrators group:
takeown /F folder /A /R
The folder can be a \\network\shared\folder, or you can use /S computer if you want to connect to a remote computer and use the command locally on that.

If you don't use /A, the owner will be you rather than the Administrators group.

/U and /P can be used to specify a username and password if you need to.
0
 
IntrepidityAuthor Commented:
Sorry, it's just the same, "Access is denied".
0
Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
dbruntonCommented:
Boot from a Linux Live CD such as Knoppix http://www.knoppix.org/ or Ubuntu http://www.ubuntu.com/

Navigate to the offending folder and delete.
0
 
IntrepidityAuthor Commented:
Forgot to mention that due to the data being available through a cluster resource and stored on SAN using WinPE, safe mode, Linux live CD's or similar is not an option.

Also forgot to mention that I did use checkdisk without finding any issues on the relevant volume.
0
 
CombatGold1Commented:
Are you able to execute the "takeown" command as the built-in Administrator account rather than just your own user account that has administrator access? The built-in account is for the most part unrestricted.
0
 
IntrepidityAuthor Commented:
Issue isn't linked to lack of permissions, domain admin account should be sufficient. No change using local Administrator account.

Kind of annoying how something as simple as deleting a folder can get this tricky.
0
 
IntrepidityAuthor Commented:
As issue is no longer relevant question is closed.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.