Solved

SBS 2011 - Backup fails

Posted on 2011-03-17
7
4,667 Views
Last Modified: 2012-05-12
Hello experts,
This issue is on a MS Small Business Server 2011. Backup fails to complete no matter what changes are made to the backup configuration. Formatting the backup location, changing the type of back up from incremental to full, stopping schedule and rescheduling with new external drive... The error message that is given from the back up console is 'The operation was stopped. Detailed error: the volume shadow copy operation failed with error 0x800423F0. View the event log for more information'. Then when I go to the event log under Server Roles>File server, I have this error:
-----------------------------------------------------------------
Log Name:      Application
Source:        VSS
Date:          3/17/2011 10:23:58 AM
Event ID:      8193
Task Category: None
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      h.local
Description:
Volume Shadow Copy Service error: Unexpected error calling routine CoCreateInstance.  hr = 0x80040154, Class not registered
.
Operation:
   Instantiating VSS server
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="VSS" />
    <EventID Qualifiers="0">8193</EventID>
    <Level>2</Level>
    <Task>0</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2011-03-17T14:23:58.000000000Z" />
    <EventRecordID>25434</EventRecordID>
    <Channel>Application</Channel>
    <Computer>h.local</Computer>
    <Security />
  </System>
  <EventData>
    <Data>CoCreateInstance</Data>
    <Data>0x80040154, Class not registered
</Data>
    <Data>
Operation:
   Instantiating VSS server</Data>
    <Binary> !Removed If needed can repost!
----------------------------------------------------------------------------
This error too:

Log Name:      Application
Source:        VSS
Date:          3/17/2011 10:32:16 AM
Event ID:      8230
Task Category: None
Level:         Warning
Keywords:      Classic
User:          N/A
Computer:      h.local
Description:
Volume Shadow Copy Service error: Failed resolving account spsearch with status 1376. Check connection to domain controller and VssAccessControl registry key.

Operation:
   PrepareForSnapshot Event

Context:
   Execution Context: Writer
   Writer Class Id: {afbab4a2-367d-4d15-a586-71dbb18f8485}
   Writer Name: Registry Writer
   Writer Instance ID: {8fd4b2fb-a379-4ea0-8079-a4c9f1873267}

Error-specific details:
   Error: NetLocalGroupGetMemebers(spsearch), 0x80070560, The specified local group does not exist.

Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="VSS" />
    <EventID Qualifiers="0">8230</EventID>
    <Level>3</Level>
    <Task>0</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2011-03-17T14:32:16.000000000Z" />
    <EventRecordID>25455</EventRecordID>
    <Channel>Application</Channel>
    <Computer>H.local</Computer>
    <Security />
  </System>
  <EventData>
    <Data>spsearch</Data>
    <Data>1376</Data>
    <Data>
Operation:
   PrepareForSnapshot Event
Context:
   Execution Context: Writer
   Writer Class Id: {afbab4a2-367d-4d15-a586-71dbb18f8485}
   Writer Name: Registry Writer
   Writer Instance ID: {8fd4b2fb-a379-4ea0-8079-a4c9f1873267}
Error-specific details:
   Error: NetLocalGroupGetMemebers(spsearch), 0x80070560, The specified local group does not exist.
</Data>
    <Binary> !Again, removed the binary, If needed please advise, and I'll repost!
------------------------------------------------------------------------------------

There are more errors and warning in the list. Not sure if these will give you enough to go on.? If more are needed please let me know and I can post them too.
Also, I have uninstalled and reinstalled the Back Up Feature from Server Manager, but that didn't work either... Please point me in the right direction to get this resolved.
Thanks in advance for your help!!!
0
Comment
Question by:HHTech1
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 3
7 Comments
 
LVL 35

Expert Comment

by:Cris Hanna
ID: 35159748
just curious..how big are your partitions on the server?
0
 
LVL 1

Author Comment

by:HHTech1
ID: 35160139
473 gb and 460 gb
0
 
LVL 35

Expert Comment

by:Cris Hanna
ID: 35160409
And how big is your USB drive?
What is the make and model of the drive?
0
Revamp Your Training Process

Drastically shorten your training time with WalkMe's advanced online training solution that Guides your trainees to action.

 
LVL 1

Author Comment

by:HHTech1
ID: 35160753
The current xternal HD is 1.5 gb Seagate Free Agent xtreme. I have had no luck with the one I bought and used at fresh install either. It is a GoFlex 2 TB drive. It worked up until last week. Not sure this is the problem since I tried backing up only a few folders off of a seperate HD and it would not even do that. errored out with the VSS error.

I've searched alot for solutions and see that the issue with the 100 mb partition being the active partition is related to this.? Should I change the active partition to c: (the one the os is installed on)?

Thanks
0
 
LVL 35

Expert Comment

by:Cris Hanna
ID: 35162439
I've just looked at my own SBS 2011.  My own system shows the 100mb reserved partition as active

I would first go here and work through these and see how you come out
http://support.microsoft.com/kb/2483007 - Windows SBS 2011 Standard Known Post Installation Event Log Errors and Warnings

Then go here  http://www.sbslinks.com/sbsbpa.htm
Notice there is a file you must download and install before installing the actual BPA

See what issues it finds and recommendations for corrective action
0
 
LVL 1

Accepted Solution

by:
jrits earned 500 total points
ID: 36482712
I had the exactly the same issue and came acros this blog:

http://blogs.technet.com/b/sbs/archive/2011/07/06/potential-issues-after-installing-sharepoint-foundation-2010-sp1.aspx 

After updating Sharepoint i had no more issues.
0
 
LVL 1

Author Comment

by:HHTech1
ID: 37001918
Problem finally fixed. It was an issue with the vss writers... there where several of them that were disabled and would not enable due to the spfarm and spsearch user account having multiple issues with thier permissions and how they controlled the sharepoint farm. After a total sharepoint disconnect and creation of a new site with a new farm user account. the back up works as it should and the sharepoint server has no more issues!!!
0

Featured Post

Best Practices: Disaster Recovery Testing

Besides backup, any IT division should have a disaster recovery plan. You will find a few tips below relating to the development of such a plan and to what issues one should pay special attention in the course of backup planning.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Lotus Notes – formerly IBM Notes – is an email client application, while IBM Domino (earlier Lotus Domino) is an email server. The client possesses a set of features that are even more advanced as compared to that of Outlook. Likewise, IBM Domino is…
A list of top three free exchange EDB viewers that helps the user to extract a mailbox from an unmounted .edb file and get a clear preview of all emails & other items with just a single click on mailboxes.
This tutorial will walk an individual through the process of installing of Data Protection Manager on a server running Windows Server 2012 R2, including the prerequisites. Microsoft .Net 3.5 is required. To install this feature, go to Server Manager…
This video shows how to quickly and easily add an email signature for all users on Exchange 2016. The resulting signature is applied on a server level by Exchange Online. The email signature template has been downloaded from: www.mail-signatures…

738 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question