Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

VMware Server Nat works Bridge Fails

Posted on 2011-03-17
16
Medium Priority
?
1,550 Views
Last Modified: 2012-05-11
I have set up a VM image of Ubuntu 10.10 on VMware Server 2 with the host being a 64bit Windows 2003 Server. This image works perfectly in Bridged mode, DHCP is set to automatic. The host machine is also working in DHCP mode and has 2 network adapters.

I have transferred the Ubuntu image to a different server on a different network. The server is set up practicably the same as the old host, a 64bit Windows 2003 Server running VMware Server 2 with 2 network cards, with an assigned IP it does not use DHCP.

My issue is getting the VM Ubuntu to access the new network on the new server. NAT works fine giving me internet access but i need to run in bridged mode. DHCP is not working it does not find the DHCP server, can not ping it. Setting the IP manually (using the same setting as the host machine, with a reserved IP) still fails to connect the VM Ubuntu to the network.

I believe this is a host issue not a VM image issue, because i know this image works just fine. Any ideas to what is causing the problem?



Edit:
My main goal is to just be able to ping the host from the Vm image. Right now i cant ping between the two using IPs so this is not DNS issue or Gateway issue.
0
Comment
Question by:Daniel_P67
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 10
  • 6
16 Comments
 
LVL 7

Expert Comment

by:Piloute
ID: 35158387
Hi,

Just a guess, since I don't use Windows server : have you checked security/firewall settings ?

Cheers,
P
0
 
LVL 1

Author Comment

by:Daniel_P67
ID: 35158418
Firewall is disabled, and both servers have the same anti-virus.
0
 
LVL 7

Expert Comment

by:Piloute
ID: 35160253
Some other thoughts then...

Is the VMware DHCP server active on this machine ? Can't remember if NAT & bridge are using the same address management in VMware... Have you checked the IP address of the Ubuntu machine when in bridged mode, to make sure it has one ?

Have you managed to get a response when pinging from the host to the guest (ping the Ubuntu system from the Windows) in bridged mode ?

P
0
Efficient way to get backups off site to Azure

This user guide provides instructions on how to deploy and configure both a StoneFly Scale Out NAS Enterprise Cloud Drive virtual machine and Veeam Cloud Connect in the Microsoft Azure Cloud.

 
LVL 1

Author Comment

by:Daniel_P67
ID: 35160496
Is the VMware DHCP server active on this machine ?
Yes DHCP is active

Can't remember if NAT & bridge are using the same address management in VMware... Have you checked the IP address of the Ubuntu machine when in bridged mode, to make sure it has one ?
I am not getting an IP, when i assign one manually it still does not work.



Have you managed to get a response when pinging from the host to the guest (ping the Ubuntu system from the Windows) in bridged mode ?
pinging from either machine does not work in DHCP mode or with a static IP
0
 
LVL 7

Expert Comment

by:Piloute
ID: 35160704
<<I am not getting an IP, when i assign one manually it still does not work.>>

OK. At least, you know now where's the problem. You must find a reason Ubuntu can't get an IP. Check out the network connections configuration (if you use Gnome : Sytem > Preferences > Network Connections).

On you first network (eth0) :
- you can unactivate IPv6 (set it to Ignore)
- you should have IPv4 set to DHCP

Or, you can drop the Wired Connection profile and create a new one...
0
 
LVL 1

Author Comment

by:Daniel_P67
ID: 35160762
On you first network (eth0) :
- you can unactivate IPv6 (set it to Ignore)
- you should have IPv4 set to DHCP

IPv6 is disabled, and i have truely disabled it by way of command line. IPV4 is set to DHCP, or manual when i set the IP manually.

Or, you can drop the Wired Connection profile and create a new one...
I have done this, it still does not pick up an IP
0
 
LVL 1

Author Comment

by:Daniel_P67
ID: 35160791
I have even added a 2nd V-networkcard in the VMware Server settings for the Ubuntu OS and set it to bridge mode. Same issue its like it has no contact out side of its self.


The only two IPs i can ping are 127.0.0.1 and the IP i assign it.
0
 
LVL 1

Author Comment

by:Daniel_P67
ID: 35161175
I just reloaded VMware Server with a fresh image and i am getting better results, but not much.

My current settings network adapter 1 is set to VMnet0 instead of bridge and under the Vm network manager i defined VMnet0 to the correct network card manually instead of letting it auto detect.

Ubuntu is getting an IP address but i still can not ping out side of itself.  
0
 
LVL 1

Accepted Solution

by:
Daniel_P67 earned 0 total points
ID: 35161720
Issue resolved, there was a lot of things wrong both on the VMware side and ubuntu side. When i searched for answers online i saw a lot of people having this issue with no answers. If your on ubuntu check your Bcast address mine was wrong, ubuntu was putting it on a different subnet and i did not notice it. Also had to make all the below changes. Right now everything is working except for DNS, but thats just because i have not set it yet.

Hope this helps someone else from hours of trail and error

•      Manually setting VMNet0 to Bridge mode-and selecting Primary(the name of one of the network adapters) as its network interface
•      Set the VM-Image to use VMNet0 and not “Bridge mode” even though “Bridge mode” should of worked, like it does on my other server
•      For some reason the the other sites DHCP server does not like Ubuntu , DHCP fails on Ubuntu even though it will giving Ubuntu an IP address.
•      Had to set IP, Subnet, Gateway, Network, Bcast, DNS, SearchDomain manually
IMPORTANT
•      Bcast needed to be 10.XXX.4.XXX not whatever Ubuntu was using 10.XXX.7.XXX and
needed to put in gateway again even though it was assigned under network connections,
sudo ifconfig eth0 broadcast " bcast ip"
sudo route add default gw "gateway IP"
0
 
LVL 7

Expert Comment

by:Piloute
ID: 35165654
Daniel,

>> Had to set IP, Subnet, Gateway, Network, Bcast, DNS, SearchDomain manually <<

Well, what did I suggest you when told to recreate your connection ?

>> DHCP server does not like Ubuntu <<

Now this is a scientific explanation !   :(

>> Bcast needed to be 10.XXX.4.XXX not whatever Ubuntu was using 10.XXX.7.XXX <<

See the first point in this remark.... If you totally reconfigured your network, how did this happen ?

-------

I'm happy you managed to make it work.

Good luck.
0
 
LVL 7

Expert Comment

by:Piloute
ID: 35165663
and... Welcome !
0
 
LVL 1

Author Comment

by:Daniel_P67
ID: 35166425
>> Had to set IP, Subnet, Gateway, Network, Bcast, DNS, SearchDomain manually <<

Well, what did I suggest you when told to recreate your connection ?
>>>I had already tried to recreate a profile, as stated above, before you mentioned it, many times including adding a second adapter and re-adding the VM to VM server. So you did not give me this idea, i had already tried it...

>> DHCP server does not like Ubuntu <<

Now this is a scientific explanation !   :(
>>> i do not have access to the DHCP server so i do not know why it does not work. Your right its a bad answer, but its the best i have.

>> Bcast needed to be 10.XXX.4.XXX not whatever Ubuntu was using 10.XXX.7.XXX <<

See the first point in this remark.... If you totally reconfigured your network, how did this happen ?
>>> Again i did not reconfigure anything on the network. Static ips are on 4 and Dynamic is on 5 thats how the network is configured. I have no idea why Ubuntu was putting the broadcast at 7 which lead me no-where and was the main cause on my issues. Even when DHCP gave me an IP it gave me the wrong Bcast.


Your post below with your:

On you first network (eth0) :
- you can unactivate IPv6 (set it to Ignore)
- you should have IPv4 set to DHCP
>>>I had already done this, so you did not add to my solution

Or, you can drop the Wired Connection profile and create a new one...?
>>>Again i had already tried this and it did not work, yes i had to manually set everything but you did not say that. Simply saying create a new one could mean manually configure each address or re-add DHCP. Your response is not clear about which one you meant.


Yes, i am accepting my own solution but awarding no points to my self as i dont believe anyone should when they find there own answer. My fix was documneted here completely along with the Command line commands. I want others to know what solved the issue. Thank you for your help in this, but your comments did not help me solve this issue.
0
 
LVL 1

Author Comment

by:Daniel_P67
ID: 35166539
To make it clear, your comments where not wrong. They are correct in their line of thinking, the same thinking i had. I did not accept as solution because they are broad comments, not a specific solution.
0
 
LVL 7

Expert Comment

by:Piloute
ID: 35167523
No need to lecture on this. I don't care about points, since you are not the only person I try to help. And I perfectly know I can't solve all problems.

All I was expecting was a 'thaks for your time'.  It usually motivates people to try to help people who are in trouble.

Cheers,
P
0
 
LVL 1

Author Comment

by:Daniel_P67
ID: 35167565
I am sorry, i forgot to thank you. That was my mistake. The points comment was related to me not you. Thank you for helping and spending time on this issue.

0
 
LVL 1

Author Closing Comment

by:Daniel_P67
ID: 35187504
Accepting own solution because i finally found out all the problems with VmWare and Ubuntu.
0

Featured Post

Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

When converting a physical machine to a virtual machine using VMware vCenter Converter Standalone or vCenter Converter Enterprise, if an adapter type is not selected during the initial customization the resulting virtual machine may contain an IDE d…
In this article, I will show you HOW TO: Install VMware Tools for Windows on a VMware Windows virtual machine on a VMware vSphere Hypervisor 6.5 (ESXi 6.5) Host Server, using the VMware Host Client. The virtual machine has Windows Server 2016 instal…
Teach the user how to use create log bundles for vCenter Server or ESXi hosts Open vSphere Web Client: Generate vCenter Server and ESXi host log bundle:  Open vCenter Server Appliance Web Management interface and generate log bundle: Open vCenter Se…
Advanced tutorial on how to run the esxtop command to capture a batch file in csv format in order to export the file and use it for performance analysis. He demonstrates how to download the file using a vSphere web client (or vSphere client) and exp…

610 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question