Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 827
  • Last Modified:

openssh on Windows 2003

I am following the procedures in the link you provided for installing openssh on windows 2003 server. I am using the older version because the compiling your own seemed to involved for a non-unix person. Anyway I am almost done but I am stuck at:

¦If you're not using the full Cygwin install you probably won't have bash so you will need to change the shells in the passwd file to use /cygdrive/c/Windows/system32/cmd.exe.

I do not find where in the passwd file I would change this.

0
InSearchOf
Asked:
InSearchOf
  • 5
  • 2
  • 2
2 Solutions
 
willettmeisterCommented:
in cygwin it should be in .etc/passwd
0
 
sgvillCommented:
you generally put it after the home directory.  Here is a link that shows a typical format

http://www.cyberciti.biz/faq/understanding-etcpasswd-file-format/
0
 
InSearchOfAuthor Commented:
Great. Thanks for the info. When I ran the mkpasswd command I used the -d switch because it was a domain user but it created accounts for all my domain users. Can I just delete the the other users?
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
sgvillCommented:
you should be able to remove the domain user accounts you don't need.
0
 
InSearchOfAuthor Commented:
Ok. Thanks for the info. One last question. In the command below where it says "/cygdrive/"
would I change that to c: or do I use the syntax as is?

¦If you're not using the full Cygwin install you probably won't have bash so you will need to change the shells in the passwd file to use /cygdrive/c/Windows/system32/cmd.exe
0
 
InSearchOfAuthor Commented:
I cannot start the openSSH service. I get these two errors:

-starting service `OpenSSHd' failed: execv: 1, Operation not permitted.
-starting service `I' failed: redirect_fd: open (1, /var/log/OpenSSHd.log): 13, Permission denied.

The "logon On" in the service properties is set to the SSH user I created. The log file in the C:\Program Files\OpenSSH\var\log is empty. Can I enable this somewhere so that I can get error info?
0
 
willettmeisterCommented:
Trying opening the cygwin prompt on the system so that you have a LINUX style shell and go to /var;log.OpenSSHd.log and see if there is info there.

0
 
InSearchOfAuthor Commented:
I am not unix savvy at all. How do I do that with my version of openSSH? From what I read openSSH installs a partial version of Cygwin.
0
 
InSearchOfAuthor Commented:
Ok. I reinstalled it. I got the service to start, generated the public/private keys and I make the connection but I do not see where I can download anything.
0

Featured Post

Automating Your MSP Business

The road to profitability.
Delivering superior services is key to ensuring customer satisfaction and the consequent long-term relationships that enable MSPs to lock in predictable, recurring revenue. What's the best way to deliver superior service? One word: automation.

  • 5
  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now