?
Solved

Problem with installing wireless card driver in Linux

Posted on 2011-03-17
22
Medium Priority
?
587 Views
Last Modified: 2012-05-11
Hello,

I downloaded the driver http://sourceforge.net/projects/ipw2200-ap/files/ipw2200-ap/0.3/ipw2200-ap-0.3.tgz/ for my laptop's wireless card. I'm studying the INSTALL file but it seems that some steps are missing. Could you please guide me through the install process to correctly install the driver?

uname -a Linux xralf-laptop 2.6.32-25-generic #45-Ubuntu SMP Sat Oct 16 19:48:22 UTC 2010 i686 GNU/Linux

Thank you
0
Comment
Question by:xRalf
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 9
  • 5
  • 2
  • +3
22 Comments
 
LVL 20

Assisted Solution

by:edster9999
edster9999 earned 288 total points
ID: 35160147
Unless your linux kernel is 3 or 4 years old then it already has IPW2200 inside it.
It may work straight out of the box (it depends on how it was setup by the distribution) or there is a slim chance you will need to recompile the kernel.
How you do this depends on what Linux distro you are running but is pretty easy.
0
 
LVL 6

Author Comment

by:xRalf
ID: 35160237
The wireless network card is probably not working. The LED diod on the laptop is not yellow (as bluetooth LED diod).

I'm using Xubuntu 10.04 (Lucid Lynx). You can see uname -a in the question.
0
 
LVL 3

Assisted Solution

by:Alberto Cortes
Alberto Cortes earned 288 total points
ID: 35160616
Module ipw2200 should be already available in Ubuntu
Try this in a console:

$ echo "options ipw2200 led=1" >> /etc/modprobe.d/ipw2200.modprobe
$ rmmod ipw2200
$ modprobe ipw2200

This should activate the led.
0
Why Off-Site Backups Are The Only Way To Go

You are probably backing up your data—but how and where? Ransomware is on the rise and there are variants that specifically target backups. Read on to discover why off-site is the way to go.

 
LVL 6

Author Comment

by:xRalf
ID: 35163142
I tried
sudo echo "options ipw2200 led=1" >> /etc/modprobe.d/ipw2200.modprobe

but it still writes
bash: /etc/modprobe.d/ipw2200.modprobe: Permission denied

and the file ipw2200.modprobe is not there
0
 
LVL 8

Assisted Solution

by:pilson66
pilson66 earned 284 total points
ID: 35164026
Try:
sudo -s
echo "options ipw2200 led=1" >> /etc/modprobe.d/ipw2200.modprobe
0
 
LVL 6

Author Comment

by:xRalf
ID: 35164062
I tried the commands successfully

after the
$ modprobe ipw2200
it wrote
WARNING: All config files need .conf: /etc/modprobe.d/ipw2200.modprobe, it will be ignored in a future release.

The the LED is not lit (yellow).
0
 
LVL 3

Expert Comment

by:Alberto Cortes
ID: 35168162
# rmmod ipw2200
# modprobe ipw2200
0
 
LVL 6

Author Comment

by:xRalf
ID: 35171403
to RicoCebiche: nothing changed.
0
 
LVL 18

Assisted Solution

by:TobiasHolm
TobiasHolm earned 568 total points
ID: 35187679
Hi!

Follow this guide: https://help.ubuntu.com/10.04/internet/C/troubleshooting-wireless.html
"Wireless troubleshooting in Ubuntu 10.04"

Regards, Tobias
0
 
LVL 35

Assisted Solution

by:Duncan Roe
Duncan Roe earned 572 total points
ID: 35187795
I suspect you can get rid of the warning by
sudo -s
cd /etc/modprobe.d
mv ipw2200.modprobe ipw2200.modprobe.conf

Open in new window

You might as well keep the root shell for Ron. Personally I would never run one of these nursemaid distributions that force you to use su in the first place, but I'm an old-timer.
2 things you can try next

1. Read the documentation

Let's say you have your Linux source as /usr/src/linux. Read /usr/src/linux/Documentation/networking/README.ipw2200

2. Observe system information

From your sudo -s session, issue rmmod ipw2200 (just to make sure the module is not loaded). Next, again issue modprobe ipw2200. After that, as a regular user if you like, issue dmesg | tail -33. You should see some output from the module, hopefully that it found a device. That's tail (T A I L) btw, with my fonts it looked like "tall".
0
 
LVL 6

Author Comment

by:xRalf
ID: 35191341
To duncan_roe

>> I suspect you can get rid of the warning by
The warning dissapeared, but the situation is probably not better.

>> You might as well keep the root shell for Ron.
OK. And who is Ron?

>> Personally I would never run one of these nursemaid distributions that force you to use su in the first place, but I'm an old-timer.
Which distribution would you recommend?

>> Let's say you have your Linux source as /usr/src/linux.
There is not such a directory. locate README.ipw2200 founds nothing.

>> rmmod ipw2200; dmesg | tail -33 (relevant lines)
[ 4278.410401] ipw2200 0000:02:04.0: PCI INT A disabled
[ 4290.615801] ipw2200: Intel(R) PRO/Wireless 2200/2915 Network Driver, 1.2.2kmprq
[ 4290.615807] ipw2200: Copyright(c) 2003-2006 Intel Corporation
[ 4290.615890] ipw2200 0000:02:04.0: PCI INT A -> Link[LNKB] -> GSI 10 (level, low) -> IRQ 10
[ 4290.615964] ipw2200: Detected Intel PRO/Wireless 2200BG Network Connection
[ 4290.616042] ipw2200 0000:02:04.0: firmware: requesting ipw2200-bss.fw
[ 4290.739988] ipw2200: Radio Frequency Kill Switch is On:
[ 4290.739992] Kill switch must be turned off for wireless networking to work.
[ 4290.742447] ipw2200: Detected geography ZZM (11 802.11bg channels, 0 802.11a channels)
[ 4578.852330] ipw2200 0000:02:04.0: PCI INT A disabled
0
 
LVL 18

Accepted Solution

by:
TobiasHolm earned 568 total points
ID: 35192571
>Radio Frequency Kill Switch is On

I suppose the switch is in wifi enable position? Then try this, set the wifi switch to OFF, reboot the computer, then set the wifi switch to ON again and reboot the computer again!

Regards, Tobias
0
 
LVL 6

Author Comment

by:xRalf
ID: 35192739
to Tobias

On my laptop there is no kill switch. I don't know what does it mean and how does it look like. But in the manual to my laptop there is no such s switch. Or is it some software switch?
0
 
LVL 18

Expert Comment

by:TobiasHolm
ID: 35192873
Usually on laptops with wireless networking built in you have a physical switch on the laptop to be able to turn off the wireless radio. This can be used if you're using the laptop in an airplane or similar. The switch can be quite tiny and hard to locate!

Regards, Tobias
0
 
LVL 6

Author Comment

by:xRalf
ID: 35192946
I don't have such a switch. The wi-fi card was working under Windows XP without switch and no switch is described in the manual to the laptop.
0
 
LVL 18

Expert Comment

by:TobiasHolm
ID: 35193253
ok. Do you have a key-combination on your laptop for switching the Wifi on/off? Like Fn+F5 (on a ThinkPad T61) or something smiliar.

Do you have Windows (dual-boot) on this machine? Then you should try booting into Windows and switch the Wifi on, and then reboot into Xbuntu again.

Another thing to test if the above fail is to get the latest upgrades for your system. Be sure to take a backup first.

Regards, Tobias
0
 
LVL 6

Author Comment

by:xRalf
ID: 35193289
>> ok. Do you have a key-combination on your laptop for switching the Wifi on/off? Like Fn+F5 (on a ThinkPad T61) or something smiliar.
No, there was no need to press key combination.
>> Do you have Windows (dual-boot) on this machine?
No, I have only Ubuntu.
>> Another thing to test if the above fail is to get the latest upgrades for your system. Be sure to take a backup first.
Which upgrades do you mean?
0
 
LVL 18

Expert Comment

by:TobiasHolm
ID: 35193476
sudo apt-get upgrade

Open in new window

If this doesn't work to get your wireless up'n running, try

sudo apt-get dist-upgrade

Open in new window

Be sure to take a backup first.

Regards, Tobias
0
 
LVL 35

Assisted Solution

by:Duncan Roe
Duncan Roe earned 572 total points
ID: 35194029
The warning disappeared, but the situation is probably not better. Agreed. But, the module is working and your dmesg output from it pinpoints the real problem.
OK. And who is Ron? You don't know Ron? His first name is Late (aussie slang for later on - couldn't resist sorry :)
Which distribution would you recommend? I use Slackware
There is not such a directory. locate README.ipw2200 founds nothing You need to install Linux Source to have it. Were you offered that during install perhaps? It should be on your distribution medium otherwise you can get it from ftp://ftp.kernel.org/pub/linux/kernel/v2.6/

The power switch may be an AT command to the modem. You will have to look on the web for its data sheet.
0
 
LVL 6

Author Comment

by:xRalf
ID: 35336235
Sorry,

I have a little time these days. It showed that I can press directly the LED diod and after pressing it's blinking. So, we're closer to solution. I will read carefully the answers and ask more accurate question alter.

thank you.
0

Featured Post

Prepare for your VMware VCP6-DCV exam.

Josh Coen and Jason Langer have prepared the latest edition of VCP study guide. Both authors have been working in the IT field for more than a decade, and both hold VMware certifications. This 163-page guide covers all 10 of the exam blueprint sections.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I. Introduction There's an interesting discussion going on now in an Experts Exchange Group — Attachments with no extension (http://www.experts-exchange.com/discussions/210281/Attachments-with-no-extension.html). This reminded me of questions tha…
Join Greg Farro and Ethan Banks from Packet Pushers (http://packetpushers.net/podcast/podcasts/pq-show-93-smart-network-monitoring-paessler-sponsored/) and Greg Ross from Paessler (https://www.paessler.com/prtg) for a discussion about smart network …
Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…
Connecting to an Amazon Linux EC2 Instance from Windows Using PuTTY.
Suggested Courses
Course of the Month14 days, 1 hour left to enroll

800 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question