Solved

Workflows aren't working plain and simple

Posted on 2011-03-17
5
683 Views
Last Modified: 2012-05-11
Plain and simple, workflows aren't working.  I recently setup my CRM 4.0 about 3 months ago and had someone on my staff do all of the master file information.  Now that I have time, I am working within the system to get everything going.  

First thing, is that I tried to create a workflow that would automatically create a contact upon the creation of a new account called "Receiving" didn't work.  

So, I decided to just do something silly and create a work flow that when a new account is added, just put something stupid in the WebSite field for testing, doesn't work.

Basically, my WF's are trying to fire but they choose to remain in a Status Reason of "Waiting".   Waiting for what, I have no clue.

I've confirmed that the "Microsoft CRM Asynchronous Processing Service" is running and I have restarted it now 10 times.  

I see no event logs saying anything bad or negative regarding CRM.   So, I'm kinda at a lose here to diagnose this issue.  
0
Comment
Question by:chrisryhal
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
5 Comments
 
LVL 27

Expert Comment

by:Chinmay Patel
ID: 35161882
Hi chrisryhal,

There are many other factors which can render WFs to be in waiting state.

I recommend you follow this article : http://support.microsoft.com/kb/907490 and setup tracing so that we can see detailed logs.

Once you get the log files. Try to run your workflow again and upload the logs here.

Regards,
Chinmay
0
 
LVL 2

Author Comment

by:chrisryhal
ID: 35182178
Chinmay,

Back on this today.  Will do what you have asked and get the results back ASAP
0
 
LVL 2

Author Comment

by:chrisryhal
ID: 35192162
Ok, looks like this is what we got.    Kinda strange message considering the way I get to the CRM system is http://crm.<domain>.com:5555

Everything else in CRM works perfect.


# CRM Tracing Version 2.0
# LocalTime: 2011-03-22 13:37:00.1
# Categories:
# CallStackOn: No
# ComputerName: WIN-H719QSEN48N
# CRMVersion: 4.0.7333.3135
# DeploymentType: OnPremise
# ScaleGroup:
# ServerRole: AppServer, AsyncService, DiscoveryService, WebService, ApiServer, HelpServer, DeploymentService

[2011-03-22 13:37:00.1] Process:CrmAsyncService |Organization:6668dbff-1bb6-4132-a432-cb46325c0b02 |Thread:    4 |Category: Platform.Async |User: 00000000-0000-0000-0000-000000000000 |Level: Error | AsyncOperationCommand.Execute
>Exception while trying to execute AsyncOperationId: {B5D665F6-AA54-E011-A1F2-0018E7087767} AsyncOperationType: 1 - System.Net.WebException: The remote name could not be resolved: 'http'
   at System.Net.HttpWebRequest.GetRequestStream(TransportContext& context)
   at System.Net.HttpWebRequest.GetRequestStream()
   at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)
   at Microsoft.Crm.SdkTypeProxy.CrmService.Retrieve(String entityName, Guid id, ColumnSetBase columnSet)
   at Microsoft.Crm.Asynchronous.SdkTypeProxyCrmServiceWrapper.Retrieve(String entityName, Guid id, ColumnSetBase columnSet)
   at Microsoft.Crm.Asynchronous.SdkPluginDescriptionProvider.GetPluginTypeDescription(Guid pluginTypeId, IOrganizationContext context)
   at Microsoft.Crm.Caching.PluginTypeCacheLoader.LoadCacheData(Guid key, IOrganizationContext context)
   at Microsoft.Crm.Caching.CrmMultiOrgCache`2.CreateEntry(TKey key, IOrganizationContext context)
   at Microsoft.Crm.Caching.CrmSharedMultiOrgCache`2.LookupEntry(TKey key, IOrganizationContext context)
   at Microsoft.Crm.Caching.PluginTypeCache.LookupEntry(Guid pluginTypeId, IOrganizationContext context)
   at Microsoft.Crm.Asynchronous.AsyncOperationCommand.GetPluginType(Guid pluginTypeId)
   at Microsoft.Crm.Asynchronous.EventOperation.InternalExecute(AsyncEvent asyncEvent)
   at Microsoft.Crm.Asynchronous.AsyncOperationCommand.Execute(AsyncEvent asyncEvent)
[2011-03-22 13:37:48.8] Process:CrmAsyncService |Organization:6668dbff-1bb6-4132-a432-cb46325c0b02 |Thread:   21 |Category: Platform.Async |User: 00000000-0000-0000-0000-000000000000 |Level: Error | AsyncOperationCommand.Execute
>Exception while trying to execute AsyncOperationId: {B5D665F6-AA54-E011-A1F2-0018E7087767} AsyncOperationType: 1 - System.Net.WebException: The remote name could not be resolved: 'http'
   at System.Net.HttpWebRequest.GetRequestStream(TransportContext& context)
   at System.Net.HttpWebRequest.GetRequestStream()
   at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)
   at Microsoft.Crm.SdkTypeProxy.CrmService.Retrieve(String entityName, Guid id, ColumnSetBase columnSet)
   at Microsoft.Crm.Asynchronous.SdkTypeProxyCrmServiceWrapper.Retrieve(String entityName, Guid id, ColumnSetBase columnSet)
   at Microsoft.Crm.Asynchronous.SdkPluginDescriptionProvider.GetPluginTypeDescription(Guid pluginTypeId, IOrganizationContext context)
   at Microsoft.Crm.Caching.PluginTypeCacheLoader.LoadCacheData(Guid key, IOrganizationContext context)
   at Microsoft.Crm.Caching.CrmMultiOrgCache`2.CreateEntry(TKey key, IOrganizationContext context)
   at Microsoft.Crm.Caching.CrmSharedMultiOrgCache`2.LookupEntry(TKey key, IOrganizationContext context)
   at Microsoft.Crm.Caching.PluginTypeCache.LookupEntry(Guid pluginTypeId, IOrganizationContext context)
   at Microsoft.Crm.Asynchronous.AsyncOperationCommand.GetPluginType(Guid pluginTypeId)
   at Microsoft.Crm.Asynchronous.EventOperation.InternalExecute(AsyncEvent asyncEvent)
   at Microsoft.Crm.Asynchronous.AsyncOperationCommand.Execute(AsyncEvent asyncEvent)
0
 
LVL 27

Accepted Solution

by:
Chinmay Patel earned 500 total points
ID: 35208419
Alright seems this link might hold the answer :
http://social.microsoft.com/Forums/en/crmdevelopment/thread/9369fc70-cfe9-4ba2-b469-5558ce80f6d9

Also if you have configured IFD, there is a chance that it has not reflected in your configuration.

Try the link given above and we'll see how it goes.

Regards,
Chinmay.
0
 
LVL 2

Author Comment

by:chrisryhal
ID: 35212697
Chinmay,

I simply reinstalled and it worked.  Don't know why, but the link you gave me was very useful in the IFD part.  Thank you again for your responses.
0

Featured Post

On Demand Webinar: Networking for the Cloud Era

Ready to improve network connectivity? Watch this webinar to learn how SD-WANs and a one-click instant connect tool can boost provisions, deployment, and management of your cloud connection.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Automatically creating a Trello card using data from a Microsoft Dynamics CRM record turned out to be an easy project that yielded great results.  Here's how I did this for an internal team at General Code.
For cloud, the “train has left the station” and in the Microsoft ERP & CRM world, that means the next generation of enterprise software from Microsoft is here: Dynamics 365 is Microsoft’s new integrated business solution that unifies CRM and ERP fun…
Michael from AdRem Software outlines event notifications and Automatic Corrective Actions in network monitoring. Automatic Corrective Actions are scripts, which can automatically run upon discovery of a certain undesirable condition in your network.…
Add bar graphs to Access queries using Unicode block characters. Graphs appear on every record in the color you want. Give life to numbers. Hopes this gives you ideas on visualizing your data in new ways ~ Create a calculated field in a query: …

729 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question