?
Solved

Filemaker Server (local) not automatically discovering. Need to manually enter path.

Posted on 2011-03-17
10
Medium Priority
?
577 Views
Last Modified: 2012-05-11
HI there,

I can't seem to get my Filemaker Server (9) to be detectable automatically when loading up FileMaker Pro (10). In the past we have had our server automatically show up when accessing 'Open Remote'. We need to manually enter the path.
The server is running Server 2008 R2 and network discovery is turned on for the Work/Home Networks. The clients are not connected to the domain but will be, however it shouldn't matter.
Firewall is currently turned off.

Thanks
0
Comment
Question by:lemonville
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 7
  • 3
10 Comments
 
LVL 25

Expert Comment

by:Will Loving
ID: 35162003
FileMaker Pro 9 has a specific issue if it's installed after a particular date (can't recall the date but it's not really important). The issue is that the SSL certificate that FileMaker Pro installs is expired and that prevents files on the server from being visible in the Open Remote dialog. You can see the server, but not the files. FileMaker has released a specific patch for this issue.

The description and patch can be found here:
 
http://help.filemaker.com/app/answers/detail/a_id/7016/~/software-update%3A-filemaker-pro-9.0v3-and-filemaker-pro-9.0v3-advanced-ssl
0
 
LVL 25

Expert Comment

by:Will Loving
ID: 35162095
Just went back and re-read your original question and realized that I didn't answer it at all. The primary issue I've seen with FileMaker Pro not listing the server under Local Hosts is that the server and client machines are on different subnets, for example the server has an IP address of 192.168.1.xxx and the clients are on 192.168.2.xxx, so the second octet is different, in this case 1 and 2. If the client and server are not or cannot be on the same subnet, then you will need to add the server IP address as a "Favorite".

Alternately, you can create a simple FileMaker startup file that lives on the desktop. It contains no tables and just one script that is set to run on startup.

Open File [ <file on server> ]
Close File [ ]

Users can just double click on this file which will then open the remote file and close itself.
0
 
LVL 1

Author Comment

by:lemonville
ID: 35162328
Hi there,

The server/clients are on the same subnet.

However, can you elaborate on the script.

Cheers
0
Visualize your virtual and backup environments

Create well-organized and polished visualizations of your virtual and backup environments when planning VMware vSphere, Microsoft Hyper-V or Veeam deployments. It helps you to gain better visibility and valuable business insights.

 
LVL 25

Expert Comment

by:Will Loving
ID: 35162523
The attached file can be set to automatically open any hosted (or local) FileMaker database. It will automatically open itself, open your remote file and then close itself leaving your remote file open. It contains no tables, no data and just one script, "Start". To setup this file to open YOUR database, hold the Shift Key and then double-click on the file. (The script is set to stop and open Scriptmaker if the Shift key is detected.)

In Scriptmaker, open the "Start" script and then select the “Open File” script step. Click the "Specify" button and Add FileMaker Pro data source, then select the remote FM file that you want to open, even if it’s located on a remote server. Save the script, close Scriptmaker and then close the file.

The “Start” script in “File Options” to automatically run when the "Start" file opens. It will open the remote file and then close itself. If you need to edit the file, just hold down the Shift key when opening it. Once you are satisfied that it works, you can remove the "Pause" step in the script.

Once setup, this file can be distributed for users to keep on their desktop. It should work from any location but may have to be modified and re-distributed it you change your server or file name. Connecting from outside a local network or across the internet can require setting up the router for Port Forwarding. (See FileMaker Knowledgebase article for more information on this topic: http://help.filemaker.com/app/answers/detail/a_id/7840/kw/FMP )
Start.fp7
0
 
LVL 1

Author Comment

by:lemonville
ID: 35176315
Thats great,

I've set it up and it works. One thing though. It starts with an error 'Filemaker cannot share this file because network sharing is turned off'.
Also, the Script Textbox stays on screen for several seconds. Can we get rid of this box?

Cheers
0
 
LVL 25

Expert Comment

by:Will Loving
ID: 35176952
A couple of things then:

1) Open the file holding the shift key down. Then, go into Sharing -> FileMaker Network, and make sure that it's set to "All Users" which the original file I uploaded was not. (see screen shot)

2) Open ScriptMaker and edit the "Start" script to remove or disable the 3 second Pause/Resume Script step. It is this step that causes the Instruction layout to stay on screen.
0
 
LVL 25

Expert Comment

by:Will Loving
ID: 35177023
0
 
LVL 1

Author Comment

by:lemonville
ID: 35195315
Hi there,

for 1) Is that on an individual client machine basis. We are using PC's btw also. I made the change and its working. I have yet to test on another machine.

2) I removed that line and that text box has remained.

Please let me know
0
 
LVL 25

Accepted Solution

by:
Will Loving earned 2000 total points
ID: 35195673
1) The network options dialog basically looks the same regardless of whether you are on a Mac or Windows machine. Network sharing is specific to individual machines, so you may have to set it on each machine. It might be sufficient to must make sure that it's turned on in FileMaker, even when no files are open.

2) The ScriptMaker dialog listing the Start Script only comes up if you hold the Shift key down. If you are referring to the instructions layout, it stays open until the Remote file has opened and then closes. You can could make a second layout that says something like "Starting up <name of database>..." instead of the instructions screen. if you want to make it completely disappear, you can add a "Move/Resize Window" step prior to the Open File[""] script step that sets the Height and Width to 0 and the Distance from Top and Left to -200 (which is off screen to the upper left).

 Move/Resize Window Options
0
 
LVL 25

Assisted Solution

by:Will Loving
Will Loving earned 2000 total points
ID: 35198874
I've posted an article on this topic along with a revised Startup file at http://www.experts-exchange.com/A_5043.html
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

The recent Microsoft changes on update philosophy for Windows pre-10 and their impact on existing WSUS implementations.
This article explains how to install and use the NTBackup utility that comes with Windows Server.
This tutorial will walk an individual through configuring a drive on a Windows Server 2008 to perform shadow copies in order to quickly recover deleted files and folders. Click on Start and then select Computer to view the available drives on the se…
This tutorial will walk an individual through setting the global and backup job media overwrite and protection periods in Backup Exec 2012. Log onto the Backup Exec Central Administration Server. Examine the services. If all or most of them are stop…
Suggested Courses

770 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question