Excel 2010 opens all spreadsheets in new instance of Excel

I just upgraded to Office 2010. Now when I open a spreadsheet any way besides using the File - Open command in Excel itself I get new instances of Excel for each spreadsheet I am opening. For example, if I go to a folder that has 3 spreadsheets, select all 3, right click Open, each spreadsheet opens in a new instance of Excel and I get the "Personal.xls is locked for editing. Open Read-Only" popup message in all but the first instance. And my macros won't work.

This occurs no matter how I open the spreadsheets, from folders as above, email attachments, doesn't matter. Very annoying. I tried a search but all I come up with is how people want to open spreadsheets in new instances of Excel. I would like to reuse the existing instance of Excel.  I did find one answer from someone who used Click-to-Run installation vs installing from CDs that might be relevant but I am not sure. The installation file was downloaded to my laptop from my company.

As always, all help will be appreciated.

JazCatAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
zorvek (Kevin Jones)Connect With a Mentor ConsultantCommented:
Excel, by default, opens all new workbooks in the same instance. It uses what is called a multiple document interface or MDI. The only way to stop this behavior is to change the way the file manager launches new documents. By repairing Excel this mechanism is reset to the default which is to open the workbook in an existing Excel instance. Why your workmates suffer the same is a mystery to me.

Here are my notes for configuring the file manager to open new workbooks in new instances of Excel. Perhaps you can reverse these instructions to restore the default behavior.

To configure Excel to open each opened workbook in a new Excel instance, open Windows File Explorer and chose the menu command Tools->Folder Options. Navigate to the tab File Types. Find the XLSX entry and click Advanced. Select Open and click Edit. Uncheck "Use DDE". Add  "%1", with the quotes, to the end of the string in the field "Application used to perform action" - making sure there is a space before the first quote - and click OK, click OK again, and click Close.

Note that when workbooks are opened in separate instances of Excel they cannot link to each other and cell ranges cannot be copied from one workbook to another.

Kevin
0
 
zorvek (Kevin Jones)ConsultantCommented:
To restore the default behavior, quit all instances of Excel, click the Start menu and select Run. Enter "Excel.exe /UnRegServer" and click OK, wait for the process to finish, then enter "Excel.exe /RegServer" and click OK. The full path to Excel may have to be entered for the command to work.

To get the command to work the full path to the Excel application may be required. If so, the path usually looks like:

   C:\Program Files\Microsoft Office\OFFICE\Excel.exe

or

   C:\Program Files\Microsoft Office\OFFICExx\Excel.exe

where xx is the Excel version: 10 for 2002, 11 for 2003, 12 for 2007, and 14 for 2010. So the commands for Excel 2003 are:

   "C:\Program Files\Microsoft Office\OFFICE11\Excel.exe" /UnRegServer
   "C:\Program Files\Microsoft Office\OFFICE11\Excel.exe" /RegServer

Kevin
0
 
JazCatAuthor Commented:
Sorry, zorvek, that didn't help. I tried it but it still does the same thing, opens new instances of Excel for each spreadsheet.
0
Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
zorvek (Kevin Jones)ConsultantCommented:
Let's try this next:

Click the Microsoft Office Button, and then click Excel Options. In the Navigation Pane, click Resources. Click Diagnose, click Continue, and then click Start Diagnostics.

Kevin
0
 
JazCatAuthor Commented:
Sorry, this is Excel 2010, no Office Button and no Resources button. Checked all the options available in the File - Options bar. In the Privacy Settings the Download a File Periodically that helps determine system problems is grayed out.
0
 
zorvek (Kevin Jones)ConsultantCommented:
See this article for how to repair Excel 2010.

Title: Update, repair, or uninstall Office Click-to-Run products
Link: http://office.microsoft.com/en-us/excel-help/update-repair-or-uninstall-office-click-to-run-products-HA010382089.aspx

Kevin
0
 
JazCatAuthor Commented:
I do not seem to have the permissions required to perform the repair. The only option I have is to uninstall Office.
0
 
zorvek (Kevin Jones)ConsultantCommented:
Then get the admin person to do the repair for you. If you can't repair you probably can't install either.

Kevin
0
 
JazCatAuthor Commented:
So you believe this is a problem with Excel and not the way Excel 2010 works? I asked a couple co-workers, theirs do the same thing but since they never open spreadsheets except via the File - Open command they don't see it as a problem.
0
 
JazCatConnect With a Mentor Author Commented:
I am closing this as a Partial Fix. Although zorvek's responses did not resolve the problem I got enough info to be able to return the laptop to my corporate Help Desk for a reimage and they are going to look into the problem while it is there.
0
 
JazCatAuthor Commented:
Half points because I am unable to verify the solution as I do not have admin privileges on my laptop. Very detailed response though.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.