Batch file set to run when RDP connection is made quit working

I have 10 kiosks running Windows XP that connect to a TS server which runs an app on another Windows Server 2003 that is local to the TS server. In "Start the following program on connection" box I have the name of a simple batch file that runs a Visual FoxPro app that resides on the server. This has worked fine for several years now, on Tuesday it quit working. I have tried everything, including rebooting every machine in the equation and checking every setting that I set up initially but no luck.

I am stuck, how do I fix this?

time.bat
 
F:
cd \vocshop\TIMECLOCK
timeclock.exe

Open in new window

LVL 9
Bob StoneIT GuruAsked:
Who is Participating?
 
mwochnickConnect With a Mentor Commented:
two questions I'd ask - maybe a little obvious
1. what changed? did a security patch get applied, etc?
2. is timeclock.exe still there and can you run it manually?
I guess that's four questions :)
0
 
Bob StoneIT GuruAuthor Commented:
Last 2 updates were on the 10th and yesterday, none before that for about a month. The problem started on the 15th.

 On the 10th was a Windows Malicious software removal tool and the 16th was this;
Update for Windows Server 2003 (KB971029)
Install this update to restrict AutoRun entries in the AutoPlay dialog to only CD and DVD drives.

I can run timeclock.exe manually and I can run the time.bat file via Task Manager once the connection is made (which loads to blank screen). It just won't do it automatically anymore.
0
 
arnoldConnect With a Mentor Commented:
Any reason you do not run f:\vocshop\TIMECLOCK\timeclock.exe directly rather than running a batch file?

0
Introducing Cloud Class® training courses

Tech changes fast. You can learn faster. That’s why we’re bringing professional training courses to Experts Exchange. With a subscription, you can access all the Cloud Class® courses to expand your education, prep for certifications, and get top-notch instructions.

 
ydsonlineCommented:
You could also try the following:
Change the account privileges of both the batch file and timeclock.exe to "Allow non-administrators to run this program" (Setting is under the right click option of each file > Properties > Compatibility Tab)

arnold does have a point, the timeclock.exe should be able to run without a batch file?
0
 
Bob StoneIT GuruAuthor Commented:
When I try to run it directly I get some garbage about there being a time / date difference between the server and the client, but all of them show the same time and date.
0
 
arnoldCommented:
The other option is to add the shortcut to the timeclock into the startup for all users
%allusersprofile%\Start Menu\Programs\Startup
Whenever a user logs in, this application will run.
This way you do not need to rely on the parameter to start the following program within the RDP from being disabled by the user.
0
 
arnoldCommented:
Check the timezone.
0
 
mwochnickCommented:
do you control security policies on these servers or does someone else?
0
 
Bob StoneIT GuruAuthor Commented:
Time zones are all the same.

I control the security policies, but being the only one in the IT department I don't mess with them unless I have to.
0
 
Bob StoneIT GuruAuthor Commented:
OK figured out what the problem was. The server where timeclock.exe resides was way out of date on updates. Spent several hours updating it to most current, then fixed auto updating thing. Odd that it was pulling some updates, but only really minor ones.

Now the batch file runs just like it is supposed to and always did prior, maybe a little faster now is all. :)
0
 
Bob StoneIT GuruAuthor Commented:
Thanks
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.