Access a mysql db from another computer.

I have a linux server running mysql 5.1.49 on a network @ work.

I want to use Navicat, a dbms on another computer.

I can manage the database locally, how can I manage that db from another computer, using something like phpMyAdmin or Navicat ??
LVL 1
ImaginxAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
upanwarConnect With a Mentor Commented:
If the link have worked and your issue has been fixed then no need to do anything.

I was just checking whether mysql is running on 3306 or not thats why I have asked for the output of # netstat -natp | grep 3306
0
 
dsmileCommented:
There're two ways to use phpMyAdmin
1. Install it on your db server and access it through the server public ip
Your server needs to have php & apache installed.
2. Install php on your computer and config it to access db sever through its public ip.
If you dont have an environment yet on your computer, you can use xampp or wamp server.

If you have navicat, use it to access db server through server's public ip .


One requirement for both public access way is to grant privileges for your local IP to access the server.
For mor info, just search google with keywords mysql, grant
0
 
ImaginxAuthor Commented:
That article may have the information I need, I'm just not sure that I'm understanding it...

(I have phpMyAdmin running on that server, I should have explained it better. NaviCat has some great import tools that are very useful for the project I'm currently on)

It seems as if GRANT just changes what the user account is allowed to do locally, or through a sql command.

Should the grant command be what I use to allow the administrator user account to log in 'remotely' per-se ... I'm using my mac laptop, and I'm not near the server (am on the same subnet) ...

Neither machine are joined to the local domain, just sharing the network ...

I can see the webserver from my laptop, but in navicat, when I use connection settings:
192.168.1.73:3306 - it can not connect. (3306 is the correct port)
0
Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

 
upanwarCommented:
By default mysql listen on Localhost so please follow this URL to enable remote connection to your mysql server.

http://www.cyberciti.biz/tips/how-do-i-enable-remote-access-to-mysql-database-server.html   
0
 
upanwarCommented:
show us the output of.

# netstat -natp | grep 3306


0
 
ImaginxAuthor Commented:
the link you posted worked,
is there something in # netstat -natp | grep 3306 I should be cautious of ??
because it doesn't seem to return anything (ran sudo)
0
 
ImaginxAuthor Commented:
That's what I figured the command was for ... wasn't sure though. Thanks for the help
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.