Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1301
  • Last Modified:

Distributed COM error, Windows Server 2008 (X64)

I am getting the following error in the log on one of our Windows 2008 Servers (X64):

From the General Tab:

The machine-default permission settings do not grant Local Activation permission for the COM Server application with CLSID
 to the user NT AUTHORITY\LOCAL SERVICE SID (S-1-5-19) from address LocalHost (Using LRPC). This security permission can be modified using the Component Services administrative tool.

From the Details Tab:

- System

  - Provider

   [ Name]  Microsoft-Windows-DistributedCOM
   [ Guid]  {1B562E86-B7AA-4131-BADC-B6F3A001407E}
   [ EventSourceName]  DCOM
  - EventID 10016

   [ Qualifiers]  49152
   Version 0
   Level 2
   Task 0
   Opcode 0
   Keywords 0x80000000000000
  - TimeCreated

   [ SystemTime]  2011-03-18T15:37:00.000Z
   EventRecordID 196918
  - Execution

   [ ProcessID]  0
   [ ThreadID]  0
   Channel System
   Computer our.server.name
  - Security

   [ UserID]  S-1-5-19

- EventData

  param1 machine-default
  param2 Local
  param3 Activation
  param4 {D2B7A809-15DC-40B4-A1E1-C61EA97191DB}
  param7 S-1-5-19
  param8 LocalHost (Using LRPC)

I have had a look in the Component Services MMC and cannot find {D2B7A809-15DC-40B4-A1E1-C61EA97191DB} and have searched the registry and cannot find it there either! Any idea guys?
  • 5
  • 2
1 Solution
Darius GhassemCommented:
Should be listed in the registry try looking again
-Juddy-Author Commented:
I used the search function in the registry, it couldn't find it.
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

-Juddy-Author Commented:
Ok, I'll look again after reading those sites.
-Juddy-Author Commented:
I can't see how they will help me with my current problem, the second link is for an SBS 2008 server running Sharepoint.
-Juddy-Author Commented:
Managed to solve the problem by Googling the CLSID; it was a problem with Sophos Anti Virus.  I re-installed the s/w and the error has gone; thanks for your help anyway.
-Juddy-Author Commented:

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 5
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now