• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 723
  • Last Modified:

Shadow Copy Client Not Showing all Previous Versions

I have a 2k3 server with a Shadow Copy protected volume; I have been monitoring it closely due to it not running smoothly recently.

Previously it was not using all the available storage to create as many snapshots as I would like.  I was thinking I may have resolved it... but now I'm not so sure.

The problem is that there are many shadow copies of the volume, but when I try to access any recent shadow copies (via the 'previous versions' tab), I am only seeing nine of the fourteen shadow copies that exist... the 5 that are missing are all the most recent snapshots.  

I know that the shadow copies ought to be there because they are listed within the "Shadow Copies" tab on the server - the 5 missing snapshots are listed as being created at the correct time, and there are no errors in the logs.  Furthermore, running a 'vssadmin list shadows' lists all 14 shadow copies with a unique GUID, and by running 'vssadmin list shadowstorage' I know that the 'Allocated Shadow Copy Storage' has grown to hold 14 snapshots. (Yes I have been monitoring it that closely).  Yet... from any client I am only seeing 9 snapshots.

Any ideas?
0
bllarson
Asked:
bllarson
  • 2
1 Solution
 
Jared LukerCommented:
This is a basic question, but since no one else has said anything...

Are you checking the previous versions tab of a particular file?  If the file has not changed, then it would not show up with a previous version.

If you are checking in that manner, then you need to make sure that it's a file that changes regularly between snapshots.  To be 100% sure, you could create a text file, and make a small change to it in between shadow copies.  That way, you should be able to look at the previous version of the text file and see all the times it's changed.
0
 
bllarsonAuthor Commented:
This issue was related to how MS DPM 2010 interacts with the local Shadow Copy Service.

I had to take MS DPM 2010 out of the equation, and which point the local VSS service started working according to expectation.
0
 
bllarsonAuthor Commented:
The issue was resolved. Prior input was not relevant.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now