Improve company productivity with a Business Account.Sign Up

x
?
Solved

Launching Crystal Reports from an ASP.NET Webpage

Posted on 2011-03-18
5
Medium Priority
?
383 Views
Last Modified: 2012-05-11
I developed an ASP.net application that works fine, then added some calls to crystal reports.  This works fine on a development box, either in debug mode or built/published to adevelopment box.  But when published to a non development box, the application works but anytime a crystal report is launched, I get a message "Load report failed." just like you get when it can't find the report.  The control boxes in the top of the viewer are X'd out and the report is blank.  Since this will run on a development box, I believe there are some runtime modules missing.  I've installed "CRRedist2008_x64" but no change.
0
Comment
Question by:tmark01
  • 2
  • 2
4 Comments
 
LVL 101

Expert Comment

by:mlmcc
ID: 35168230
Are you running on 64-bit machines?

Are you using CR2008?

If not what O/S and what version of Crystal?

mlmcc
0
 

Author Comment

by:tmark01
ID: 35243974
It will be deployed on a 64 bit 2008R2 server.  Right now, the development environment is on a XP machine.  On the XP development box, the only thing that is installed on this box, is Video Studio 2008, no crystal or anything.  On this development box, it works perfectly in debug mode or after being built and IIS turned on.  Runs both CR11 and CR8.5 reports flawlessly.  On other boxes, any version of crystal report just gives you a blank viewer, and the box controls are x'd out with button pictures missing.  So Video studio 2008 installation put something on the box that makes it work.
0
 
LVL 101

Accepted Solution

by:
mlmcc earned 2000 total points
ID: 35244063
I doubt CR8.5 will run on 64-bit Windows.

The Red X's are usually caused by missing files or permissions
http://www.sdn.sap.com/irj/boc/go/portal/prtroot/docs/library/uuid/50aa68c0-82dd-2b10-42bf-e5502b45cd3a?QuickLink=index&overridelayout=true

mlmcc
0
 

Author Closing Comment

by:tmark01
ID: 35297017
It was from missing files, had to uninstall and re-install the run time distributable for some reason.
0

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Problem Hi all,    While many today have fast Internet connection, there are many still who do not, or are connecting through devices with a slower connect, so light web pages and fast load times are still popular.    If your ASP.NET page …
There have always been a lot of questions related to when Crystal Reports evaluates report components (such as formulas, summaries, cross-tabs, charts, to name a few examples). Crystal Reports uses a two-pass reporting process to provide greater …
Free Data Recovery software is an advanced solution from Kernel Tools to recover data and files such as documents, emails, database, media and pictures, etc. It supports recovery from physical & logical drive after a hard disk crash, accidental/inte…
Through the video, you can check the migration process of Outlook PST file to PDF. Kernel for Outlook to PDF tool can convert Outlook emails with all attributes like Subject, To, From, Cc, Bcc and other folders such as Inbox, Outbox, Sent Items, Jun…

607 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question