Solved

Launching Crystal Reports from an ASP.NET Webpage

Posted on 2011-03-18
5
357 Views
Last Modified: 2012-05-11
I developed an ASP.net application that works fine, then added some calls to crystal reports.  This works fine on a development box, either in debug mode or built/published to adevelopment box.  But when published to a non development box, the application works but anytime a crystal report is launched, I get a message "Load report failed." just like you get when it can't find the report.  The control boxes in the top of the viewer are X'd out and the report is blank.  Since this will run on a development box, I believe there are some runtime modules missing.  I've installed "CRRedist2008_x64" but no change.
0
Comment
Question by:tmark01
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
5 Comments
 
LVL 100

Expert Comment

by:mlmcc
ID: 35168230
Are you running on 64-bit machines?

Are you using CR2008?

If not what O/S and what version of Crystal?

mlmcc
0
 

Author Comment

by:tmark01
ID: 35243974
It will be deployed on a 64 bit 2008R2 server.  Right now, the development environment is on a XP machine.  On the XP development box, the only thing that is installed on this box, is Video Studio 2008, no crystal or anything.  On this development box, it works perfectly in debug mode or after being built and IIS turned on.  Runs both CR11 and CR8.5 reports flawlessly.  On other boxes, any version of crystal report just gives you a blank viewer, and the box controls are x'd out with button pictures missing.  So Video studio 2008 installation put something on the box that makes it work.
0
 
LVL 100

Accepted Solution

by:
mlmcc earned 500 total points
ID: 35244063
I doubt CR8.5 will run on 64-bit Windows.

The Red X's are usually caused by missing files or permissions
http://www.sdn.sap.com/irj/boc/go/portal/prtroot/docs/library/uuid/50aa68c0-82dd-2b10-42bf-e5502b45cd3a?QuickLink=index&overridelayout=true

mlmcc
0
 

Author Closing Comment

by:tmark01
ID: 35297017
It was from missing files, had to uninstall and re-install the run time distributable for some reason.
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
asp.net web app 3 57
sql views 3 55
Left aligned $ and right aligned amount ASP.NET 7 41
async questions 5 48
In .NET 2.0, Microsoft introduced the Web Site.  This was the default way to create a web Project in Visual Studio 2005.  In Visual Studio 2008, the Web Application has been restored as the default web Project in Visual Studio/.NET 3.x The Web Si…
International Data Corporation (IDC) prognosticates that before the current the year gets over disbursing on IT framework products to be sent in cloud environs will be $37.1B.
In a recent question (https://www.experts-exchange.com/questions/29004105/Run-AutoHotkey-script-directly-from-Notepad.html) here at Experts Exchange, a member asked how to run an AutoHotkey script (.AHK) directly from Notepad++ (aka NPP). This video…
Attackers love to prey on accounts that have privileges. Reducing privileged accounts and protecting privileged accounts therefore is paramount. Users, groups, and service accounts need to be protected to help protect the entire Active Directory …
Suggested Courses

739 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question