Use "Open With" on the right-click context menu to open web desktop shortcuts

Hello,

My agency uses Google Apps Education for Email and, therefore, the default web browser has to be Google Chrome.  Our city, state, and federal funders have come up with these cloud applications that lose functionality unless they're opened in Internet Explorer.  I've placed shortcuts on user desktops but, of course when clicked, they open in Chrome.  I'd like to right-click on these desktop web shortcuts and see the "Open With" option so that users could choose Internet Explorer (or a different browser other than the Chrome default).

Thank you.
andraLedwardsAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
Dave BaldwinConnect With a Mentor Fixer of ProblemsCommented:
You can use the shortcut method I found.  I did it differently than you did.  Here's a pic to show what I did:
IE-shortcut.jpg
0
 
BCipolloneCommented:
Why not create a shortcut that goes to iexplore.exe instead.

C:\Program Files\Internet Explroer\iexplore.exe

right click it and create a shortcut

When you run that, not matter what the default browser is set to it will open Internet Explorer.
0
 
Dave BaldwinFixer of ProblemsCommented:
The internet links on my XP desktop have the "Open with..." line so I can do that.  ??
0
Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

 
andraLedwardsAuthor Commented:
O.K.

I created the iexplorer shortcut.  Then I right-clicked and tried to create another shortcut which it pasted onto the desktop immediately as a 2nd IE shortcut. I then went to the Properties of the 2nd shortcut and tried putting the URL in the target address box while leaving the IE path in the Start In field.

Doesn't work.
0
 
andraLedwardsAuthor Commented:
I've just checked again.  The internet links on my user desktops do not have the "open with" option.  I did a Registry hack (HKEY_CLASSES_ROOT\*\SHELL...) that added the Open With option to all of my files, but not to the desktop website URLs.
0
 
Dave BaldwinFixer of ProblemsCommented:
My mistake, the link I checked was an HTML file but it was on my computer.  The Internet links don't have that option.  sorry.
0
 
DIIRECommented:
Change the .URL extension to open with Internet Explorer and leave http and https to open with chrome.  

That only .url will open with IE and any urls in email attachments etc will still open with chrome.
0
 
Dave BaldwinFixer of ProblemsCommented:
Ok, I now have a shortcut to IE8 on my desktop that takes me straight to Yahoo.  I made a copy of the shortcut for IE8 and added the web site after the program name like this on the Shortcut tab in Target:


"C:\Program Files\Internet Explorer\iexplore.exe" "www.yahoo.com"
0
 
FireW0lfCommented:
"I've just checked again.  The internet links on my user desktops do not have the "open with" option.  I did a Registry hack (HKEY_CLASSES_ROOT\*\SHELL...) that added the Open With option to all of my files, but not to the desktop website URLs"

Yes, because you put the Reg hack into HKEY_CLASSES_ROOT\* - * means "all files"

Just change it and put it into HKEY_CLASSES_ROOT\InternetShortcut - now they'll have the "Open With" just for their .url shortcuts
0
 
andraLedwardsAuthor Commented:
My apologies for being momentarily distracted with a few other problems.

I tried what FireWolf suggested.  After figuring out how to take temporary ownership of of the Registry, I did the following:

1.  Go to HKEY_CLASSES_ROOT\InternetShortcut\Shell
3. Add a new Key named "OpenWith" by right clicking the "Shell" Key and selecting new
4. Set the (Default) to "Open With..."
5. Add a new Key named "Command" by right clicking the "OpenWith" Key and selecting new
6. Set the (Default) to "C:\Windows\rundll32.exe shell32.dll,OpenAs_RunDLL %1", C:\ being your Windows drive. You must enter the "OpenAs_RunDLL %1" exactly this way.

As I've said, this worked for files, but still does nothing for .url shortcuts.  Perhaps my Command Key default value is incorrect.

I sincerely appreciate all of your suggestions.
0
 
FireW0lfCommented:
Your reg entry is right, but the Command is wrong

Here is my Command for you to put in your "Open With..."

"C:\Windows\System32\rundll32.exe" "C:\Windows\System32\ieframe.dll",OpenURL %l

It works fine :-)
0
 
FireW0lfCommented:
My solution works, and is what the question asked for :)
0
 
MikeIT ProfessionalCommented:
This question has been classified as abandoned and is closed as part of the Cleanup Program. See the recommendation for more details.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.