Solved

Cisco 871 and multiple VLAN HRSP or VRRP

Posted on 2011-03-18
3
1,015 Views
Last Modified: 2012-05-11
I would like to configure HSRP or VRRP between a Cisco1841 router and a Cisco871.  

I have three different scenarios:

Three networks on the same interface (using secondary addressing)

Three VLANs using subinterfaces on the Cisco1841

Three Networks - Two on the fa0/0 as primary/secondary, One on fa0/1.

-
So if the networks are

10.0.1.0/24
10.0.2.0/24
10.0.3.0/24

How would HSRP or VRRP be configured in these scenarios to have all traffic failover.  I understand there are some limitations to the 871 series.  I have advanced IP feature set on both.
0
Comment
Question by:salesandservice
3 Comments
 
LVL 45

Accepted Solution

by:
Craig Beck earned 500 total points
ID: 35181325
On the same interface, create separate HSRP groups on the interface on each router for each IP range.

For example, on the 1841...

int vlan1
ip address 10.0.1.2 255.255.255.0
ip address 10.0.2.2 255.255.255.0 secondary
ip address 10.0.3.2 255.255.255.0 secondary
standby 1 ip 10.0.1.1
standby 2 ip 10.0.2.1
standby 3 ip 10.0.3.1
exit

and on the 871...

int vlan1
ip address 10.0.1.3 255.255.255.0
ip address 10.0.2.3 255.255.255.0 secondary
ip address 10.0.3.3 255.255.255.0 secondary
standby 1 ip 10.0.1.1
standby 2 ip 10.0.2.1
standby 3 ip 10.0.3.1
exit




Using sub-interfaces (1841)....

int fa0.1
ip address 10.0.1.2 255.255.255.0
standby 1 ip 10.0.1.1
exit
int fa0.2
ip address 10.0.2.2 255.255.255.0
standby 2 ip 10.0.2.1
exit
int fa0.3
ip address 10.0.3.2 255.255.255.0
standby 3 ip 10.0.3.1
exit

and on the 871...

int fa0.1
ip address 10.0.1.3 255.255.255.0
standby 1 ip 10.0.1.1
exit
int fa0.2
ip address 10.0.2.3 255.255.255.0
standby 2 ip 10.0.2.1
exit
int fa0.3
ip address 10.0.3.3 255.255.255.0
standby 3 ip 10.0.3.1
exit
0
 
LVL 68

Expert Comment

by:Qlemo
ID: 35422481
This question has been classified as abandoned and is closed as part of the Cleanup Program. See the recommendation for more details.
0

Featured Post

Network it in WD Red

There's an industry-leading WD Red drive for every compatible NAS system to help fulfill your data storage needs. With drives up to 8TB, WD Red offers a wide array of solutions for customers looking to build the biggest, best-performing NAS storage solution.  

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Redirect mail server from IP to IP 2 90
Connecting APC UPS 2200 via serial port 3 81
Native Vlans, Tagged & untagged annnd Trunks 6 45
Layer 2 versus layer 3 10 48
SSL is a very common protocol used these days when browsing the web.  The purpose is to provide security to communication, but how does it do it?  There are several pieces at work that have to be setup before SSL will even work and it requires both …
We recently endured a series of broadcast storms that caused our ISP to shut us down for brief periods of time. After going through a multitude of tests, we determined that the issue was related to Intel NIC drivers on some new HP desktop computers …
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

911 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

23 Experts available now in Live!

Get 1:1 Help Now