Solved

how to get IM+ on the iphone to work with an Openfire server?

Posted on 2011-03-18
14
4,571 Views
Last Modified: 2013-01-15
We just implemented Spark and Openfire for our company's IM solution. Now we want people with smart phones to be able to use it too. We chose IM+ because it's free, and it supports iphone + blackberry.

We've tried it on our phones with all the settings entered but it doesn't seem to connect. do we need to make changes on the server side for this to work? Please advice. Thanks.
0
Comment
Question by:schang626
  • 8
  • 6
14 Comments
 
LVL 1

Author Comment

by:schang626
ID: 35169502
i installed the desktop version of IM+ on my laptop and it's not working too. Is it my settings?
0
 
LVL 4

Expert Comment

by:booster49
ID: 35179832
IM+ Doesnt have full native XMPP support. The best alternative for iphone is oneteam
0
 
LVL 1

Author Comment

by:schang626
ID: 35182309
I've seen people got their IM+ working with Openfire. IM+ is free but oneteam is like $5 per download. We don't really need something fancy, as long as we can send messages that's all it matters. thanks.
0
U.S. Department of Agriculture and Acronis Access

With the new era of mobile computing, smartphones and tablets, wireless communications and cloud services, the USDA sought to take advantage of a mobilized workforce and the blurring lines between personal and corporate computing resources.

 
LVL 4

Expert Comment

by:booster49
ID: 35182408
Try checkin if monal does work to see if the error is related to EM+ or server sided settings.
0
 
LVL 1

Author Comment

by:schang626
ID: 35182591
Monal doesn't work neither. it says connection error. maybe i'm missing something here.
here are the settings:

Jabber ID: ID@CompanyName.com
Password: password
Enabled: On
Server: ServerName.CompanyName.com
Port: 5222
Resource: Monal
Use SSL: On

0
 
LVL 4

Expert Comment

by:booster49
ID: 35187152
Have you tried connecting to the server via LAN? Could be a firewall issue check if ports 5222, 5223, 5269, and 8010 are forwarded.
0
 
LVL 1

Author Comment

by:schang626
ID: 35194477
i've installed IM+ desktop version on my laptop which is on the same subnet as the Openfire server. when i enter myID@CompanyName.com i get "Connection Failed". When i enter myID, i get "Authorization failed, please check your username/password".
0
 
LVL 4

Expert Comment

by:booster49
ID: 35196735
Are you running openfire on Windows or Linux/Unix?
And could you please post openfires errorlog?
0
 
LVL 1

Author Comment

by:schang626
ID: 35201662
Here's the log.

I've replaced my login name to ID and my company address to CompanyName.comd
log.txt
0
 
LVL 1

Author Comment

by:schang626
ID: 35201668
im running openfire on windows
0
 
LVL 4

Expert Comment

by:booster49
ID: 35202859
Have you tried logging in without SSL? (PLAIN)

Your server seems to be setup correctly.

Are you planning to use SSL, and did you set up the server to use SSL?
http://www.igniterealtime.org/builds/openfire/docs/latest/documentation/ssl-guide.html

Are you using LDAP or the openfire account system?
0
 
LVL 1

Author Comment

by:schang626
ID: 35203492
Yes i tried logging in without SSL but i got the same error message.

I can use spark to login no problem so i dont think it has something to do with SSL.

i checked the server settings and the xmpp.domain = the server name. should i change it to CompanyName.com?

0
 
LVL 1

Author Comment

by:schang626
ID: 35203493
im using LDAP
0
 
LVL 4

Accepted Solution

by:
booster49 earned 500 total points
ID: 35205243
xmpp.domain = domain.com

To rename you'll have to re-run the setup tool: (might be easier to reinstall)

    First go to the Admin Console > Server > Server Properties
    Find the Property Name: admin.authorizedJIDs
    You'll see a list of users of the form user@server.domain.com. Edit the value so it has the same admin users as before but also ensure that the user admin@domain.com is also present or you won't be able to logon to your server after renaming it.
    Stop Openfire.
    Edit conf/openfire.xml in your Openfire installation folder and set <setup>true</setup> to <setup>false</setup>.
    Start the server and navigate to http://server:9090 to rerun the setup. Ensure the new Server Name matches the domain name eg. example.com
    Make sure Server Name is domain.com and NOT server.domain.com
    Once the server is running go to the Admin Console > Server > Server Settings > Server Certificates
    Delete any certificates belonging to the old domain.
    If no certificates now exist regenerate them.

 

If you added your admin to the admin list successfully you should be able to logon. If not you can reset it manually in the database. An example for MySQL:

        mysql -h localhost -u root -p PASSWORD gtms

        REPLACE ofProperty VALUES('admin.authorizedJIDs','admin@example.com');
0

Featured Post

Ransomware-A Revenue Bonanza for Service Providers

Ransomware – malware that gets on your customers’ computers, encrypts their data, and extorts a hefty ransom for the decryption keys – is a surging new threat.  The purpose of this eBook is to educate the reader about ransomware attacks.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Short answer to this question: there is no effective WiFi manager in iOS devices as seen in Windows WiFi or Macbook OSx WiFi management, but this article will try and provide some amicable solutions to better suite your needs.
Email is way too noisy, prone to hiding the important stuff, and really becoming unreliable for critical/timely communications. There are better ways to communicate.
Viewers will learn how to use the Hootsuite Dashboard.
An overview on how to enroll an hourly employee into the employee database and how to give them access into the clock in terminal.

860 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question