• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 420
  • Last Modified:

Query Syntax

okay someone wake me up here

I am making a simple query  VB.NET access DB  

SELECT ID, LN, FN,  Date_active FROM Clients
WHERE Date_active >=   ?
ORDER BY  LN


in my VB code i am biding it to a datetimepicker

 Private Sub DateTimePicker1_ValueChanged(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles DateTimePicker1.ValueChanged
       
Dim Date_active As Date = DateTimePicker1.Value

        MembersTableAdapter.Fill(DsDataset.Clients, _
                                 Date_Active)
End Sub

When I run it its showing all the records   > ?          but NOT records  = ?  

much appreciated easy 2000 pts  

0
plusone3055
Asked:
plusone3055
1 Solution
 
Jerry MillerCommented:
Are you sure that you have equal records? I mean down to the seconds? You could be comparing March 18, 2011 10:00:00 to March 18, 2011 10:00:01 and all you are seeing is March 18, 2011.
0
 
plusone3055Author Commented:
no the dates in the table are like 2/14/2011 not time
so I put  2/14/2011  in my datetimepicker (which is set to short)
and as stated before it display all records  > 2/14/2011   but not = 2/14/2011  

0
 
OP_ZaharinCommented:
i suggest you to put a format to the date in your sql statement
different database handles date format differently.

for Sql Server it will look like this:
SELECT ID, LN, FN,  Date_active FROM Clients where Convert(varchar,Date_Active,103) >= ?

'103' is DD/MM/YYYY format, you can use other date formatting that you desired.
0
Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
plusone3055Author Commented:
figured it out time format was wrong in the database
0
 
OP_ZaharinCommented:
its the default date format that the database handles which you can change the default date setting based on what database you are using. another solution is to set a date format in your sql query as I suggested.
0
 
plusone3055Author Commented:
sorry i thought i could reopen to give out poitns and its giving me **** about that really sorry ive never had a problem aewarding points to anyone :(
0
 
OP_ZaharinCommented:
i think my suggestion works for the author problems.
0
 
SharathData EngineerCommented:
try DATEVALUE to truncate the time part.
SELECT ID, LN, FN,  Date_active FROM Clients
WHERE DATEVALUE(Date_active) >=   ?
ORDER BY  LN

Open in new window

0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now