Solved

how to prevent word wrap on command line in unix

Posted on 2011-03-18
8
1,066 Views
Last Modified: 2013-12-16
I would like to know the parameter that should go into .Xdefaults file that prevents word wrap on a command line on Linux Redhat.
0
Comment
Question by:monocacy570
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
8 Comments
 

Author Comment

by:monocacy570
ID: 35169939
would like to know the syntax that should go into .Xdefaults file that would prevents word wrap on a command line on Linux Redhat
0
 
LVL 9

Expert Comment

by:svs
ID: 35181151
This doesn't make sense.  "command line" is normally provided by shell (/bin/sh and the like), but shells are not configured via .Xdefaults.

More details, please?
0
 

Author Comment

by:monocacy570
ID: 35181986
svs, your point is noted and therefore the question should be asked like this:  how do I prevent word wrap from occuring at the 80 character limit on a command line?
0
Optimize your web performance

What's in the eBook?
- Full list of reasons for poor performance
- Ultimate measures to speed things up
- Primary web monitoring types
- KPIs you should be monitoring in order to increase your ROI

 
LVL 9

Expert Comment

by:svs
ID: 35182320
I've seen this happen, but do not recall in which shell and which OS.  sorry.
0
 
LVL 62

Expert Comment

by:gheist
ID: 35188016
.Xdefaults has no influence on word wrapping.

bash input is controlled by ~/.inputrc /etc/inputrc

i suspect wrapping at :80 happens because of a wrong TERM setting
0
 
LVL 4

Accepted Solution

by:
m_walker earned 250 total points
ID: 35188306
Are you talking about the terminal window under xwindows or from a remote terminal eg: putty.

The way I see it is you can change the line length with the stty command
eg:  stty cols 120
But, the terminal program may notice the line "needs" to be wrapped.  As such you would need to check the settings for the terminal app.

The terminal program must do something with the data, so it could just drop the exta data (trunc it) or store in a buffer and add a scroll bar.
0
 
LVL 19

Expert Comment

by:jools
ID: 35281662
have you tried not typing in anything bigger than 80 chars?
0
 

Author Closing Comment

by:monocacy570
ID: 35396711
Thanks to all who responded.
0

Featured Post

Get 15 Days FREE Full-Featured Trial

Benefit from a mission critical IT monitoring with Monitis Premium or get it FREE for your entry level monitoring needs.
-Over 200,000 users
-More than 300,000 websites monitored
-Used in 197 countries
-Recommended by 98% of users

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Hello fellow BSD lovers, I've created a patch process for patching openjdk6 for BSD (FreeBSD specifically), although I tried to keep all BSD versions in mind when creating my patch. Welcome to OpenJDK6 on BSD First let me start with a little …
When you do backups in the Solaris Operating System, the file system must be inactive. Otherwise, the output may be inconsistent. A file system is inactive when it's unmounted or it's write-locked by the operating system. Although the fssnap utility…
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…
Suggested Courses

630 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question