• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2087
  • Last Modified:

Comcast Business Modem 5 static IPs and Sonicwall TZ 210. Very slow internet speed

Just got Comcast Cable service from a DSL service. I should be seeing a faster increase of speed but the service is very slow. Yet the reports that I bring up from a webpage speed test show 25-30mb down and 8-10mb up. Nothing on the sonicwall should be changed except for the new static IP address, GW, and DNS. I disabled the DHCP and firewall on the modem. Is there something I am missing? When I had the DHCP on, on the modem and plugged a laptop in, the speed was good clicking through websites.

Is there something else I need to do on the modem or sonicwall?
0
calitech
Asked:
calitech
  • 6
  • 4
1 Solution
 
digitapCommented:
check the speed/duplex of the WAN interface. it's auto by default. try 100mb/full. also, review my article for setting MTU on the sonicwall appliance and see if your MTU needs to be adjusted.

http://www.experts-exchange.com/viewArticle.jsp?articleID=3110
0
 
calitechAuthor Commented:
that is a great article. I did change the MTU to 1460 for that was the first one that went through. My speeds are still the same. speakeasy test shows 3-4MB down when it should be 20mb+
anything else I can change on the sonicwall?
0
 
calitechAuthor Commented:
I have the server plugged into the x0 port and the switch plugged into one of the x2-x5 slots, is that correct?
the server being SBS2003 with DHCP on it.
0
Protect Your Employees from Wi-Fi Threats

As Wi-Fi growth and popularity continues to climb, not everyone understands the risks that come with connecting to public Wi-Fi or even offering Wi-Fi to employees, visitors and guests. Download the resource kit to make sure your safe wherever business takes you!

 
digitapCommented:
glad you liked the article. you should go back and click 'yes' that the article helped you.

typically, you only need to plug your switch into port x0 and everything else plugs into the switch. but, you can use the other ports as a switch for the lan zone.

did you confirm the speed duplex of the wan interface? auto is default and you should try 100mb/full.
0
 
calitechAuthor Commented:
Yes i changed it to 100 full no difference
0
 
digitapCommented:
are you at the latest firmware? i think the latest is 5.8.
0
 
calitechAuthor Commented:
yes I have the latest
0
 
calitechAuthor Commented:
Speed test with the linksys showed 20MB+ but going to different pages take forever and I can't get to yahoo.com right now but I can ping it. I think I might be a service related issue with Comcast.
0
 
digitapCommented:
possibly. do the pages eventually load? take a look at the following and see if it does anything to clear it up...incidentally, when you test connectivity to yahoo, are you also logged onto the sonicwall management console from the same computer you are testing yahoo.com from?

Try unchecking "Enforce Host Tag Search for CFS" in the diag page. In some scenarios, the HTTP header exceeds the MSS and gets split into two packets, and the host tag is in the second packet. In this scenario the sonicwall will drop first packet and wait until the client sends the second packet, which contains the host tag. Once it receives this packet, it will wait for the client to resend the first packet. Some HTTP clients do not follow RFC 1323 (TCP windows, "fill the pipe") and they do not send the second packet until they get the ACK for the first packet, which the sonicwall will not do if the HTTP Host Tag option is enabled.
0
 
calitechAuthor Commented:
I have to set both the comcast modem and the sonicwall router to auto and that solved the issue.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 6
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now