Solved

How to setup multiple DSL modems to different ISPs on Cisco 3660

Posted on 2011-03-19
7
506 Views
Last Modified: 2013-12-27
I need to connect 4 DSL modems to 3660 via ethernet. Have 1 0/22 lan segment and then ,  of course, different ISPs

Further requirement is to point traffic by IP out certaint DSL connections which should be easy.
When I connect a second DSL to the router  the traffic stops and the ping time increase from 100ms to >700ms, obviously a loop has been created

The modems are connected via ethernet on different 192.168.x.x /30 segments..
Any ideas on the best way to proceed??

Thanks
0
Comment
Question by:voretl
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 2
7 Comments
 

Author Comment

by:voretl
ID: 35172355
added more zones to get some help
0
 
LVL 24

Expert Comment

by:rfc1180
ID: 35172811
Can you post your config?
0
 

Author Comment

by:voretl
ID: 35175280
name xxxxxx
!
boot-start-marker
boot-end-marker
!
enable password 5117711
!
no aaa new-model
!
!
no ip cef
ip domain timeout 1
ip domain name 99k.org
ip name-server 8.8.8.8
ip name-server 208.67.222.222
!
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 192.168.100.199 255.255.252.0
 ip nat inside
 ip virtual-reassembly
 duplex auto
 speed auto
 no cdp enable
!
interface FastEthernet0/1
 ip address 192.168.10.2 255.255.255.0
 ip accounting output-packets
 ip nat outside
 ip virtual-reassembly
 duplex auto
 speed auto
 no cdp enable
!
interface FastEthernet2/0
 ip address 192.168.20.2 255.255.255.0
 ip nat outside
 ip virtual-reassembly
 duplex auto
 speed auto
 no cdp enable
!
interface FastEthernet2/1
 ip address 192.168.30.2 255.255.255.0
 ip nat outside
 ip virtual-reassembly
 duplex auto
 speed auto
 no cdp enable
!
interface Ethernet3/0
 no ip address
 shutdown
 half-duplex
!
interface Ethernet3/1
 no ip address
 shutdown
 half-duplex
!
interface FastEthernet4/0
 ip address 192.168.40.2 255.255.255.0
 ip nat outside
 ip virtual-reassembly
 duplex auto
 speed auto
 no cdp enable
!
interface Serial4/0
 description VPN
 no ip address
 encapsulation frame-relay IETF
!
interface Serial4/0.1 point-to-point
 ip address 10.212.249.242 255.255.255.252
 ip access-group 101 out
 snmp trap link-status
 frame-relay interface-dlci 410
!
interface FastEthernet4/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
no ip http server
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 192.168.10.1
ip route 8.8.8.8 255.255.255.255 192.168.10.1
ip route 58.71.1.38 255.255.255.255 192.168.40.1
ip route 58.71.2.8 255.255.255.255 192.168.40.1
ip route 123.242.0.0 255.255.0.0 192.168.20.1
ip route 125.5.0.0 255.255.0.0 192.168.20.1
ip route 192.168.1.0 255.255.255.0 10.212.249.241
ip route 202.57.0.0 255.255.0.0 192.168.10.1
ip route 208.43.0.0 255.255.0.0 192.168.30.1
!
ip dns server
!
ip nat inside source list 111 interface FastEthernet4/0 overload
!
access-list 101 deny   ip host 192.168.101.100 host 192.168.1.100
access-list 101 permit ip any any
access-list 111 permit ip 192.168.100.0 0.0.3.0 any
snmp-server community public RO
!
!
!
This is my basic config... I was not sure which mechanism to use nor how to begin setting this up. The 4 DSL modems do have bridging options in them, but not sure what the advantage would be over the ethernet version. Each lan side of the modem is connected to an ethernet port and assigned a private address.

Thanks
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 24

Expert Comment

by:rfc1180
ID: 35176075
Add these lines to your config:

ip nat inside source route-map isp1 interface fast0/1 overload
ip nat inside source route-map isp2 interface fast2/0 overload
ip nat inside source route-map isp3 interface fast2/1 overload
ip nat inside source route-map isp4 interface fast4/0 overload

route-map isp1 permit 10
 match ip address 111
 match interface fast0/1
!
route-map isp2 permit 10
 match ip address 111
 match interface fast2/0

route-map isp3 permit 10
 match ip address 111
 match interface fast2/1
!
route-map isp4 permit 10
 match ip address 111
 match interface fast4/0

-----

Remove this line as it is no longer required:
'ip nat inside source list 111 interface FastEthernet4/0 overload'

no ip nat inside source list 111 interface FastEthernet4/0 overload

Billy
0
 

Author Comment

by:voretl
ID: 35177352
Thanks,, I'll give it a shot and get back to you quickly...

Thanks again
0
 

Accepted Solution

by:
voretl earned 0 total points
ID: 35196435
OK,,,

I set this up added the lines and deleted the one line.  I tried this on a couple of routers and just put up 4 serial interfaces as a test.. I was able to ping the far end rounter loopback and the packets would return on the correct interfaces. What is a little confusing is that when I used the /22 Lan network, there are no ip nat stats, when i convert the LAN to a /24, the pings from that lan stiill work and now I'm getting the nat info, than i'm used to seeing. I assume there is something else I need to do to get the stats with the /22 lan network?
Thank you
0
 

Author Closing Comment

by:voretl
ID: 35252842
I had a follow up question which kinda got dropped, so I submitted a second question, which got answered very quickly.
0

Featured Post

Connect further...control easier

With the ATEN CE624, you can now enjoy a high-quality visual experience powered by HDBaseT technology and the convenience of a single Cat6 cable to transmit uncompressed video with zero latency and multi-streaming for dual-view applications where remote access is required.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
ACL deny / Permit 10 56
Guest Wireless in a Business Environment 6 150
TL-R470T+ and Cisco ASA 2 49
Configure 2 Servers with Crossover cable 3 46
The Cisco RV042 router is a popular small network interfacing device that is often used as an internet gateway. Network administrators need to get at the management interface to make settings, change passwords, etc. This access is generally done usi…
In the world of WAN, QoS is a pretty important topic for most, if not all, networks. Some WAN technologies have QoS mechanisms built in, but others, such as some L2 WAN's, don't have QoS control in the provider cloud.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

710 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question