[Last Call] Learn about multicloud storage options and how to improve your company's cloud strategy. Register Now

x
?
Solved

When I create a rule, "on this machine only" gets checked automatically.

Posted on 2011-03-19
14
Medium Priority
?
541 Views
Last Modified: 2012-06-27
When I create a rule in Microsoft Outlook, "on this machine only" gets checked automatically. How do I change this behavior ?
0
Comment
Question by:thenelson
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 7
  • 6
14 Comments
 
LVL 6

Expert Comment

by:Tonypeswani
ID: 35171462
On this machine only" is automatically applied by Outlook software, when you generate a rule, because - as I understand it - rules (from Outlook 2002 on?) can be for application on the Exchange Server or on a specific computer and you just generated the rule on a specific computer. Later on, in your case, you changed the computer or system-configuration and so the rule will no longer work on that computer/configuration, as it thinks it is on a different "machine".

For those of us who are not using an Exchange Server, the annoying thing is how the automatic application of the phrase, "on this machine only", is done by Microsoft when you generate a rule. When you get the last piece of the rule in place at the end of the rule, and click on "Next", _then_ the phrase "on this machine only" automatically pops up into the _middle_ of the rule. When this happens, in our case, use the "Back" button to back up to the _first_ sub-window you originally encountered with a long list of items each headed by a check box. NOW the first item on that list will be "on this machine only" and its box will be checked!! (You are not going nuts, the item was NOT there the first time you came through, it was at the very bottom of the list and UNchecked!!) Uncheck it now and use the "Next" button to get back to where you were and finish up the rule generation to get a rule without the phrase "on this machine only". For a rule with that phrase already in it, Change/Edit it, and, at that same, first sub-window with a list with check boxes, you will now find the first item to be a checked, check box labeled "on this machine only". Proceed as above. If you have already gone to the new "machine", transferring rules that contained "on this machine only" on the original "machine", I believe the rule will now contain a phrase something like "on another machine" in its place, and you have to go in an uncheck that corresponding box.

0
 
LVL 59

Expert Comment

by:Chris Bottomley
ID: 35171482
ON this machine only is largely unimportant if using a pop/imap accounts since the setting is ignored.  It is however a default that you cannot change ... to the best of my knowledge.

Chris
0
 
LVL 39

Author Comment

by:thenelson
ID: 35171506
chris_bottomley,
"ON this machine only is largely unimportant if using a pop/imap accounts since the setting is ignored."
When On this Machine Only is checked the rule is not applied on my computer.

Tonypeswani,
That is exactly what is happening. I have to go back & uncheck the On this Machine Only checkbox. I am asking if this behavior can be turned off. Perhaps a macro could be created that unchecks the box whenever a rule is created?
0
Fill in the form and get your FREE NFR key NOW!

Veeam® is happy to provide a FREE NFR server license to certified engineers, trainers, and bloggers.  It allows for the non‑production use of Veeam Agent for Microsoft Windows. This license is valid for five workstations and two servers.

 
LVL 59

Expert Comment

by:Chris Bottomley
ID: 35171680
Okay, I have to take your statement as fact.  I'm not aware that there is an event to detect edit / reation of a rule ... might be possible to have a script that unsets it if set on any rule?

I'm looking out of interest but would it meet your needs here?

Chris
0
 
LVL 39

Author Comment

by:thenelson
ID: 35171704
A macro that unsets it on every rule would be useful. Could run the macro Outlook start.
0
 
LVL 39

Author Comment

by:thenelson
ID: 35171706
Could run the macro on Outlook start.
0
 
LVL 59

Expert Comment

by:Chris Bottomley
ID: 35171762
It seems that setting is read only ... am looking to see if I can find a method that enables it to be changed.

Chris
0
 
LVL 59

Accepted Solution

by:
Chris Bottomley earned 2000 total points
ID: 35171806
Haven't found a method at all.  The following returns a list of any rules that do not comply ... at least you get the chance to edit them!

Chris
Sub AnyMachine()
Dim olRules As Outlook.Rules
Dim olRule As Outlook.Rule
Dim strStatus As String

    Set olRules = Application.Session.DefaultStore.GetRules
    For Each olRule In olRules
        If olRule.IsLocalRule = True Then strStatus = strStatus & olRule.name & vbCrLf
    Next
    olRules.Save
    If strStatus <> "" Then
        MsgBox "Following outlook Rules are this Machine only:" & vbCrLf & vbCrLf & strStatus, vbInformation, "Outlook Rule Automation Complete."
    End If
 
    Set olRules = Nothing
    Set olRule = Nothing

End Sub

Open in new window

0
 
LVL 59

Expert Comment

by:Chris Bottomley
ID: 35171813
BTW I think the rules collection starts in 2007 ... so if you have an earlier version it will probably return an error ... and if so even that very limited capability will not be available to you.

Chris
0
 
LVL 39

Author Comment

by:thenelson
ID: 35171912
When I run the macro, I get "user defined type is not defined" on "olRules As Outlook.Rules" I guess I need to set a reference to a library?
0
 
LVL 39

Author Comment

by:thenelson
ID: 35171920
I have Outlook 2003.
0
 
LVL 59

Assisted Solution

by:Chris Bottomley
Chris Bottomley earned 2000 total points
ID: 35171955
Nope, as I commented and didn't consider early enough when raising your hopes ... the rules collection is exposed in 2007 therefore you have no chance!

>>> When I create a rule in Microsoft Outlook, "on this machine only" gets checked automatically. How do I change this behavior

No can do!

Chris
0
 
LVL 39

Author Comment

by:thenelson
ID: 35174068
"No can do!" is an answer to the question and you did come up with something that addresses the problem for Outlook 2007+ so I'LL give you the points. Thanks!
0
 
LVL 59

Expert Comment

by:Chris Bottomley
ID: 35174401
I'm quite disappointed in the solution as even with 2010 it doesn't seem that that aspect of rules can be accessed, perhaps in the future.

Thanks for the consideration
Chris
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Large Outlook files lead to various unwanted errors and corruption issues. Furthermore, large outlook files can also make Outlook take longer to start-up, search, navigate, and shut-down. So, In this article, i will discuss a method to make your Out…
You need to know the location of the Office templates folder, so that when you create new templates, they are saved to that location, and thus are available for selection when creating new documents.  The steps to find the Templates folder path are …
Get people started with the process of using Access VBA to control Outlook using automation, Microsoft Access can control other applications. An example is the ability to programmatically talk to Microsoft Outlook. Using automation, an Access applic…
There are cases when e.g. an IT administrator wants to have full access and view into selected mailboxes on Exchange server, directly from his own email account in Outlook or Outlook Web Access. This proves useful when for example administrator want…

656 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question