[2 days left] What’s wrong with your cloud strategy? Learn why multicloud solutions matter with Nimble Storage.Register Now

x
?
Solved

Sending email to Exchange Server 2007

Posted on 2011-03-19
19
Medium Priority
?
874 Views
Last Modified: 2012-05-11
I'm trying to send an email to somebody via MS Exchange Server by using the POSTIE Extender.  I keep getting an error.  Does anyone know the proper setting such as port, protocol, etc.  Outlook has no problems communicating with Exchange but I get a 550 5.7.1 unable to relay message when I try to p;ost a email message when using WinBatch.

Thanks
0
Comment
Question by:chasmx1
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 11
  • 8
19 Comments
 
LVL 4

Expert Comment

by:needleboy
ID: 35171787
Hi there,

you must create new Exchange 2007 receive connector and allow IP address for POSTIE Extender to relay mails.

You can follow this nice step by step guide:
http://www.techrepublic.com/blog/networking/exchange-2007-how-to-allow-relay-exceptions/373

Marko
0
 

Author Comment

by:chasmx1
ID: 35172148
Can you tell me if I should setup another IP address on the TCP/IP stack for TCP/IPv4?  Do I need to specify a "Custom" or "Internal" in the wizard setup?  Do I need to specify a different FQDN in the wizard?  Currently we are using "MUSTANG.ets.local".  How do I tell Exchange to allow open relay on the new connection?

Thanks,
Charles
0
 
LVL 4

Expert Comment

by:needleboy
ID: 35172316
No other IP is needed.
You can specify what ever you want. It's not important.
You can specify MUSTANG.ets.local if MUSTANG is name of exchange server.
You can tell exchange to open relay by specifiyng permissions in connecter (Figure E and F from step by step guide posted above)
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

 

Author Comment

by:chasmx1
ID: 35172424
Do I need to specify userid, password, port and security for the the POSTIE call below when using Exchange Server? Also how is Exchange going to be able to delineate between the regular email "receive connector" and this special internal "receive connector" WinBatch needs to use that provides for an open relay?

These are the three calls that have to be made to send an email with the POSTIE Extender.

kInit( host, fromaddr, userid, password [, port [, security ]] )
kDest(tolist,cclist,bcclist)
kSendText(subject,mymsg,attachments,flags)

0
 
LVL 4

Expert Comment

by:needleboy
ID: 35172479
You only need to specify host and port. (there is no security settings to configure on client).
Dont worry about "how exchange can decide which connector to use?" because we don't know how exchange is designed but that thing actually works.
Name of receive connector is just descriptional.

Hope this helps
0
 

Author Comment

by:chasmx1
ID: 35172671
I'm still getting "Could not send:  error= -1@CRLFStatus: 550 5.7.1 Unable to relay@CRLF@CRLF".  I have the flags set to "h".  Any ideas?

Thanks
0
 
LVL 4

Expert Comment

by:needleboy
ID: 35173075
Did you specify remote address in Create connector wizard?
You must enter IP address of application server which relay messages.

0
 

Author Comment

by:chasmx1
ID: 35173314
I ran the "New Receive Connector". Do I need to run something else?   Is this different than the "Create connector wizard" you speak of?

Thanks
0
 

Author Comment

by:chasmx1
ID: 35173751
Attached is the program snippet and Exchange Server settings. Exchange slide #1  
Slide-2.jpg
Slide-3.jpg
Slide-4.jpg
email-program.txt
0
 
LVL 4

Expert Comment

by:needleboy
ID: 35175008
0
 
LVL 4

Expert Comment

by:needleboy
ID: 35175009
0
 
LVL 4

Expert Comment

by:needleboy
ID: 35175013
0
 
LVL 4

Expert Comment

by:needleboy
ID: 35175014
0
 
LVL 4

Expert Comment

by:needleboy
ID: 35175018
You are right about the name of the wizard.
These are screenshoots of my working setup.

0
 

Author Comment

by:chasmx1
ID: 35175697
I was experimenting with telnet and I found that when I telnet to IP 192.168.2.4 it works fine for relay but 192.168.2.3 does not ( I put a second IP address on the Exchange Server).  I can always telnet emails between Exchange server users but not to an external user unless I use telnet "192.168.2.4 25".  Is there anyway to force POSTIE to use a specific IP address?

Thanks
0
 
LVL 4

Expert Comment

by:needleboy
ID: 35175989
There is no need to add second IP on exchange server.
POSTIE will use ip address of server (or computer) where running.
0
 

Author Comment

by:chasmx1
ID: 35176452
If I telnet to 192.168.2.3 on port 25 the email relay attempt fails.  This is the default connector that was installed during initial setup of Exchange 2007.  We certainly don't want this to be an open reply receive connector or we'll get blacklisted as a spam sender.  If I telnet to 192.168.2.4 the  email relay attempt succeeds.  If I telnet to mustang.ets.local the email relay attempt fails.  I bound the second IP to the mustang (Exchange Server) NIC after reading a few articles on the Internet that said this was the way to go.  I set the returned FQDN to mail2.ets.local for the new receive connector that will allow relays. Again I can get the email relay to work if I do "telnet 192.168.2.4 25" but nothing else will work.  I can't tell POSTIE to connect to 192.168.2.4 so I'm stuck.  Should I setup a second port for SMTP email?
slide--1.jpg
slide--2.jpg
0
 
LVL 4

Accepted Solution

by:
needleboy earned 2000 total points
ID: 35176634
Point mail2.ets.local in forward lockup zone in DNS manager to ip 192.168.2.4 and you  are done.
Than you can use mail2.ets.local in your WinBatch srcipt.

You can ping mail2.ets.local to and see to which ip address is forwarded now. (maybe 192.168.2.3)

Adding new NIC doesn't impove overall security. Remote servers tab is used for restricting computers to relay off exchange server.
0
 

Author Comment

by:chasmx1
ID: 35181448
That's a winner.  I have tried that setup before but set mail2 up as a CNAME in DNS which didn't work.  Once I made it an "A" record it worked fine.

Thanks,
Charles
0

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

We aren’t perfect, just like everyone else.  Check out the email errors our community caught and learn the top errors every email marketer should avoid.
Want to know how to use Exchange Server Eseutil command? Go through this article as it gives you the know-how.
To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…
This video demonstrates how to sync Microsoft Exchange Public Folders with smartphones using CodeTwo Exchange Sync and Exchange ActiveSync. To learn more about CodeTwo Exchange Sync and download the free trial, go to: http://www.codetwo.com/excha…
Suggested Courses

649 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question