Solved

Outlook errors when connecting to exchange 2010

Posted on 2011-03-19
23
1,336 Views
Last Modified: 2012-05-11
I am using Win Server 2008 R2 Std SP1 and Exchange 2010.

Clients are Outlook 2003 and outlook 2010, this issue is the same for all users.

Outlook will allow me to set up the profile and the server is discovered by the client (server and username underlined), only when I try to start outlook do I get the following messages.

Offline file switched on, on opening outlook I get the message   -   "Cannot Open your default email folders. You must connect to Microsoft Exchange with the current profile before you can synchronize your folders with your outlook data file (.ost)"

Offline files switched off, on opening outlook I get the message   -   "Cannot Open your default email folders. Microsoft Exchange is not available. Either there are network problems or the Exchange server is down for maintenance"

After clicking OK outlook closes.

I get the same message from Outlook 2003 and 2010, with security enabled or disabled (client and server.)

I have installed Outlook 2010 on the exchange server also with the same error

I am able to access the mailboxes via OAB, using "server name" or FQDN in the browser.

I can send and receive internal mail, I can send mail out to external addresses (No receive for external mail configured as this is still used with pop3)

The only information that relates to this is ref to "RPC encryption requirement" this does not appear to be that issue.

Any pointers please?








0
Comment
Question by:jacass
  • 10
  • 7
  • 5
  • +1
23 Comments
 
LVL 1

Expert Comment

by:schmied77
ID: 35172369
You can try deleting the mail profile and re-creating - control panel > mail > Profiles > remove...now open Outlook back up and re-create the mail profile  Is the client computer and the exchange server both a member of the same domain? Make sure the client PC can ping and resolve the FQDN of the Exchange Server.
0
 

Author Comment

by:jacass
ID: 35172578
Schmied, thanks but all of that is answered in my post.
0
 
LVL 4

Expert Comment

by:rjpilcher
ID: 35172596
Have you tried checking the box in your Outlook 2003 client in the image below:

http://lh5.ggpht.com/_1Z-H-ni-Cj0/SqAhwj5WSXI/AAAAAAAAAYA/agGEkrYuQ6k/s1600-h/O3%5B4%5D.jpg
0
What is SQL Server and how does it work?

The purpose of this paper is to provide you background on SQL Server. It’s your self-study guide for learning fundamentals. It includes both the history of SQL and its technical basics. Concepts and definitions will form the solid foundation of your future DBA expertise.

 

Author Comment

by:jacass
ID: 35172656
Hi RJ, yes thats the only ref I have found also.
0
 
LVL 4

Expert Comment

by:rjpilcher
ID: 35172681
0
 

Author Comment

by:jacass
ID: 35172701
The exchange server is only internal at the moment so none of those tests would help.
0
 
LVL 4

Expert Comment

by:rjpilcher
ID: 35172729
Test-OutlookWebServices -ClientAccessServer "CASServer01" (replace CASServer01)

Also, http://www.msexchange.org/articles_tutorials/exchange-server-2010/management-administration/exchange-autodiscover.html
0
 

Author Comment

by:jacass
ID: 35172924
That did not work, but other tests show OWA and the CAS are working correctly.
0
 
LVL 4

Expert Comment

by:rjpilcher
ID: 35173336
From the Exchange Management Shell, you should be able to run the command above and get a long readout of successful tests.  

I'm leaning towards an Autodiscover/RPC issue here.  
0
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 35173351
Outlook 2003 doesn't use autodiscover. Try starting outlook with /safe and see if that makes a difference.

Also try starting outlook with /rpcdiag to confirm it is connecting over TCP/IP and is not trying to connect to decommissioned servers.
0
 
LVL 4

Accepted Solution

by:
rjpilcher earned 250 total points
ID: 35173365
Yeah, you're right MegaNuk3.  The errors indicate something is misconfigued, though.

Try this for troubleshooting from EMS:

Set-RpcClientAccess –Server Exchange_server_name –EncryptionRequired $False

0
 

Author Comment

by:jacass
ID: 35175000
Hi Mega,

I dont think it is a client issue but I am willing to try anything at the moment, /safe = same error   /rpcdiag = connected over TCP/IP "true"   There has never been an exchange server on this domain so no decommissioned servers

Hi RJ,

I have already switched security on and off making no difference.
Set-RpcClientAccess –Server Exchange_server_name –EncryptionRequired $False
Set-RpcClientAccess –Server Exchange_server_name –EncryptionRequired $true

0
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 35175036
Is this issue affecting all users? I.e. No one can use Outlook at the moment?
0
 

Author Comment

by:jacass
ID: 35175038
That is correct, Clients are Outlook 2003 and outlook 2010, this issue is the same for all users.
0
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 35176059
Check the time on the Exchange server compared to the DC
0
 

Author Comment

by:jacass
ID: 35176251
Hi Mega,

Sorry could you explain? Why time? there are 2 DC's the PDC is also the ES, and dont forget I have installed outlook on the PDC to test with the same issue.


0
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 35176609
If there is a big time difference (more than 5 minutes) then Kereberos authentication won't work.

Have you tried rebooting your exchange server yet? Also try "gpupdate /force" on it and see if it can apply GPOs properly. Check the system and application eventvwr for errors/warnings
0
 

Author Comment

by:jacass
ID: 35208997
Still not able to resolve this issue, any other takers?
0
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 35209212
Have you checked the times on the servers? What about the exchange event log? You can also run exBPA on your Exchange Server and see whether that highlights anything.
0
 
LVL 31

Assisted Solution

by:MegaNuk3
MegaNuk3 earned 250 total points
ID: 35209294
See if autodiscover is working for the outlook 2010 clients:
 test outlook autoconfig:
With outlook open, hold down CTRL key and right click on the Outlook icon in the bottom right hand side of your screen, then on the popup menu select the "Test Autoconfiguration". Select that, enter valid credentials and select the "autodiscover" option only and test.

Also have a look at outlook /rpcdiag and check the server names are correct that Outlook is trying to connect to, you might have a typo in your client access array or something...

Have a look at the output if EMS
Get-mailboxdatabase | fl name, *RPC*
0
 

Author Comment

by:jacass
ID: 35209912
Thanks Mega, report back soon
0
 

Author Comment

by:jacass
ID: 35227872
Looks like it is now working, not to sure what fixed it but I do know the RPC service was not running, it was at last check but for some reason failed, no errors found in logs, I also disabled Folder redirect at around the same time.

I will award points to you both as I believe without it it may of taken me longer.

Thanks
0
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 35227891
Thanks for the points.
0

Featured Post

VMware Disaster Recovery and Data Protection

In this expert guide, you’ll learn about the components of a Modern Data Center. You will use cases for the value-added capabilities of Veeam®, including combining backup and replication for VMware disaster recovery and using replication for data center migration.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Note: This is the second blog post in a series on email clearinghouses (https://www.xmatters.com/alert-management/blog-email-has-failed-us?utm_campaign=70138000000ydLoAAI&utm_source=exex&utm_medium=article&utm_content=blog-post).   Every month t…
When you have clients or friends from around the world, it becomes a challenge to arrange a meeting or effectively manage your time. This is where Outlook's capability to show 2 time zones in one calendar comes in handy.
In this video we show how to create a mailbox database in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Servers >> Data…
The basic steps you have just learned will be implemented in this video. The basic steps are shown to configure an Exchange DAG in a live working Exchange Server Environment and manage the same (Exchange Server 2010 Software is used in a Windows Ser…

803 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question