Solved

Unable to Share ACT DB using ACT 2011 Premium on SBS2008

Posted on 2011-03-19
17
1,712 Views
Last Modified: 2013-01-03
Recently installed new Server running SBS2008.  
Installed ACT2011 Premium, backed-up database from old server running SBS2003 and restored to new server running SBS2008.  
The database restore was fine.  I can access the ACT databsae from the Server but cannot access from client workstations.  
I have allowed user access to new ACT database.  The "Share" option under Tools, Database Management is unavailable for some reason.
Any suggestions?
0
Comment
Question by:rjchallenged
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
17 Comments
 
LVL 30

Expert Comment

by:Mike Lazarus
ID: 35174161
What happens when you try to access from the workstations? Do you get an error? If so, what is it?
0
 

Author Comment

by:rjchallenged
ID: 35174169
The error reads:  "Could not find a database called (DBName) on host (Workstations) as opposed to the domain where the database is located.  The workstation is mapped to the server location and access rights are co-owner for all users.
0
 
LVL 30

Expert Comment

by:Mike Lazarus
ID: 35174180
If you are using a PAD file, you might be using the wrong one ... you can open the PAD file in Notepad - it just has the machine names, database name and location
0
Database Solutions Engineer FAQs

In this series, we will discuss common questions received as a database Solutions Engineer at Percona. In this role, we speak with a wide array of MySQL and MongoDB users responsible for both extremely large and complex environments to smaller single-server environments.

 

Author Comment

by:rjchallenged
ID: 35174193
Don't know why ACT is looking for the database on th elocal PC when the path indicates the database is on the server?
0
 

Author Comment

by:rjchallenged
ID: 35174204
No the PAD file is looking to the correct location:

<?xml version="1.0" standalone="no"?>
<!DOCTYPE ACTDatabasePADFile>
<!--This file represents a Pointer to an Act Database or [PAD]-->
<ACTDatabase name="SR11" host="." location="E:\DATA\RJMCSTEP\RJMC\ACT\Databases" type="Sql" />
0
 
LVL 30

Expert Comment

by:Mike Lazarus
ID: 35174207
Please post the contents of the PAD file
0
 
LVL 30

Expert Comment

by:Mike Lazarus
ID: 35174209
The host should not be "."

That means local PC .... it should have the server name or it's IP address
0
 

Author Comment

by:rjchallenged
ID: 35174212
I can insert the IP address and see if that works.
0
 

Author Comment

by:rjchallenged
ID: 35174230
New error after I inserted the IP Address:
"The database SR11 cound not be accessed.  In order to access the database, check your network connection and verify that your database server is available.  If may be necessary to disable any firewall software on your computer or the server."

I can easily access all the shared files on our server from any workstation.  There is no firewall software running to my knowledge unless it is a setting that is part of SBS2008.  

I still think it has something to do with the fact that I cannot enable the "share" status under the database maintenance option in ACT 2011.  This was not a prblem in our previous version of ACT 2009.  
0
 
LVL 30

Accepted Solution

by:
Mike Lazarus earned 250 total points
ID: 35174234
0
 

Author Comment

by:rjchallenged
ID: 35174240
The only possibility that I see is the Microsoft Firewall issue but I'll have to work with someone more technical than me to try it out.  

Thank you for your quick responses . . .. maybe tomorrow will be a better day.
0
 
LVL 30

Expert Comment

by:Mike Lazarus
ID: 35174284
0
 

Author Comment

by:rjchallenged
ID: 35174300
I'll give it a try and let you know.  Although this looks like a morning exercise.  Thank you.
0
 
LVL 7

Assisted Solution

by:50cal
50cal earned 250 total points
ID: 35175012
If share database is Grey on the server then possibly UAC's are preventing access.
Close act on the server, then right click in the act icon and choose run as administrator, log into the database using an act admin user name and Password and then try sharing the database from tools -> database maintenance -> share database.

50cal.
0
 

Author Comment

by:rjchallenged
ID: 35175570
Thanks for the suggestion.  I'll give it a try when I get to my office in a few hours and will let you know if that solves the problem.
0
 

Author Closing Comment

by:rjchallenged
ID: 35176970
Really appreciated the quick response time and willingness to dig deeper.
0
 
LVL 3

Expert Comment

by:DJNafey
ID: 38739383
** FIXED **

Hi,

In my case, the Windows Firewall was causing the problem so, if you're going to work through the very long list of possible causes in the Sage KnowledgeBase article, try the Windows Firewall suggestion first!  To get straight to the answer, visit the Microsoft support article at http://support.microsoft.com/kb/968872.  There's a 'Fix It' tool there but it only runs on plain Windows Server 2008, not SBS 2011.  However, Microsoft also give you all the code that you need to copy into a batch file.  

That worked perfectly for me on Small Business Server 2011 and took less than 2 minutes.  

I had experienced the same issue after moving a client with Sage ACT! Pro 2011 from an SBS 2003 server to an SBS 2011 server (based on Windows Server 2008 R2).  It wasted 2-3 hours of my time-critical server installation visit so I hope that my update can help someone else :-)
0

Featured Post

 Watch the Recording: Learning MySQL 5.7

MySQL 5.7 has a lot of new features. If you've dabbled with an older version of MySQL, it is definitely worth learning.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Read about achieving the basic levels of HRIS security in the workplace.
These days socially coordinated efforts have turned into a critical requirement for enterprises.
Progress
Starting up a Project

636 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question