Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 4077
  • Last Modified:

slow Comcast speed with Sonicwall TZ210

I cannot get fast speeds when connecting through my sonicwall router. If I connect through the comcast modem I get great speeds. I have changed the MTU on the sonicwall to 1420 by following this http://www.experts-exchange.com/viewArticle.jsp?articleID=3110 
I have turned off all security setting.
Do I need to add the comcast modem private ip somewhere? 10.1.10.1 and my SW is 192.168.10.1
I have the SW with one of my Static IPs and I have the server as the DHCP and it is plugged into the x0 LAN port and the network switch in x3 port. I am getting slow speeds from the server and on workstations.

let me knowi f there is something else I need to change on the SW.
0
calitech
Asked:
calitech
  • 6
  • 2
  • 2
  • +1
1 Solution
 
rfc1180Commented:
Very common issue you have, check you dulpex settings on both the comcast modem and firewall and ensure the duplex settings match (both sides must be auto or har set to the same full and full, exmaple 100-full/100full or auto/auto).

Billy
0
 
calitechAuthor Commented:
yes they are both full 100MB and not auto
0
 
Aaron TomoskyTechnology ConsultantCommented:
Turn off qos
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
calitechAuthor Commented:
I set it to none for LAN to WAN and no change
0
 
rfc1180Commented:
check the duplex settings on all hosts and network devices.
Has anything changed in the network to get slow speeds (Changed ISPs, new setup, etc).

Billy
0
 
Aaron TomoskyTechnology ConsultantCommented:
Ping 4.2.2.2 what is the time in ms?
Try disconnecting all devices except one PC but still go through the sonicwall and do a speedtest.
0
 
digitapCommented:
i think rfc1180 has the idead as i suggested in your other question for this same issue.
http://mobile.experts-exchange.com/Q_26897673.html

0
 
calitechAuthor Commented:
the duplex is set to 100 Full.
It was an office move/new service
I just bought a linksys router to test and the speed seems fine with it. Now I just have to dive deeper into Sonicwall to see where there could be a bottle neck.
0
 
calitechAuthor Commented:
Speed test with the linksys showed 20MB+ but going to different pages take forever and I can get to yahoo.com right now but I can ping it. I think I might be a service related issue with Comcast.
0
 
calitechAuthor Commented:
it was can't get to yahoo but now it seems to be ok.
0
 
calitechAuthor Commented:
It seems as though I had to have both the comcast modem and the sonicwall router set to auto and that solved the problem.
0

Featured Post

Managing Security Policy in a Changing Environment

The enterprise network environment is evolving rapidly as companies extend their physical data centers to embrace cloud computing and software-defined networking. This new reality means that the challenge of managing the security policy is much more dynamic and complex.

  • 6
  • 2
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now