Go Premium for a chance to win a PS4. Enter to Win

x
?
Solved

Cisco Routing

Posted on 2011-03-20
4
Medium Priority
?
444 Views
Last Modified: 2012-05-11
I currently am using a 2621 cisco router to route traffice for two lans connected via fiber.  Currently the 2621 is configured with a fastethernet port for each lan.  Each of these ports is in turn connected to a 2950 which recieves the fiber from one lan and is dirrectly connected to the other.  My problem is I would like to free up one of the fastethernet ports for something else.  I attempted to create two subinterfaces on one of the fastethernet ports two accomidate both of the lans.  Problem is once i did this the lan connected via fiber is unreachable.  My cisco knowledge is limited and I'm not sure where I am going wrong.  Below is the config for the two ports on the 2621 as is.


Building configuration...

Current configuration : 3229 bytes
!
version 12.2
service timestamps debug datetime msec localtime
service timestamps log datetime msec localtime
service password-encryption
!
hostname r1.ECB.Ewald
!
logging buffered 16000 debugging!
ip subnet-zero
!
!
ip dhcp excluded-address 192.168.3.1 192.168.3.59
ip dhcp excluded-address 192.168.3.210 192.168.3.254
ip dhcp excluded-address 192.168.3.119 192.168.3.189
!
ip dhcp pool CLIENT
   network 192.168.3.0 255.255.255.0
   default-router 192.168.3.1
   netbios-name-server 192.168.1.26
   dns-server 69.130.45.228
   lease 2
!
frame-relay switching
call rsvp-sync
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 description Ewald Chevy Buick Local LAN
 ip address 192.168.3.1 255.255.255.0
 duplex auto
 speed auto
!
!
interface FastEthernet0/1
 description Ewald C/P VLAN
 ip address 192.168.4.1 255.255.255.0
 no ip redirects
 duplex auto
 speed auto
!
router eigrp 1
 passive-interface FastEthernet0/1
 network 10.0.0.0
 network 192.168.3.0
 network 192.168.4.0
 network 192.168.255.0
 no auto-summary
 no eigrp log-neighbor-changes
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.255.5
ip route 10.227.35.0 255.255.255.0 10.230.108.252
ip route 10.230.108.0 255.255.255.0 192.168.3.10
ip route 172.16.5.0 255.255.255.0 192.168.3.10
ip route 192.168.4.0 255.255.255.0 192.168.3.16
ip route 192.168.10.1 255.255.255.255 192.168.255.5
ip route 198.208.187.154 255.255.255.255 192.168.255.5
no ip http server
!
!
dial-peer cor custom
!

r1.ECB.Ewald#

And the configuration of the two ports on the 2950 that are connected to the 2621


interface FastEthernet0/1
 description to F0/1 Ewald Chev c2621
 no ip address
 spanning-tree portfast
!
interface FastEthernet0/2
 description to F0/0 Ewald Chev c2621
 no ip address
 spanning-tree portfast
!

Any suggestions would be greatly appreciated.  Please let me know if more information is needed.
 
0
Comment
Question by:e_miller53
  • 2
4 Comments
 
LVL 79

Expert Comment

by:lrmoore
ID: 35177301
Well, you're pretty much stuck with the working config.
The switches need to be a  trunk port to connect to sub-interfaces of the router, and so you need to create separate vlans for each of the connected networks/2950 switches, then connect them together over a trunk port...
0
 

Author Comment

by:e_miller53
ID: 35177567
I apoloigize ahead of time agiain my cisco knowledge is very limited.  This can or can't be done with the equipment I am currently using?  Could i create two vlans on the 2950 and then use one port as a trunk port like you mentioned to connect to the 2621 and carry the traffice for both LANS?  If so can you give some info on how to configure that.
0
 
LVL 6

Accepted Solution

by:
gcl_hk earned 2000 total points
ID: 35177884
On 2621 Rouer, you need to create sub interface for inter vlan routing

en
conf t
int fa0/1
no ip address
! release the existing ip address on fa0/1
int fa0/0
no ip address
! release the existing ip address on fa0/0, and free up for other purpose
int fa0/1.1
encap dot1q 1
ip add 192.168.3.1 255.255.255.0
int fa0/1.2
encap dot1q 2
ip add 192.168.4.1 255.255.255.0

On 2950 Rouer, you need to create additional VLAN 2 for subnet 192.168.4.0/24, and configure to trunk port for int FA0/1
en
conf t
vlan 2
! create additional vlan 2 on 2950
int fa0/1
no spanning-tree portf
switchport mode trunk
! configure fa0/1 as a trunk port to allow multiple vlan traffic

After that, all other device belongs to VLAN 2 (192.168.4.0/24), the switch port require to configure as below:

switchport access vlan 2
0
 

Author Comment

by:e_miller53
ID: 35182383
I'm with you on creating the subinterfaces, assigning a vlan to the 2950 switch, and setting the port on the 2950 switch that connects to the 2621 router to trunk.  All of the traffic from the 4 subnet comes across fiber on port 25 of the 2950, so that would be the only port i need to set for switchport access vlan 2 correct?
0

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

WARNING:   If you follow the instructions here, you will wipe out your VTP and VLAN configurations.  Make sure you have backed up your switch!!! I recently had some issues with a few low-end Cisco routers (RV325) and I opened a case with Cisco TA…
Tech spooks aren't just for those who are tech savvy, it also happens to those of us running a business. Check out the top tech spooks for business owners.
Viewers will learn how to connect to a wireless network using the network security key. They will also learn how to access the IP address and DNS server for connections that must be done manually. After setting up a router, find the network security…
In this tutorial you'll learn about bandwidth monitoring with flows and packet sniffing with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're interested in additional methods for monitoring bandwidt…

972 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question