Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

EIGRP autosummarization

Posted on 2011-03-20
14
Medium Priority
?
632 Views
Last Modified: 2012-05-11
I am trying to understand this practice question on cisco Adv test:

 10.10.10.0/24----E0 RTR1 S0----172.16.10.0/24---S0 RTR2 S1---192.168.20.0/24---S1 RTR3---E0

RTR1 config:
router eigrp 4
  network 10.0.0.0
  network 172.16.0.0
  no auto-summary

Auto-summarization is disabled on RTR1 but is enabled on RTR2 and RTR3. Which
two routes will be seen on the routing table of RTR3:
A. 10.0.0.0/8
B. 10.10.0.0/16
C. 10.10.10.0/24
D. 172.16.0.0/16
E. 172.16.0.0/24
F. 172.16.10.0/24
0
Comment
Question by:totaram
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 5
  • 3
14 Comments
 
LVL 50

Expert Comment

by:Don Johnston
ID: 35177666
A & D

When auto-summary is enabled, routes will be summarized to the classfull boundaries.
0
 

Author Comment

by:totaram
ID: 35177697
Thats what I thought, answer is C,D.
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 35177712
Says who? :-)
0
Nothing ever in the clear!

This technical paper will help you implement VMware’s VM encryption as well as implement Veeam encryption which together will achieve the nothing ever in the clear goal. If a bad guy steals VMs, backups or traffic they get nothing.

 
LVL 6

Expert Comment

by:gcl_hk
ID: 35178004
10.10.10.0/24 is advertise by RTR1, even RTR2 have enabled auto summary, as the 10.10.10.0/24 is learn from neighbor, so auto summarization will not modify it and advertise to others by default
0
 

Author Comment

by:totaram
ID: 35178012
The answer provided with the question bank...

Could it be that since the two interfaces on RTR1 are directly connected, the no auto summarization  advertises them as what they are tp both RTR2 & RTR3.??
0
 
LVL 6

Expert Comment

by:gcl_hk
ID: 35178014
I have tried on lab.... and the result for your reference.

en
conf t
host R3
int g0/1
no sh
ip add 10.10.10.3 255.255.255.0
int fa0/0/1
no sh
ip add 172.16.10.3 255.255.255.0
router eigrp 4
network 10.0.0.0
network 172.16.0.0
no auto-summary

en
conf t
host R4
int fa0/0
no sh
ip add 172.16.10.4 255.255.255.0
int s0/0/0
ip add 192.168.20.4 255.255.255.0
router eigrp 4
network 172.16.0.0
network 192.168.20.0

en
conf t
host R2
int s0/0
clockrate 64000
ip add 192.168.20.2 255.255.255.0
router eigrp 4
network 192.168.20.0

10.10.10.0/24 - G0/1 --- R3 --- F0/0/1 - 172.16.10.0/24 - F0/0 --- R4 --- S0/0/0 - 192.168.20.0/24 - S/0 --- R2

R2#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

D    172.16.0.0/16 [90/2172416] via 192.168.20.4, 00:22:03, Serial0/0
C    192.168.20.0/24 is directly connected, Serial0/0
     10.0.0.0/24 is subnetted, 1 subnets
D       10.10.10.0 [90/2174976] via 192.168.20.4, 00:21:04, Serial0/0
0
 

Author Comment

by:totaram
ID: 35178037
You gave the output on R2, what is 'sh ip route' on R3??

I think you are right if command 'no passive int' is defined on R1. I guess default is passive interface...
0
 
LVL 6

Accepted Solution

by:
gcl_hk earned 252 total points
ID: 35178055
R3????

R3#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, + - replicated route

Gateway of last resort is not set

      10.0.0.0/8 is variably subnetted, 3 subnets, 3 masks
D        10.0.0.0/8 [90/30720] via 172.16.10.4, 00:04:11, FastEthernet0/0/1
C        10.10.10.0/24 is directly connected, GigabitEthernet0/1
L        10.10.10.3/32 is directly connected, GigabitEthernet0/1
      172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.16.10.0/24 is directly connected, FastEthernet0/0/1
L        172.16.10.3/32 is directly connected, FastEthernet0/0/1
D     192.168.20.0/24
           [90/2172416] via 172.16.10.4, 00:40:14, FastEthernet0/0/1

R4#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.16.10.0/24 is directly connected, FastEthernet0/0
D       172.16.0.0/16 is a summary, 00:41:17, Null0
C    192.168.20.0/24 is directly connected, Serial0/0/0
     10.0.0.0/24 is subnetted, 1 subnets
D       10.10.10.0 [90/30720] via 172.16.10.3, 00:40:16, FastEthernet0/0

0
 

Author Comment

by:totaram
ID: 35178078
Sorry, didn't realize that you had named them differently.. the last one does have the interface address in routing table.
0
 
LVL 50

Assisted Solution

by:Don Johnston
Don Johnston earned 248 total points
ID: 35180268
Now I see what's going on. The auto-summary feature only works on directly connected routes. Since R2 learned the 10.10.10.0 route, it won't summarize when it sends it to R3.

And since R2 is connected to the 172.16.10.0 network, it will summarize that to R3.

0
 

Author Comment

by:totaram
ID: 35181218
"Since R2 learned the 10.10.10.0 route, it won't summarize when it sends it to R3."

How did R2 learn 10.10.10.0/24 route, it is not directly connected to R2, 172.16.0.0/16 is connected to R2 and R1.

0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 35181287
>How did R2 learn 10.10.10.0/24 route,

R1 advertised it via EIGRP.
0
 

Author Comment

by:totaram
ID: 35181430
I see... R1 is no-auto summary and the other subnet (172.16.0.0) is directly connected, so auto-summary :-)
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 35181782
Correct.
0

Featured Post

Simplify Your Workload with One Tool

How do you combat today’s intelligent hacker while managing multiple domains and platforms? By simplifying your workload with one tool. With Lunarpages hosting through Plesk Onyx, you can:

Automate SSL generation and installation with two clicks
Experience total server control

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

How to set-up an On Demand, IPSec, Site to SIte, VPN from a Draytek Vigor Router to a Cyberoam UTM Appliance. A concise guide to the settings required on both devices
Originally, this post was published on Monitis Blog, you can check it here . It goes without saying that technology has transformed society and the very nature of how we live, work, and communicate in ways that would’ve been incomprehensible 5 ye…
Viewers will learn how to connect to a wireless network using the network security key. They will also learn how to access the IP address and DNS server for connections that must be done manually. After setting up a router, find the network security…
In this video we outline the Physical Segments view of NetCrunch network monitor. By following this brief how-to video, you will be able to learn how NetCrunch visualizes your network, how granular is the information collected, as well as where to f…

618 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question