Solved

Netbeans Java J2ee environment keeps throwing error

Posted on 2011-03-20
5
472 Views
Last Modified: 2012-05-11
Whenever I deploy a web application in netbeans I get the following error:
In-place deployment at C:\Documents and Settings\Home\My Documents\NetBeansProjects\TestWebApplicationProject\build\web
deploy?path=C:\Documents and Settings\Home\My Documents\NetBeansProjects\TestWebApplicationProject\build\web&name=TestWebApplicationProject&force=true failed on GlassFish Server 3
C:\Documents and Settings\Home\My Documents\NetBeansProjects\TestWebApplicationProject\nbproject\build-impl.xml:694: The module has not been deployed.
BUILD FAILED (total time: 6 seconds)

Can some one let me know how to resolve this error
0
Comment
Question by:onaled777
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
5 Comments
 
LVL 47

Accepted Solution

by:
for_yan earned 125 total points
ID: 35178196
I guess it id not very informative message
It just states  that deployment failed.
There probably could be many different reasons with the same message
like that, maybe you could
find details in some log file.

People report a lot of such errors (see examples below)
but there is now guarantee that they are caused by
the same issue.

Some are even writing that if you upgrade
netbeans to 6.9 the issue  will go away (of course those
folks were running on 6.8)
but it probably depends on what is the root cause of the issue.
 

http://netbeans-org.1045718.n5.nabble.com/6-8-Can-t-deploy-Java-EE-6-Enterprise-Application-td2927939.html

http://www.techienuggets.com/Comments?tx=110533
0
 
LVL 20

Assisted Solution

by:Sathish David Kumar N
Sathish David  Kumar N earned 125 total points
ID: 35178501
I think ur build.xml not build(create) correctly or Some invaild DD problem in ur JSP
0
 
LVL 86

Assisted Solution

by:CEHJ
CEHJ earned 250 total points
ID: 35179720
Try running the following at the command line. Attach the log file ant.log (in the current directory) here
C:\Documents and Settings\Home\My Documents\NetBeansProjects\TestWebApplicationProject>ant -d >ant.log 2>&1

Open in new window

0
 

Author Comment

by:onaled777
ID: 35185546
@CFHJ
'ant' is not recognized as an internal or external command,
operable program or batch file.
0
 
LVL 86

Assisted Solution

by:CEHJ
CEHJ earned 250 total points
ID: 35185781
You need to add the ant bin directory (the one that contains ant.bat) to your path
0

Featured Post

More Than Just A Video Library

Train for your certification. Learn the latest DevOps tools. Grow your skillset to do better work.

At Linux Academy, we release new training modules every week so you'll always be up to date on the latest tech.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This exercise is about for the following scenario: Dmgr and One node with 2 application server. Each application server contains it owns application. Application server name as follows server1 contains app1 server2 contains app1 Prereq…
Java Flight Recorder and Java Mission Control together create a complete tool chain to continuously collect low level and detailed runtime information enabling after-the-fact incident analysis. Java Flight Recorder is a profiling and event collectio…
This theoretical tutorial explains exceptions, reasons for exceptions, different categories of exception and exception hierarchy.
This tutorial explains how to use the VisualVM tool for the Java platform application. This video goes into detail on the Threads, Sampler, and Profiler tabs.

707 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question