Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people, just like you, are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
Solved

Netbeans Java J2ee environment keeps throwing error

Posted on 2011-03-20
5
470 Views
Last Modified: 2012-05-11
Whenever I deploy a web application in netbeans I get the following error:
In-place deployment at C:\Documents and Settings\Home\My Documents\NetBeansProjects\TestWebApplicationProject\build\web
deploy?path=C:\Documents and Settings\Home\My Documents\NetBeansProjects\TestWebApplicationProject\build\web&name=TestWebApplicationProject&force=true failed on GlassFish Server 3
C:\Documents and Settings\Home\My Documents\NetBeansProjects\TestWebApplicationProject\nbproject\build-impl.xml:694: The module has not been deployed.
BUILD FAILED (total time: 6 seconds)

Can some one let me know how to resolve this error
0
Comment
Question by:onaled777
5 Comments
 
LVL 47

Accepted Solution

by:
for_yan earned 125 total points
ID: 35178196
I guess it id not very informative message
It just states  that deployment failed.
There probably could be many different reasons with the same message
like that, maybe you could
find details in some log file.

People report a lot of such errors (see examples below)
but there is now guarantee that they are caused by
the same issue.

Some are even writing that if you upgrade
netbeans to 6.9 the issue  will go away (of course those
folks were running on 6.8)
but it probably depends on what is the root cause of the issue.
 

http://netbeans-org.1045718.n5.nabble.com/6-8-Can-t-deploy-Java-EE-6-Enterprise-Application-td2927939.html

http://www.techienuggets.com/Comments?tx=110533
0
 
LVL 20

Assisted Solution

by:Sathish David Kumar N
Sathish David  Kumar N earned 125 total points
ID: 35178501
I think ur build.xml not build(create) correctly or Some invaild DD problem in ur JSP
0
 
LVL 86

Assisted Solution

by:CEHJ
CEHJ earned 250 total points
ID: 35179720
Try running the following at the command line. Attach the log file ant.log (in the current directory) here
C:\Documents and Settings\Home\My Documents\NetBeansProjects\TestWebApplicationProject>ant -d >ant.log 2>&1

Open in new window

0
 

Author Comment

by:onaled777
ID: 35185546
@CFHJ
'ant' is not recognized as an internal or external command,
operable program or batch file.
0
 
LVL 86

Assisted Solution

by:CEHJ
CEHJ earned 250 total points
ID: 35185781
You need to add the ant bin directory (the one that contains ant.bat) to your path
0

Featured Post

Easy, flexible multimedia distribution & control

Coming soon!  Ideal for large-scale A/V applications, ATEN's VM3200 Modular Matrix Switch is an all-in-one solution that simplifies video wall integration. Easily customize display layouts to see what you want, how you want it in 4k.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
print map entry 34 72
windows explorer path to command prompt 5 54
Chrome and Firefox Java 5 50
Problem to Alipay 10 42
Most of the developers using Tomcat find it easy to configure the datasource in Server.xml and use the JNDI name in the code to get the connection.  So the default connection pool using DBCP (or any other framework) is made available and the life go…
Introduction This article is the last of three articles that explain why and how the Experts Exchange QA Team does test automation for our web site. This article covers our test design approach and then goes through a simple test case example, how …
This tutorial covers a practical example of lazy loading technique and early loading technique in a Singleton Design Pattern.
This tutorial covers a step-by-step guide to install VisualVM launcher in eclipse.

839 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question