Solved

RedHat Linux 4 Kernel Panic not syncing kill init no volume groups found

Posted on 2011-03-20
8
9,465 Views
Last Modified: 2014-04-16
I just imaged my RHEL 4 system that was running on a Dell Poweredge 2950 server using Acronis software and I restored the image to a VmWare virtual machine.  

Dell Poweredge 2950 - RAID 5
VmWare - using ESX 4.0

OS - Red Hat Enterprise Linux 4 ES Update 5 x64
kernel - 2.6.9-55.0.9.ELsmp

I'm getting the following when I try to boot on the new virtual machine.  I'm thinking it has to do with the fact that it's new hardware and it's having trouble either finding the right drivers or pointing to the correct place.

"No Volume Groups found
Volume Group "Volgroup00" not found
ERROR: /bin/lvm exited abnormally! (pid505)
mount: error 6 mounting ext3
mount: error 2 mounting none
switchroot: mount failed: 22
umount /initrd/dev failed: 2

Kernel panic - not syncing: Attempted to kill init!"
------------------------------------------------------------------
I was able to boot into Linux rescue mode using the boot CD.  Then I typed:
#chroot /mnt/sysimage

Here's all the info from the commands I typed:

#ldd /bin/bash

libtermcap.so.2 => /lib64/libtermcap.so.2 
libdl.so.2 => /lib64/libdl.so.2
libc.so.6 => /lib64/tls/libc.so.6
/lib64/ld-linux-x86-64.so.2

#uname -a
Linux localhost.localdomain 2.6.9-89.EL x86_64

#df -h

Filesystem                Size                   Used          Avail            Use%              Mounted on

/dev/volgroup00/logvol00
                                  4.0G                  3.2G            558M           86%                /

/dev/sda3                  190M                 41M             140M           23%                /boot
/dev/volgroup00/logvol05
                                   6.9G                 117M            6.5G             2%               /home
/dev/volgroup00/logvol03
                                   4.0G                  78M             3.7G             3%               /tmp
/dev/volgroup00/logvol06
                                 109G                   14G             89G              14%             /u01
/dev/volgroup00/logvol02
                                   7.9G                  3.5G            4.1G             46%             /usr
/dev/volgroup00/logvol04 
                                   4.0G                  1.4G            2.4G             37%            /var


#fdisk -l

Disk /dev/sda: 740.8GB
255 heads, 63 sectors per track, 90073 cylinders

Device                      Boot                  Start               End           Blocks     ID         System
/dev/sda1                                             1                    8            64228      de        Dell Utility
/dev/sda2                                             9                  531        4200997    8e        Linux LVM
/dev/sda3                   *                        532               556          200812    83        Linux
/dev/sda4                                            557              90074   719051370   5         Extended
Partition 4 does not end on cylinder boundary
/dev/sda5                                            557              88849   709213491   8e       Linux LVM


#cat /etc/redhat-release
Red Hat Enterprise Linux ES Release 4 (Update 5)

#cat /etc/fstab

#This file is edited by fstab-sync

/dev/volgroup00/logvol00                     /                             ext3                       Defaults
LABEL=/boot                                        /boot                      ext3                       defaults
none                                                    /dev/pts                  devpts                   gid=5,mode=620
none                                                   /dev/shm                  tmpfs                     defaults
/dev/volgroup00/logvol05                   /home                      ext3                        defaults
none                                                   /proc                        proc                       defaults
none                                                  /sys                          sysfs                     defaults
/dev/volgroup00/logvol03                  /tmp                          ext3                        defaults
/dev/volgroup00/logvol02                  /usr                           ext3                        defaults
/dev/volgroup00/logvol04                   /var                          ext3                        defaults
/dev/volgroup00/logvol01                   swap                       swap                      defaults
/dev/volgroup00/logvol06                   /u01                         ext3                         defaults
/dev/hde                                   /media/cdrecorder             auto                         pamconsole
/dev/sdb                                  /media/floppy                      auto                         pamconsole


#cat /etc/modprobe.conf

alias eth0 bnx2
alias eth0 bnx2
alias scsi_hostadapter megaraid_sas
alias usb-controller ehci-hcd
alias usb-controller1 uhci-hcd


#cat /boot/grub/grub.conf

#boot =/dev/sda3
default=1
timeout=5
splashimage=(hd0,2)/grub/splash.xpm.gz
hiddenmenu
title Red Hat Enterprise Linux ES (2.6.9-55.0.9.EL)
root (hd0,2)
kernel /vmlinuz-2.6.9-55.0.9.EL ro root=/dev/volgroup00/logvol00 linux ide2=0x1f0 rhgb quiet
initrd /initrd-2.6.9-55.0.9.EL.img
title Red Hat Enterprise Linux ES (2.6.9-55.0.9.ELsmp)
root (hd0,2)
kernel /vmlinuz-2.6.9-55.0.9.ELsmp ro root=/dev/volgroup00/logvol00 linux ide2=0x1f0 rhgb quiet
initrd /initrd-2.6.9-55.0.9.ELsmp.img

...
...

#cat device.map
(fd0)               /dev/fd0
(hd0)              /dev/sda

---------------------------------------------------------------------------

Open in new window

I've tried the following:

1.  mkinitrd -v -f /boot/initrd-2.6.9-55.0.9.EL.img 2.6.9-55.0.9.EL
2.  modified the device.map to point to /dev/sda3
3.  changed the SCSI controller in Vmware to use BusLogic instead of LSI Logic.  (didn't work because I'm running 64 bit.. gave me an error message)
4.  grub-install --recheck /dev/sda
5.  tried booting to differerent OS versions (i.e. 2.6.9-55.0.6, etc.).  I tried all of the versions listed in the boot menu


None of these worked.
0
Comment
Question by:Florescu
  • 5
  • 2
8 Comments
 

Author Comment

by:Florescu
ID: 35178040
0
 
LVL 34

Expert Comment

by:Seth Simmons
ID: 35178056
If you are trying to convert P2V, why don't you use VMware converter for this?
0
 

Author Comment

by:Florescu
ID: 35178066
I tried to do that but that keeps failing.  I have a case open with Vmware and their tech worked on it some but it may take them a while to figure out why it's failing.
0
 
LVL 6

Expert Comment

by:JRoyse
ID: 35180194
0
Backup Your Microsoft Windows Server®

Backup all your Microsoft Windows Server – on-premises, in remote locations, in private and hybrid clouds. Your entire Windows Server will be backed up in one easy step with patented, block-level disk imaging. We achieve RTOs (recovery time objectives) as low as 15 seconds.

 
LVL 6

Expert Comment

by:JRoyse
ID: 35180263
You could try the lastest VConverter again, but focus on the operating system, not the data partitions.  You already know you have the data partitions...?

You said changing the virtual SCSI adapter gave you an error - can you change the host designation to 32bit, then swap the Virtual scsi to what you want.  You can also try generic linux as an OS, it should boot without designating a 64 bit OS as the guest.
0
 

Author Comment

by:Florescu
ID: 35184788
I tried Vconverter at least 10 times, same result.

I also tried 32bit as well as Generic linux.  no luck
0
 

Accepted Solution

by:
Florescu earned 0 total points
ID: 35317302
I got it fixed:

http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1002402

http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1004797

Virtual machine does not boot after being converted from a physical Red Hat machine
Details
•      A converted physical machine running Red Hat does not boot as expected
•      Virtual machine fails to boot after conversion
•      The boot process halts with an error
•      Possible errors include:
o      No volume groups found
o      Kernel panic - not syncing: Attempted to kill init!
o      VFS: Cannot open root device "LABEL=/" or 00:00
o      Please append a correct = "root=" boot option
o      Kernel panic: VFS: Unable to mount root fs on 00:00
Solution
The issue occurs because the operating system's ramdisk image does not include the drivers or modules for the virtual SCSI adapter configured for the virtual machine. These modules are not in the ramdisk image because the image was originally created on a system that did not use this hardware. You must replace the existing ramdisk image with one that includes the proper drivers.
 
Converter 3.0.x did not support hot cloning of Linux operating systems or the configuration of resulting virtual machines for new virtual hardware. It only supported cold cloning without configuration. vCenter Converter 4.0 does support hot cloning and the configuration of some Linux operating systems, including Red Hat. Refer to the manual for a list of supported versions.
 
Please validate that each troubleshooting step below is true for your environment. Each step will provide instructions or a link to a document, in order to eliminate possible causes and take corrective action as necessary. The steps are ordered in the most appropriate sequence to isolate the issue and identify the proper resolution. Please do not skip a step.
 
Note: If you perform a corrective action in any of the following steps, attempt booting the virtual machine again.
1.      If your physical source machine has a vCenter Converter 4.0 supported version of Red Hat installed and you still have access to it:
a.      Upgrade to vCenter Converter 4.0 if you have not done so already.
b.      Run Converter and perform another physical to virtual conversion. This virtual machine should boot.
 
2.      If you are unable to use Converter to create a new Red Hat virtual machine that boots, you will need to modify the guest operating system.

Notes:
•      Before beginning, VMware recommends that you take a snapshot of your virtual machine. VMware also recommends that you back up any files that you edit in the following steps. Once the operating system is working the snapshot and back up files can be deleted.
•      In these steps, you will be making sure that the operating system has the appropriate type of virtual hard disk controller. This can be either LSI Logic or BusLogic. Choose the controller that is most suited to your version of Red Hat and make sure that it is this controller that is being presented to the virtual machine.
 
c.      Boot the virtual machine from the first Red Hat installation disk.
d.      At the first prompt, type linux rescue and press Enter.
e.      Change root to the mounted installation. Type chroot /mnt/sysimage and press Enter.
f.      If the physical computer was IDE based, replace any instance of the text /dev/hda with /dev/sda in the files /etc/fstab, /boot/grub/device.map, and /boot/grub/grub.conf.
g.      Ensure that grub is installed properly. Type grub-install and press Enter.
h.      If the file /etc/modules.conf exists, edit it and remove any existing entries.
i.      Edit the file /etc/modprobe.conf.
i.      Look for alias ethx module entries, where x is replaced by a number and module is replaced by text. Change each module entry to pcnet32.
ii.      If you will be using BusLogic:

Look for alias scsi_hostadapterx module entries, where x is replaced by a number and module is replaced by text. Change each module entry to BusLogic.
 
iii.      If you will be using LSI Logic:

Look for alias scsi_hostadapterx module entries, where x is replaced by a number and module is replaced by text. Change each module entry to mptscsih.

Additionally, look for an alias scsi_hostadapter module entry, where module is replaced by text and there is no number after hostadapter. If it exists, replace module with mptbase. If it does not exist, add alias scsi_hostadapter mptbase directly above the line that now reads alias scsi_hostadapter1 mptscsih.
 
j.      Determine the full path to the ramdisk image to be rebuilt. The file will is located in /boot. List the contents of the directory by typing ls /boot and pressing Enter. There will be a file with a name similar to initrd-2.6.9-42.EL.img. In this example, the full path to the ramdisk image is /boot/initrd-2.6.9-42.EL.img. Make a note of this.

Note: If there is more than one initrd- file in /boot, type cat /etc/grub.conf and press Enter to determine which file is being used.
 
k.      Determine the kernel version to use for rebuilding the ramdisk image. Type ls /lib/modules and press Enter. In this example, you will see the directory 2.6.9-42.EL. Make a note of this.

Note: If there is more than one directory shown, type cat /etc/grub.conf and press Enter to determine which kernel version is being used.
 
l.      Rebuild the ramdisk. Type the command mkinitrd -v -f /boot/initrd-2.6.9-42.EL.img 2.6.9-42.EL and press Enter, where /boot/initrd-2.6.9-42.EL.img is replaced with the information noted in h. and 2.6.9-42.EL is replaced by the information noted in step i.
 
3.      If you are unable to use a supported version of Red Hat, or the procedure in 2. did not work:
 .      Modify the physical machine to have support for either BusLogic or LSI Logic.
a.      Convert the physical machine again.


0
 

Author Closing Comment

by:Florescu
ID: 35356982
found answer elsewhere
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

This is the error message I got (CODE) Error caused by incompatible libmp3lame 3.98-2 with ffmpeg I've googled this error message and found out sometimes it attaches this note "can be treated with downgrade libmp3lame to version 3.97 or 3.98" …
I am a long time windows user and for me it is normal to have spaces in directory and file names. Changing to Linux I found myself frustrated when I moved my windows data over to my new Linux computer. The problem occurs when at the command line.…
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:

746 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now