Solved

How can I get a console session working with a ProCurve switch?

Posted on 2011-03-21
11
4,290 Views
Last Modified: 2013-11-09
I am trying to connect to a 2810-48G ProCurve switch via a console but I can't get a connection. When I try to connect I get a whole bunch of gibberish coming up, like random characters constantly scrolling across the window.

I have tried changing the baud rate in case it had been set on the switch but no option works, they just change the speed of scrolling gibberish.

I also tried adding a crossover cable between the console port and my serial port but that just gives me a blank screen and pressing enter does nothing.

I think the lead I am using maybe setup incorrectly because I made it based on google searches. I don't have the cable that came with the switch obviously. Does anyone know what the correct connections between the RJ-45 and DB9 plugs are? Or any other ideas why I can't connect, maybe it's not the cable?

Cheers! :)
0
Comment
Question by:luketay
  • 6
  • 5
11 Comments
 
LVL 4

Expert Comment

by:m_walker
Comment Utility
If you are getting gibberish on the screen then I would think your cable is working ok.  By changing the baud rate you got differnet type of gibbeish shows that your settings are not correct.

From the user guide at  : http://bizsupport2.austin.hp.com/bc/docs/support/SupportManual/c02564229/c02564229.pdf

The switch should auto detect any speed between 1200 to 115200
8 data bits, 1 stop bit, no parity, and flow control set to Xon/Xoff
Hit the enter key a few times when you see the gibberish, it should sync to the enter key presses.

Good luck
0
 

Author Comment

by:luketay
Comment Utility
Thanks for the advice.

I have tried pressing enter many times while the gibberish is displaying as well as sending breaks but no luck. Also, the settings I have are straight out of the same manual you pointed me to (configured as you wrote above).

0
 
LVL 4

Expert Comment

by:m_walker
Comment Utility
Can you ssh/telnet to the device ? If so you could check to see if the serial settings have changed in the config.  I will see if we have a simular model at work and see what I can find.  I know there is a procurve 24 port Gig in the back room, but cant remember the model.  The procurves I have here are all DB9 connectors.

Did you make the cable yourself ?
0
 

Author Comment

by:luketay
Comment Utility
I can't telnet/ssh because I can't remember the password. I pressed the clear button but the problem is I have to first use a console to set a new password before I can connect with telnet/ssh/web interface.

Yes I made the cable myself, which is why I was worried about the wiring of it, not the quality, but rather whether I wired the right wires to the pins.
0
 
LVL 4

Accepted Solution

by:
m_walker earned 500 total points
Comment Utility
I will see what I can find at work.  I'm gussing the cable will be the same as the cisco ones.

Have a look at this : http://www.hp.com/rnd/support/faqs/8212zl.htm#questionGP8
0
How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

 

Author Comment

by:luketay
Comment Utility
Mate you are a legend that helped me fix my cable straight away.

Now I can get into the console!

Only problem now is that I can't reset the passwords with the clear button...

I don't want to reset all the settings on it, just reset the passwords. The manual says hold down the clear button for 1 second to do this. I have tried that, tried holding it for much longer, tried holding it while rebooting, but no luck.

Whenever I try and log on to the console it asks for username and password, I leave both blank and it says "Invalid password". Am I doing something wrong here?
0
 
LVL 4

Assisted Solution

by:m_walker
m_walker earned 500 total points
Comment Utility
You can disable the password "clear" function in the config.

Have a read of : http://ftp.hp.com/pub/networking/software/2810-Security-July2007-59914734.pdf
Page: 2-15

You may need to erase the whole config to get access.

Some times you can use snmp to change a setting like the password.  A lot of people dont reset the defaults of public and private snmp V2 communities. If your handy with snmp you may be able to recover via that.  Its a long shot, but worth a look.
0
 

Author Comment

by:luketay
Comment Utility
That's annoying I was really hoping to avoid resetting all the settings because I don't know how it is configured and it's in a live environment. That link you sent me mentions calling ProCurve tech support for a new temporary password, this is totally new compared to the other manuals I have read, do you think it's a change in the software that you must contact them if you want to reset the password now?

As for snmp, I have no idea, how would you recover the password using that?
0
 
LVL 4

Assisted Solution

by:m_walker
m_walker earned 500 total points
Comment Utility
Not sure as where I work we would just swap out the device, clear the config/password and re-configure.  I understand that sometimes you cant really do that, or that its not the first option.

I would guess that HP allowed you to "lock" the device from the button reset, so offer a support call to reset without loosing the config.  Contact them via an email/web request and see what they say.

As to snmp it can get a little tricky if you have not used it before.
SNMP (Simple Network Managament Protocol): is used to manage you network devices.  A lot of devices come pre-configured (default) with snmp on with v2 community names public (read only) and private (read write).  The do this so you can just plug in, set the ip and point you snmp software to it and bingo your in.  The snmp "passwords" of differnet from the console passwords.  This means there MAY be a way to set the consol password via snmp.  Cheap gear has the password in clear text in some configs, but I will assume procurve are better then that.

If you have an IP port scanner, scan the device and see if port 161 is open.  This is the default SNMP Server port.  if its not you can forget the snmp attempt.  If it is, then find and snmp walk utility (linux will have one as part of the stock install) and run a walk over the device (the output can be long).

A quick test would be to walk the oid : 1.3.6.1.2.1.1  this will return a few lines about the device.  If this works your community name is correct.  You will want to try "private" as that would give read write access.

If that bit works, we can lookup the snmp password oid and workout what to send it to set the password (if it exists).  But its not worth too much time until basic snmp connectivity has been verified.

I would try HP first as it may be a free or cheap servie.  Then drop back to the snmp attempt, or option 3, the config reset and re-configure.  With some home work, you should be able to work out most of what needs to be setup.  The best place to start is the uplink switch.  If you dont have an uplink switch then it should not be too hard to work out whats going on.

0
 

Author Comment

by:luketay
Comment Utility
SNMP is a no go, the only ports open are SSH and Web, but interesting idea!

I've contacted HP support, hopefully they can help me with the clear, otherwise I'll have to do a full reset.

Thanks for your help.
0
 
LVL 4

Expert Comment

by:m_walker
Comment Utility
Glad I could help.
0

Featured Post

What Security Threats Are You Missing?

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

Join & Write a Comment

Quality of Service (QoS) options are nearly endless when it comes to networks today. This article is merely one example of how it can be handled in a hub-n-spoke design using a 3-tier configuration.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

15 Experts available now in Live!

Get 1:1 Help Now