Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2441
  • Last Modified:

SBS 2011 email bounce to local email address, rest works fine

Hi!

We have newly installed SBS 2011 server.

Every things works fine but whenever any user puts name of local user in TO field Outlook 2010 it gets resolves to email id in local exchange server format (@mycompany.local) & bounced back

if we put anyhow full internet email address (@mycompanydomain.com) then it gets deliver locally successfully.

Please help.


Please find the bounced message:




Delivery has failed to these recipients or groups:
 
mycompany sons - SURENDRA GANDHI
The e-mail address you entered couldn't be found. Please check the recipient's e-mail address and try to resend the message. If the problem continues, please contact your helpdesk.
 
Joginder Gandhi
The e-mail address you entered couldn't be found. Please check the recipient's e-mail address and try to resend the message. If the problem continues, please contact your helpdesk.
 
mycompany sons - RajKumar
The e-mail address you entered couldn't be found. Please check the recipient's e-mail address and try to resend the message. If the problem continues, please contact your helpdesk.
 
mycompany - 2 (Rishi)
The e-mail address you entered couldn't be found. Please check the recipient's e-mail address and try to resend the message. If the problem continues, please contact your helpdesk.
 
 
 
 
 
 
 
Diagnostic information for administrators:
 
Generating server: IBMDC.mycompany.local
 
IMCEAEX-_O=mycompanyS_OU=FIRST+20ADMINISTRATIVE+20GROUP_CN=RECIPIENTS_CN=SURENDER@mycompany.local
#550 5.1.1 RESOLVER.ADR.ExRecipNotFound; not found ##
 
IMCEAEX-_O=mycompanyS_OU=FIRST+20ADMINISTRATIVE+20GROUP_CN=RECIPIENTS_CN=JOGANDHI@mycompany.local
#550 5.1.1 RESOLVER.ADR.ExRecipNotFound; not found ##
 
IMCEAEX-_O=mycompanyS_OU=FIRST+20ADMINISTRATIVE+20GROUP_CN=RECIPIENTS_CN=RAJKUMAR@mycompany.local
#550 5.1.1 RESOLVER.ADR.ExRecipNotFound; not found ##
 
IMCEAEX-_O=mycompanyS_OU=FIRST+20ADMINISTRATIVE+20GROUP_CN=RECIPIENTS_CN=RISHI@mycompany.local
#550 5.1.1 RESOLVER.ADR.ExRecipNotFound; not found ##
 
Original message headers:
 
Received: from IBMDC.mycompany.local ([fe80::48c9:c045:32ad:ca79]) by
 IBMDC.mycompany.local ([fe80::48c9:c045:32ad:ca79%12]) with mapi id
 14.01.0270.001; Sat, 19 Mar 2011 14:52:40 +0530
Content-Type: application/ms-tnef; name="winmail.dat"
Content-Transfer-Encoding: binary
From: Surender Gandhi <Surender@mycompanysons.com>
To: Ablaze-OE2 <oe2@ablaze.co.in>, mycompany sons - SURENDRA GANDHI
        <IMCEAEX-_O=mycompanyS_OU=FIRST+20ADMINISTRATIVE+20GROUP_CN=RECIPIENTS_CN=SURENDER@mycompany.local>
CC: Joginder Gandhi
        <IMCEAEX-_O=mycompanyS_OU=FIRST+20ADMINISTRATIVE+20GROUP_CN=RECIPIENTS_CN=JOGANDHI@mycompany.local>,
        mycompany sons - RajKumar
        <IMCEAEX-_O=mycompanyS_OU=FIRST+20ADMINISTRATIVE+20GROUP_CN=RECIPIENTS_CN=RAJKUMAR@mycompany.local>,
        mycompany -3 <mycompanys@nda.vsnl.net.in>, "mycompany - 2 (Rishi)"
        <IMCEAEX-_O=mycompanyS_OU=FIRST+20ADMINISTRATIVE+20GROUP_CN=RECIPIENTS_CN=RISHI@mycompany.local>
Subject: RE: New Orders India 04-03-2011
Thread-Topic: New Orders India 04-03-2011
Thread-Index: AcvbOHbtQwi2oj11S2ua9lSKaM35CQK3m4SA
Date: Sat, 19 Mar 2011 14:52:37 +0530
Message-ID: <A86EFED4AD7FAA49B931112C0D6FDB700143B36E@IBMDC.mycompany.local>
References: <4C7EE1CA72A1438BA3039EFDACB6F6CE@mycompanys>
In-Reply-To: <4C7EE1CA72A1438BA3039EFDACB6F6CE@mycompanys>
Accept-Language: en-IN, en-US
Content-Language: en-US
X-MS-Has-Attach: yes
X-MS-TNEF-Correlator: <A86EFED4AD7FAA49B931112C0D6FDB700143B36E@IBMDC.mycompany.local>
MIME-Version: 1.0
X-Originating-IP: [192.168.0.102]
 
0
Akash Bansal
Asked:
Akash Bansal
  • 13
  • 8
2 Solutions
 
Glen KnightCommented:
Have you completed all the wizards in the SBS console? The INternet Address Wizard set's up your email domain, if you haven't done this then you will see the problems you are experiencing.
0
 
rrococi2Commented:
When you place the name of the user of mycompany.local does it resolve to just a name in the outlook to field?  It should.
0
 
Akash BansalIT ProfessionalAuthor Commented:
@demazter yes I did

@rrococi2 I could not get you
when i ping server or any host server.mycompany.local  it pings correctly

0
Visualize your virtual and backup environments

Create well-organized and polished visualizations of your virtual and backup environments when planning VMware vSphere, Microsoft Hyper-V or Veeam deployments. It helps you to gain better visibility and valuable business insights.

 
Glen KnightCommented:
can you check the properties of the users in Exchange Management Console, what email addresses do they have listed as their primary address?
0
 
Akash BansalIT ProfessionalAuthor Commented:
@demazter
You reached the right problem area.
 the list should have two email address i.e user@mycompany.local & user@mycompanydomain.com

but there is only one email address is present smtp:  user@mycompanydomain.com

& update email address as per policy is selected
0
 
Glen KnightCommented:
OK, there is no requirement for the @mycompany.local address, why do you want to use it?

if you want it, just add it to the email address policy under Organisation Configuration > Hub Transport > Email Address Policies
0
 
Akash BansalIT ProfessionalAuthor Commented:
No I do not want to add @mycompany.local address
but when any user is putting user name in TO: field of outlook while drafting email it auto resolves & the email is sent to @mycompany.local & result a bounced email

its happening on all users outlook
0
 
Glen KnightCommented:
have you migrated to PST from another system?
0
 
Akash BansalIT ProfessionalAuthor Commented:
not migrated but on some systems we have imported address book from pst / csv format (exporting address to csv or copying form pst contacts on few system)


we used to have sbs 2003 previously but we fresh installed sbs2011 on another physical server & then shut down sbs 2003
0
 
Glen KnightCommented:
that's the problem.  Outlook will use the contacts/NKS/suggested contacts from the previous version of exchange to resolve internal contacts.

You either need to delete the NK2 files (or suggested contacts if  using Outlook 2010) and that should fix it or add the username@domain.local to the address policy.

There's a quick way and a not so quick way to do this.
0
 
Akash BansalIT ProfessionalAuthor Commented:
v r using outlook 2010 on all pc
0
 
Akash BansalIT ProfessionalAuthor Commented:
would work on these two points & update you tomorrow :)
0
 
Akash BansalIT ProfessionalAuthor Commented:
I guess this problem is not with exchange server but with outlook or some bug in either of these.
i even tried adding smtp address through exchange console as @domain.local but the problem remain same.

Whenever the user choose "reply to all" & recipient are local users in that email; outlook shows warning as per the screen shots.
  further error help pop up
though if we right click on the address it shows correct address as @mydomain.com
but the facebook social connector shows the address as:
IMCEAEX-_O=mycompanyS_OU=FIRST+20ADMINISTRATIVE+20GROUP_CN=RECIPIENTS_CN=RAJKUMAR@mycompany.loca






outlook shows that there is problem in email address
I get the following text if I click on help popups

This error usually occurs when you attempt to view the calendar for a user who has one or more of the following issues:
Is not part of your domain.
Is not listed in the LDAP.
Is not a member of your Exchange Server.
Has not granted you the necessary permissions to view their calendar.
To avoid this error message, use the Open Calendar command only if the user is using Exchange Server.  If the user uses Exchange Server and you still encounter an error message, ask the user for the appropriate permissions to view their calendar.  If they are not part of your network, you will probably not gain access to their calendar.
For more information, see Microsoft Knowledge Based article 813603.
0
 
Glen KnightCommented:
You will need to reconfigure the facebook social connector or add an X500 address as explained in this article: http://support.microsoft.com/kb/909271
0
 
Akash BansalIT ProfessionalAuthor Commented:
even I could not find any @mydomain.local email address in outlook contacts or suggested contacts in outlook 2010
0
 
Akash BansalIT ProfessionalAuthor Commented:
If I uninstall facebook social connector still I need to ass a X500 address as per MS link?
0
 
Akash BansalIT ProfessionalAuthor Commented:
please read add in place of ass
0
 
Glen KnightCommented:
It's worth a try, if it doesn't work then you will need the X500 address
0
 
Akash BansalIT ProfessionalAuthor Commented:
0
 
Glen KnightCommented:
have you followed my suggestions?
0
 
Akash BansalIT ProfessionalAuthor Commented:
ya I had added X500 format email at exchange server then test it again but had no effect
after looking minutely I had noticed that every user was replying to same email

as I was right clicking the address in cc field  it was showing the right email address in the contact card  but now when I looked the email headers  I found that sender had marked cc in X500 format and users were replying to these email address causing bounced mails

now I have asked users to reproduce this problem with other emails and let  me know

If they can't I would consider this issue as resolved



Would update u if they revert back


Thanks for your nice efforts
0
 
Akash BansalIT ProfessionalAuthor Commented:
Actually I was wrong at the detection of the issue but the expert guided me correctly.

Please see my last comment where I describe why I was wrong.
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

  • 13
  • 8
Tackle projects and never again get stuck behind a technical roadblock.
Join Now