Solved

SBS 2008 will not accept RDP

Posted on 2011-03-21
6
706 Views
Last Modified: 2012-05-11
Successfully completed a migration over the weekend from Server 2003 Standard with Exchange 2003 to SBS 2008.

The problem I'm having is the only user that can RDP to the new SBS 2008 server is the 'administrator' account. Any new user I create in the Network Administrator role, it does not allow them to connect via RDP.

I have tried manually adding the new admin accounts to the Remote Desktop Users group and the Terminal Services group, with no results.

The error message I get is:
"To log on to this remote computer, you must be granted the Allow log on through Terminal Services right. By default, members of the Remote Desktop Users group have this right. if you are not a member of the Remote Desktop Users group or another group that has this right, or if the Remote Dekstop User does not have this right, you must be granted this right manually."
0
Comment
Question by:call_me_rick
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
6 Comments
 
LVL 23

Expert Comment

by:ormerodrutter
ID: 35181255
Have you checked on your new 2008 server to accept RDP (i.e. tick the "Enable Remote Desktop on this computer" box under System Properties? :)
0
 
LVL 23

Expert Comment

by:ormerodrutter
ID: 35181273
Ar but SBS won't accept RDP from non admin anyway. Maybe you need to put Network Admin into Administrators group.
0
 

Author Comment

by:call_me_rick
ID: 35181833
In SBS, the Network Administrator role automatically adds that user to the Domain Admins group...and I have verified manually that this is happening through AD Users & Computers.

Just for kicks, I did check the remote settings under system properties and Domain Admins is in the list of allowed users.

Again, the 'Administrator' user account CAN log in via RDP, but no other Domain Admins can.
0
 
LVL 58

Accepted Solution

by:
Cliff Galiher earned 250 total points
ID: 35184529
First guess is that a security template was applied to either the local security policy or to one of the domain group policies. Use RSoP to view what group policies are being applied for the DC and for the user attempting to log in. One of the security policies defines which users and groups are allowed to log in remotely as well as interactively (console) and if the defaults have been changed (as some of the high-security templates do) then they supercede the settings on the remote desktop tab of the computer properties.

-Cliff
0
 
LVL 6

Expert Comment

by:jaredr80
ID: 37475275
This question has been classified as abandoned and is closed as part of the Cleanup Program. See the recommendation for more details.
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Because virtualization becomes more and more common, and, with Microsoft Hyper-V included in Windows Server at no additional costs, and, most server hardware nowadays is more than capable of running a physical Small Business Server (SBS) 2008 or 201…
You may have discovered the 'Compatibility View Settings' workaround for making your SBS 2008 Remote Web Workplace 'connect to a computer' section stops 'working around' after a Windows 10 client upgrade.  That can be fixed so it 'works around' agai…
Finds all prime numbers in a range requested and places them in a public primes() array. I've demostrated a template size of 30 (2 * 3 * 5) but larger templates can be built such 210  (2 * 3 * 5 * 7) or 2310  (2 * 3 * 5 * 7 * 11). The larger templa…

756 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question