Solved

Sharepoint Server 2010 - New Installation default port 80 page now says error 404

Posted on 2011-03-21
38
1,665 Views
Last Modified: 2012-05-11
hi Guys


I am new to sharepoint I just installed a fresh copy of it the default saite through port 80 was working fine until it suddendly complained of error 404.

I have not made any changes that I know of, any help would be appreciated.

Kind REgards
0
Comment
Question by:ridha121
  • 19
  • 19
38 Comments
 
LVL 14

Expert Comment

by:GeorgeGergues
ID: 35181329
go to central administration.

- > Application management
 List of applications

Do you see your application ?

If yes
    Go  to site collections and see if you have a default site collection for that application you have.
If No

You do not have an application this means you have deleted your application .


Best of luck.
0
 
LVL 3

Author Comment

by:ridha121
ID: 35181411
Hi there

This  screen shot shows my default app that was automatically configured when i installed sharepoint..

it does not seem to work any longer?
defaultappsite.png
0
 
LVL 3

Author Comment

by:ridha121
ID: 35181599
I also have this error in the event log might be related

 
Log Name:      Application
Source:        Microsoft-SharePoint Products-SharePoint Foundation
Date:          21/03/2011 15:24:12
Event ID:      8059
Task Category: Configuration
Level:         Warning
Keywords:      
User:          AXIA-SHAREP\Administrator
Computer:      Axia-ShareP
Description:
Alternate access mappings have not been configured.  Users or services are accessing the site http://axia-sharep with the URL http://10.1.3.10.  This may cause incorrect links to be stored or returned to users.  If this is expected, add the URL http://10.1.3.10 as an AAM response URL.  For more information, see: http://go.microsoft.com/fwlink/?LinkId=114854"/>
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Microsoft-SharePoint Products-SharePoint Foundation" Guid="{6FB7E0CD-52E7-47DD-997A-241563931FC2}" />
    <EventID>8059</EventID>
    <Version>14</Version>
    <Level>3</Level>
    <Task>2</Task>
    <Opcode>0</Opcode>
    <Keywords>0x4000000000000000</Keywords>
    <TimeCreated SystemTime="2011-03-21T15:24:12.073242100Z" />
    <EventRecordID>2906</EventRecordID>
    <Correlation ActivityID="{54271912-33D7-4A88-B756-7FF6E72B7AFD}" />
    <Execution ProcessID="4988" ThreadID="3204" />
    <Channel>Application</Channel>
    <Computer>Axia-ShareP</Computer>
    <Security UserID="S-1-5-21-470641027-3109471647-597311291-500" />
  </System>
  <EventData>
    <Data Name="string0">http://axia-sharep</Data>
    <Data Name="string1">http://10.1.3.10</Data>
    <Data Name="string2">http://10.1.3.10</Data>
  </EventData>
</Event>

Open in new window

0
 
LVL 14

Expert Comment

by:GeorgeGergues
ID: 35182143
[1] are you trying to connect at

 http://axia-ShareP ?

or are you trying http://localhost  


[2] are you able to ping that name from your client and server and do they get the same IP.?

[3] Under application management - do you see an alternative access mappings other that that name ?
0
 
LVL 3

Author Comment

by:ridha121
ID: 35182295
I am connecting through the servers internal IP address (10.1.3.10)

Do I need to map this in alternative access mappings?
0
 
LVL 3

Author Comment

by:ridha121
ID: 35182317
well even localhost is not working
0
 
LVL 14

Expert Comment

by:GeorgeGergues
ID: 35182328
you should browse using this url
 http://axia-ShareP
0
 
LVL 3

Author Comment

by:ridha121
ID: 35182337
even with that url it comes up with 404 error and even in the server itself when I use localhost same issue
0
 
LVL 14

Expert Comment

by:GeorgeGergues
ID: 35182389
looks like you don't have any alterntive access mappings

Or they might have been deleted


Under application management ( by default ) you should have
 http://axia-ShareP
under the application
if that does not exist , add it .

0
 
LVL 3

Author Comment

by:ridha121
ID: 35182472
Application Management > Manage Web Applications

I have

Name
SharePoint - 80 then URL http://axia-sharep/ Port: 80

Isnt this correct? is that what your reffering to?
0
 
LVL 14

Expert Comment

by:GeorgeGergues
ID: 35182482
yes
0
 
LVL 3

Author Comment

by:ridha121
ID: 35182495
Hmm then I already have that configured which was set up by default?

It was working fine from the fresh install until it randomly came up with this error.

COuld it be any other settings?
0
 
LVL 14

Expert Comment

by:GeorgeGergues
ID: 35182569
can you send a screen shot of the AAM
0
 
LVL 3

Author Comment

by:ridha121
ID: 35182678
Ok what I done was to delete the site and create it again but now I get the following when I browse to its default IP on port 80.



HTTP/1.1 200 OK
Server: Microsoft-IIS/7.5
Date: Mon, 21 Mar 2011 17:19:32 GMT
Connection: close

I have also attached screenshot of AAM

 screenshot of aam
0
 
LVL 14

Expert Comment

by:GeorgeGergues
ID: 35182735
are you able to browse to  http://axia-sharep:18760
0
 
LVL 3

Author Comment

by:ridha121
ID: 35182760
yep that works well
0
 
LVL 14

Expert Comment

by:GeorgeGergues
ID: 35182768
ok , then you need to delete the  http://axia-sharep/
then re add it  at the AAM
0
 
LVL 3

Author Comment

by:ridha121
ID: 35182822
hmmm I am trying to delete it but where exactly is the option for this?

0
 
LVL 14

Expert Comment

by:GeorgeGergues
ID: 35182877
select it and delete it .
0
Backup Your Microsoft Windows Server®

Backup all your Microsoft Windows Server – on-premises, in remote locations, in private and hybrid clouds. Your entire Windows Server will be backed up in one easy step with patented, block-level disk imaging. We achieve RTOs (recovery time objectives) as low as 15 seconds.

 
LVL 3

Author Comment

by:ridha121
ID: 35182888
sorry for not mentioning , but the delete option is greyed out
0
 
LVL 14

Expert Comment

by:GeorgeGergues
ID: 35182911
you can try to change the default AAM to somthing else .
like 8080

also see if your IIS application has that port set correctly ,and make sure there isn't any host header
0
 
LVL 3

Author Comment

by:ridha121
ID: 35182952
I have deleted the default SharePoint - 80 app

and then readded it mapping it to the IIS website created during server installtion.

I have also checked bindings in IIS to verified that it iis binding to port 80.

I now get the message below when I go to the default site

HTTP/1.1 200 OK
Server: Microsoft-IIS/7.5
Date: Mon, 21 Mar 2011 17:47:00 GMT
Connection: close


0
 
LVL 14

Expert Comment

by:GeorgeGergues
ID: 35183168
what is the SharePoint - 80 app ?
is that inside the SharePoint or on IIS ?
0
 
LVL 3

Author Comment

by:ridha121
ID: 35188632
its in the IIS it is what was created automatically when installing sharepoint sever 2010
0
 
LVL 14

Expert Comment

by:GeorgeGergues
ID: 35188695
why delete it ?
that is your application ...

0
 
LVL 14

Expert Comment

by:GeorgeGergues
ID: 35188902
Do you have any other applications on the IIS server

at least you should have the Central Administration .


can you confirm that you are still able to get to http://axia-sharep:18760
0
 
LVL 3

Author Comment

by:ridha121
ID: 35188967
Hi there

I can still use Central Administration fine.

On IIS I have

1) SharePoint - 80 (I didnt delete this from IIS I deleted the app in Central Admin)
2) SharePoint Central Administration v4
3) Share Point Web Services

I only deleted the web app in central administration but I choose to keep the IIS website (shown in screenshot)

I have also put a screenshot of the IIS sites.

So after doing that when I now go to the site on port 80 it asks for user credentials and when I login I get the following error

HTTP/1.1 200 OK
Server: Microsoft-IIS/7.5
Date: Tue, 22 Mar 2011 12:37:59 GMT
Connection: close


0
 
LVL 14

Expert Comment

by:GeorgeGergues
ID: 35189036
The default is your application , why would you delete your SharePoint application .
I was under the assumption you wanted it , (hence this whole discussion thread )
0
 
LVL 3

Author Comment

by:ridha121
ID: 35189531
I didnt delete the sharepoint application I only deleted and then readded it to see if it would work after that.

I have aadded it back but I get that error now
0
 
LVL 14

Expert Comment

by:GeorgeGergues
ID: 35189684
can you go to Central admin
manage applications

You should see the same list of applications

Can you list the applications you have (a screen shot would be nice)
0
 
LVL 3

Author Comment

by:ridha121
ID: 35189706
Heres the list of applications

Applications
0
 
LVL 14

Expert Comment

by:GeorgeGergues
ID: 35189845
Can you post a list of the Applications on your IIS server

It looks like the application still exists in SP  but missing in IIS.

we are getting close.
0
 
LVL 3

Author Comment

by:ridha121
ID: 35189885
Sorry to keep troubling you.

Heres the screenshot of sites in IIS.

Could it be related to connected to the WSS database? because if you look at the ohter screenshot ive added it shows 0 connections I do remember this being 2?

 IIS SItes
 DB Connections
0
 
LVL 14

Expert Comment

by:GeorgeGergues
ID: 35189977
Very interesting

Did you ever have a site collection created
if you have not created one already  ( and that shows under Site collection count of 0)

you might want to create a new site collection

Under site collections , simply create new site collection , and pick a template
that should be the default site collection. on port 80


following site collections can be under /Sites/Sc1 , /Sites/Sc2 etc...


Best of luck
0
 
LVL 3

Author Comment

by:ridha121
ID: 35190128
I did create a site collection, I think it must of been after creating this that it stoppped working?
0
 
LVL 14

Expert Comment

by:GeorgeGergues
ID: 35190370
are you saying you have or or do not have a site collection ?

can you send a screen shot of the site collection lists
0
 
LVL 3

Author Comment

by:ridha121
ID: 35190498
Ok under application Management.

I clicked on create site collection then chose the template and chose teh site on port 80 and now it works taking me to the team site homepage.

I think this was my problem.

Thank you so much for your help for it has led me to this, I am still a newbie with sharepoint
0
 
LVL 14

Accepted Solution

by:
GeorgeGergues earned 500 total points
ID: 35190575
Any time
That is why we are here.
0

Featured Post

Maximize Your Threat Intelligence Reporting

Reporting is one of the most important and least talked about aspects of a world-class threat intelligence program. Here’s how to do it right.

Join & Write a Comment

The Scenario: Let’s say you have a quote worksheet in Excel that you use to work up sales figures and such for your clients. You utilize SharePoint to manage and keep track of these documents. You would like values from your worksheet to populate Sh…
We had a requirement to extract data from a SharePoint 2010 Customer List into a CSV file and then place the CSV file into a directory on the network so that the file could be consumed by an AS400 system. I will share in Part 1 how to Extract the Da…
In this seventh video of the Xpdf series, we discuss and demonstrate the PDFfonts utility, which lists all the fonts used in a PDF file. It does this via a command line interface, making it suitable for use in programs, scripts, batch files — any pl…
When you create an app prototype with Adobe XD, you can insert system screens -- sharing or Control Center, for example -- with just a few clicks. This video shows you how. You can take the full course on Experts Exchange at http://bit.ly/XDcourse.

759 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now