Solved

Mac Trash Won't Empty

Posted on 2011-03-21
24
1,725 Views
Last Modified: 2012-05-11
Hello Experts:
MY PROBLEM: [for my system info see below] A while I noticed that my good old reliable favorite Mac trash management app, "EmptyTrash," had stopped working. Odd. I tried a re-install. No change. I unistalled EmptyTrash.
My Trash Bin is waaay full (appprox. 2 million items), so I wanted to empty it. It won't empty. No way, no how. Returns an Error Code [see attachment] . Have tried the Press-mouse-Option-key trick. Doesn't work. I repaired permissions on disk, restarted - doesn't work. I resorted to several 3rd party apps: bathhmod, tothtrash,emptytrash, trashit - none of them worked. I already have Cocktail, which offers an option to Force Empty Trash. Doesn't work!

Have been all over Apple forums - see nothing useful there, except some Unix stuff, but I am not Unix-wise, so am afraid of Terminal.

Anyone got any ideas how to empty my Trash?

Oh, one other pertinent fact: there are old Time Machine backup folders in Trash - HOWEVER - I used batchmod to unlock them.

Please note, as well, I run my system from a Sandbox on external Firewire HD.



MY SYSTEM:
  Model Name:      iMac
  Model Identifier:      iMac8,1
  Processor Name:      Intel Core 2 Duo
  Processor Speed:      3.06 GHz
  Number Of Processors:      1
  Total Number Of Cores:      2
  L2 Cache:      6 MB
  Memory:      4 GB
  Bus Speed:      1.07 GHz
  Boot ROM Version:      IM81.00C1.B00
  SMC Version (system):      1.30f1
 Model: Hitachi HDS721075KLA360
 OSX ver 10.6.6              

 Error Message when attempt Empty Trash
0
Comment
Question by:jbm4
  • 12
  • 7
  • 4
  • +1
24 Comments
 
LVL 10

Expert Comment

by:jramsier
ID: 35182197
Many people suggest a format fixes this issue since this issue is related to the time machine.  You can also try this application below, i have not personally used it but know someone who had the same issue and it fixed her issue, just ensure you backup before:

http://www.macupdate.com/app/mac/8214/trash-it%21

Good luck.
0
 
LVL 4

Expert Comment

by:leewv1
ID: 35182424
You can try this link: http://hints.macworld.com/article.php?story=20010812235157202

It's not that difficult, just preform the following:

1) open terminal
2) cd ~/.Trash
3) rm -r *
4) type exit & hit return
5) quit terminal
0
 
LVL 53

Expert Comment

by:strung
ID: 35182630
Failure to empty trash is often a symptom of disk directory corruption. What happens when you run "verify disk" using Disk Utility. You should also repair permissions while you are at it.
0
 

Author Comment

by:jbm4
ID: 35182979
Hello:

¿ jramsier: Have already tried Trashit. Didn't work!

¿strung: Verify Disk finds no problems. Have repaired permissions multiple times. No change.

¿leewv1: i visited the  link you provided. Unfortunately, (as I originally whined!) I am not Unix-trained/friendly, and I find instructions on this web page for using Terminal commands as the Fix really unclear.  However, if you could translate  this business for me in Unix For Dummies language, and if it actually works, then you take the medal!

TX!

0
 

Author Comment

by:jbm4
ID: 35184250
leewv1 : TX for that additional reply. But I need to know: between your steps 1,2 &3...am I supposed to hit carriage return? Or are they all typed in single string? Exsqueeze my dumb-ness, but I've read so many dire warnings about fiddling in Terminal unless you're an expert, which I'm not - I'm not touching it until I know exactly what I'm doing!
0
 
LVL 53

Expert Comment

by:strung
ID: 35184260
Yes. Carriage returns between. You can copy and paste the lines into terminal so you don't mistype.
0
 
LVL 53

Expert Comment

by:strung
ID: 35184274
By the way, did you try doing a safe start (while holding down the shift key) and then emptying the trash?
0
 

Author Comment

by:jbm4
ID: 35184374
strung: am just about to undertake the Unix fix. But yes, i did run a Safe Start - nothing changed!
0
 

Author Comment

by:jbm4
ID: 35184479
de nada....
Well, guys, I painstakingly used those Terminal commands [snapshot attached], then I attempted "normal' empty Trash - threw same Error Code as above; then repeated the whole protocol two more times, and after each of those I attempted "Secure Delete Empty Trash." No change. Threw same error again!
 Terminal commands completed, exit.
0
 

Author Comment

by:jbm4
ID: 35184482
Experts;

i have to leave the house on biz for a few hours. Will check back on this issue later today. Thanks-so-far!
0
 

Author Comment

by:jbm4
ID: 35184499
OH - WAIT A MINUTE - I just noticed the "no such file or directory" message in those Terminal commands. Will go back now and try one more time! Will let you know!
0
 

Author Comment

by:jbm4
ID: 35184548
TAKE FOUR!
Well, I repeated Terminal Commands with extra care, and, as you can see in embedded snapshot, that "no such file or directory" message was generated. Terminal Commands and exit
*Could this have any connection to the fact of my running OSX from external Sandbox?
0
What Security Threats Are You Missing?

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

 

Author Comment

by:jbm4
ID: 35184551
Will be back later!
0
 
LVL 4

Expert Comment

by:leewv1
ID: 35185415
go back to your trash folder in Terminal and change directory to .Trash then type ls to see the contents of the directory.  Does anything show when  type ls and hit enter?
0
 
LVL 53

Expert Comment

by:strung
ID: 35185979
0
 
LVL 53

Expert Comment

by:strung
ID: 35185981
0
 
LVL 53

Expert Comment

by:strung
ID: 35185988
0
 
LVL 4

Expert Comment

by:leewv1
ID: 35186176
Try this:

1) Open terminal
2) cd $HOME/.Trash
3) type pwd to verify the dirrectory you are in.  It should read: /Users/your username/.Trash
4) type ls & hit return
5) if the ls command displays files/directories, then type sudo rm -r * and press return
0
 

Author Comment

by:jbm4
ID: 35191443
Good morning leew1 & strung:

Hey, NONE of the above achieved anything.

strung, I had already been over all of the sites you pointed me to - nothin' there worked.

leew1: I tried your last Terminal commands several times - nothin' happened at all !! And, re : "go back to your trash folder in Terminal and change directory to .Trash then type ls to see the contents of the directory.  Does anything show when  type ls and hit enter?". Sorry, but the instruction is not clear to me. Can you dumb it down for me?
0
 

Author Comment

by:jbm4
ID: 35191450
Will be on the road most of this day. Will check back here tomorrow!
0
 
LVL 53

Expert Comment

by:strung
ID: 35191560
0
 
LVL 4

Expert Comment

by:leewv1
ID: 35191826
jbm4, quick & brief unix training (simplistic at best):

ls = list the contents of the current directory
pwd = print working directory (tells where you are currently within the file structure)
rm = remove file/directory
cd = change directory

First requirement is to have a shell (window) open in Terminal.
Type pwd & press return to see what directory you are in.  It typically is your home directory (the user account in which you are logged into), like /Users/mimbyus/
Type ls -al & press return.  This will provide a list of all files and directories (including hidden ones)
Hopefully, you should see at the top of the directory listing on the far right is the directory .Trash
Hidden files are indicated by having a period in front of the file or directory.
If you see the directory entry .Trash, change directory (cd .Trash) to set the current working directory to the .Trash directory.
Type the ls -al command to see what files and directories that are in the .Trash directory
Because you have Time Machine files & directories (a LOT of files & directories), removing them all at one time can be daunting.  So I would change directories (cd) deeper into file structure probably 2 directories deeper and start removing files & directories by typing sudo rm -r <directory or filename> and press return.
Using sudo will require you to enter your administrator's password.  But doing it this way will keep you from having to confirm you deleting the contents.

I look forward to your response.
0
 

Accepted Solution

by:
jbm4 earned 0 total points
ID: 35200885
YOU'RE NOT GONNA BELIEVE THIS!

I knew that those deleted Time Machine backup files in Trash were almost for sure the central issue in my problem with not being able to empty Trash. How to get rid of  those Time Machine files??

After trying so many approaches to this problem suggested by you intrepid experts, I started noodling around with the utility, Cocktail. It has a feature: "Files/Locked" - it extends a panel onto which you can drag locked files for secure deletion (7-pass, I think). Just for the hell of it - never believing it would work - last nite before bed I dragged the Time Machine files from Trash into the Cocktail delete box.

The thing ground away for hours. Didn't look like anything was going to happen. So I went to bed and left it grinding away overnight. You guessed it: Cocktail DID delete the Time Machine files. Still, however, "Empty Trash" was not working. I discovered by trial and error that I could drag all contents in Trash onto Cocktail, and Trash was emptied fully that way. After a restart, and a test of Trash function, now my Trash Can is working just fine.

Go Figure!
0
 

Author Closing Comment

by:jbm4
ID: 35230086
MY OWN BLINDMAN STUMBLING AROUND SOLUTION!
0

Featured Post

Give your grad a cloud of their own!

With up to 8TB of storage, give your favorite graduate their own personal cloud to centralize all their photos, videos and music in one safe place. They can save, sync and share all their stuff, and automatic photo backup helps free up space on their smartphone and tablet.

Join & Write a Comment

Ever notice how you can't use a new drive in Windows without having Windows assigning a Disk Signature?  Ever have a signature collision problem (especially with Virtual Machines?)  This article is intended to help you understand what's going on and…
In this article we will discuss some EI Capitan Mail app issues and provide some manual process to resolve them.
This video teaches viewers how to encrypt an external drive that requires a password to read and edit the drive. All tasks are done in Disk Utility. Plug in the external drive you wish to encrypt: Make sure all previous data on the drive has been …
This Micro Tutorial will teach you how to reformat your flash drive. Sometimes your flash drive may have issues carrying files so this will completely restore it to manufacturing settings. Make sure to backup all files before reformatting. This w…

743 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now