Improve company productivity with a Business Account.Sign Up

  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3749
  • Last Modified:

Outlook 2010 won't connect to hosted Exchange Server

On a small business network that I support (about 20 seats altogether), one of the computers cannot connect from Outlook 2010 to the hosted exchange provider.  All the other computers can.  The problem is not with the user's hosted exchange account.  I tested by connecting successfully from one of my own office computers to his exchange provider.  Worked immediately.  This user recently upgraded by himself from Microsoft Office 2003 to Microsoft Office 2010.  However the upgraded Outlook 2010 worked fine for over 30 days.  Then one day it just stopped working.  The hosted exchange company is Intermedia.  I have tried to reinstall his Intermedia profile connector and tried to create a new profile.  I get the same error every time I attempt this...

"The connection to Microsoft Exchange is unavailable.   Outlook must be online or connected to complete this action."

From inside Outlook I can turn on Offline Mode and turn it back off.  When off, a prompt at the bottom of the screen shows Outlook trying to connect to the exchange server but reported "disconnected".  I have tried a whole bunch of interventions, none of which worked.  Here is a list of the things I've tried...

*turn off Windows Firewall
*turn off McAfee real time scan
*uninstall McAfee
*run malwarebytes scan (no viruses)
*completely uninstall Microsoft Office 2010 including uninstalling remnants of Microsoft Office 2003.  Delete Office folder from Program Files.  Delete "Office" Registry entries from Current User\Software and Local Machine\Software.
*numerous other attempts

The PC has normal Internet access and, as I mentioned, I scanned for viruses and found none.

I have followed Microsoft instructions in the following links with no success...
(box for "Encrypt data between Microsoft Office Outlook and Microsoft Exchange" is already checked)
"How to troubleshoot connectivity issues that are caused by RPC client protocol registry entries"
All the DLLs listed in the article appear to be present and match the version number of the O/S.
Name      Type      Data
ncacn_http      REG_SZ      rpcrt4.dll
ncacn_ip_tcp      REG_SZ      rpcrt4.dll
ncacn_np      REG_SZ      rpcrt4.dll
ncadg_ip_udp      REG_SZ      rpcrt4.dll

I am thinking there is some Outlook registry corruption of mismatch, possibly caused by the user's upgrade from Office 2003 to Office 2010, but at this point I cannot find the cause.  Thank  you for any help you can give.

1 Solution
AmitIT ArchitectCommented:
Check the lan and dns settings. Check any entry in the host file.
It may the Outlook 2010 autodiscover is corrupted.  Try to manually add the Exchange Account.

Perform these steps to get your server information to manually add the Exchange Acct.
1. Log on with the user's credentials to Outlook Web Access (OWA) at

2. Within OWA, click on Options in the top right corner.

3. Click on About.

4. Record the server listed under "Mailbox server name:".

5. Record the first name listed under "Mailbox Owner:"

Then in Outlook 2010,
1. Goto File > Account Settings
2. User the Server Info and Mailbox Name from OWA  for the fields

Good Luck
dgowerAuthor Commented:
amitkulshrestha and saastech:

Good advice from you both.   I am on-site for another customer today but I will try both suggestions out in next day.  I didn't think of the host file.  Thanks, will report back later.

Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

dgowerAuthor Commented:
I just remoted to the problem Outlook users' computer and tried both of your suggestions.  No joy, but the behavior did change a bit.

The HOST file had a great many entries apparently added at some point by Spybot.  It also had two entries pointing at an old subnet that formerly contained an Exchange server.  I removed all the entries except for localhost.

The DNS for the computer itself is weird, many more entries than I am used to...

The computer is actually on the 192.168.168.x subnet so I don't see how is going to work.  Could all these DNS entries be an issue?

After clearing the HOST file I tried reconnecting to the Exchange mailbox using the standard automated Profile Creator program from the hoster Intermedia.   The profile seemed to "create" much faster than before (more normally).  This screen did not hang and it did not end in the original error message about Outlook being "offline".  However eventually Outlook displayed the window which asks for the server name and user name.  It failed to resolve either.

I had previously logged on into OWA as the user in question and checked the entries in About, per saastech.  The entries were identical to what Outlook was already looking for, so that doesn't seem to be a promising direction.

As I say, the change in the HOST file seemed to show some improvement, but still no positive outcome.

Any other ideas?

Thank you.
I just fixed a similar issue by making sure that both items were checked in the Exchange Proxy settings:
    On a fast network, connect using HTTP first, and then by using the TCP/IP
    On a slow network, connect using HTTP first, and then by using the TCP/IP
Outlook connected right away after this. Previously, only the "On a Slow network" item was checked.
dgowerAuthor Commented:
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now