Solved

I would like to know what specs to look for a Cisco Switch on this configuration.

Posted on 2011-03-21
10
674 Views
Last Modified: 2012-05-11
Hi:
I am configuring a PIX/ASA and a CISCO switch with the configuration provided by tgerbert but I would like to know what model of switch should I use and what to look for on the switch?
Second: I would like to know what cable is use to trunk between the pix/asa and the switch
Third: Will the PIX/ASA 5505 work fine?.

Please advise.
NetDiagram.jpg
0
Comment
Question by:chenzovicc
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 4
10 Comments
 
LVL 16

Assisted Solution

by:memo_tnt
memo_tnt earned 100 total points
ID: 35183887
Hi

this depends on your network LAN speed, if 1Gig or 100Mbps, and if you have PoE devices like IPphones etc,,and the budget you have ..
from your network, you can use any of 2900 series (L2), i recommend 2960
or you can go to L3 switch 3500 .. i recommend 3560


regards
0
 

Author Comment

by:chenzovicc
ID: 35184441
The reality is that the customer I have does not want to spend much as he is going to buy the
CISCO/ASA 5505.

Will the 2924 or 2950 work fine?. Please advise me as you are expert on this things.
0
 
LVL 79

Accepted Solution

by:
lrmoore earned 400 total points
ID: 35184984
I would go with a 2960S full gigabit to all ports and inter-vlan routing if required.
Will 24x gig ports + the 7x 10/100 ports on the ASA be enough?

WS-C2960S-24TS-L  Catalyst 2960S 24 GigE, 4 x SFP LAN Base  
Or
WS-C2960-24TC-L  Catalyst 2960 24 10/100 + 2T/SFP LAN Base Image  

Standard CAT5e patch cable between the ASA and the 2960 switch

Be sure that you get the ASA with enough user licenses (10, 50 or unlimited) and DMZ. I recommend the Sec+ with unlimited user license.
ASA5505-SEC-BUN-K9  ASA 5505 Sec Plus Appliance with SW, UL Users, HA, 3DES/AES  
0
What is SQL Server and how does it work?

The purpose of this paper is to provide you background on SQL Server. It’s your self-study guide for learning fundamentals. It includes both the history of SQL and its technical basics. Concepts and definitions will form the solid foundation of your future DBA expertise.

 

Author Comment

by:chenzovicc
ID: 35185358
I know this could be another question but according to the diagram I provided for you.
Can I just configure E 0/1 with network 172.168.1.0 and place a linksys switch and on port E 0/2
with network 192.168.1.0 and place a linksys switch?

Thanks.
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 35185550
Yes, that will work fine but if the two networks need to talk to each other, be careful of the license on the ASA5505 because most options restrict communications between the vlans. The Sec+ does not restrict it.
0
 

Author Comment

by:chenzovicc
ID: 35185794
I need the two networks to be completely separate as they are 2 different businesses(One is investments and another Insurance but in the same office) so I think it will work fine.
Now Do I have to assign the same security level to E 0/1 and E 0/2.

Thanks
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 35185860
No, you can assign e1 default inside security level of 100 and e2 as level 99 if you want
0
 

Author Comment

by:chenzovicc
ID: 35203088
I configured the pix and try to connect my laptop directly into the port e 0/1 with the 192.168.1.1
and I was able to connect into the internet but when I try to connect with my laptop directly into the port
e 0/2 ip address 10.0.0.1 I can not access the internet. I am providing the configuration if you can please
advise why I can not connect on that port.

Thanks

This is the configuration:


:
ASA Version 7.2(4)
!
hostname CASA
domain-name cib.com
enable password 1plFi encrypted
passwd 2K encrypted
names
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.1.1 255.255.255.0
!
interface Vlan2
 no forward interface Vlan1
 nameif REALESTATE
 security-level 97
 ip address 10.0.0.1 255.255.255.0
!
interface Vlan11
 nameif outside
 security-level 0
 ip address dhcp setroute
!
interface Ethernet0/0
 switchport access vlan 11
!
interface Ethernet0/1
!
interface Ethernet0/2
 switchport access vlan 2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
dns server-group DefaultDNS
 domain-name cib.com
pager lines 24
mtu inside 1500
mtu REALESTATE 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-524.bin
no asdm history enable
arp timeout 14400
global (outside) 101 interface
nat (inside) 101 0.0.0.0 0.0.0.0
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
http server enable
http 192.168.1.15 255.255.255.255 inside
http 192.168.1.0 255.255.255.255 inside
http 10.0.0.0 255.255.255.255 REALESTATE
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
telnet 192.168.1.0 255.255.255.255 inside
telnet 192.168.1.15 255.255.255.255 inside
telnet timeout 5
ssh timeout 5
console timeout 0
dhcp-client client-id interface outside

!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect netbios
  inspect rsh
  inspect rtsp
  inspect skinny
  inspect esmtp
  inspect sqlnet
  inspect sunrpc
  inspect tftp
  inspect sip
  inspect xdmcp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:01722997b6d2a11c7d6f92d0f564dc2a
: end
asdm image disk0:/asdm-524.bin
no asdm history enable



User Access Verification

Password:
Type help or '?' for a list of available commands.
CA> en
Password: ******
CASA# config t
CASA(config)# sh ver

Cisco Adaptive Security Appliance Software Version 7.2(4)
Device Manager Version 5.2(4)

Compiled on Sun 06-Apr-08 13:39 by builders
System image file is "disk0:/asa724-k8.bin"
Config file at boot was "startup-config"

CASA up 24 mins 9 secs

Hardware:   ASA5505, 256 MB RAM, CPU Geode 500 MHz
Internal ATA Compact Flash, 128MB
BIOS Flash Firmware Hub @ 0xffe00000, 1024KB

Encryption hardware device : Cisco ASA-5505 on-board accelerator (revision 0x0)
                             Boot microcode   : CNlite-MC-Boot-Cisco-

Licensed features for this platform:
Maximum Physical Interfaces : 8
VLANs                       : 3, DMZ Restricted
Inside Hosts                : 50
Failover                    : Disabled
VPN-DES                     : Enabled
VPN-3DES-AES                : Enabled
VPN Peers                   : 10
WebVPN Peers                : 2
Dual ISPs                   : Disabled
VLAN Trunk Ports            : 0

This platform has a Base license.

Serial Number: JMX13
Running Activation Key: 0xd307f771 0xa3d46c94 0x48261487
Configuration register is 0x1
Configuration last modified by enable_15 at 15:34:04.582 UTC Wed Mar 23
0
 
LVL 79

Assisted Solution

by:lrmoore
lrmoore earned 400 total points
ID: 35206050
Simply add:
  nat (REALESTATE) 101 0 0
0
 

Author Closing Comment

by:chenzovicc
ID: 35208222
Thanks memo and Irmoore for your answers to my questions. Thanks for the last reply Irmoore works fine
when I add the nat.
0

Featured Post

Business Impact of IT Communications

What are the business impacts of how well businesses communicate during an IT incident? Targeting, speed, and transparency all matter. Find out more in this infographic.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
DHCP default-router command 1 28
VTP Setup 4 34
VoIP Polycom Phones not working 30 68
New CLI Commands Needed for Cisco ASA 5506 5 63
Creating an OSPF network that automatically (dynamically) reroutes network traffic over other connections to prevent network downtime.
Concerto Cloud Services, a provider of fully managed private, public and hybrid cloud solutions, announced today it was named to the 20 Coolest Cloud Infrastructure Vendors Of The 2017 Cloud  (http://www.concertocloud.com/about/in-the-news/2017/02/0…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Both in life and business – not all partnerships are created equal. Spend 30 short minutes with us to learn:   • Key questions to ask when considering a partnership to accelerate your business into the cloud • Pitfalls and mistakes other partners…

737 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question