Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

Use of Special Characters in Share Names on a Buffalo LinkStatio¿n NAS.

Posted on 2011-03-21
5
Medium Priority
?
479 Views
Last Modified: 2012-05-11
I have a Buffalo LinkStation which I mainly use for emulating client (i.e. customer) server locations prior to configuring software to point at those locations (e.g. \\servername\sharename\folder level 1\folder level 2\...).

I do this by logging into the root of the NAS and selecting the "Security > Setup shared folder" option; I then "Add a new folder" and enter the name of the top level folder on the designated server (i.e. "sharename" in the example above).
 
Next I add a new entry to the "hosts" file which is stored in the "C:\Windows\system32\drivers\etc" folder on my test PC; this quotes the IP address of the NAS and the name that is being allocated to that server ("servername" in the example above).

If I then use Explorer, I can type in \\servername\sharename and it will display all folders and files that have already been set up on the LinkStation; these can also be seen by typing in \\Buffalo\sharename (since "Buffalo" is the machine name I have ascribed to the device).

My problem is that some of the clients have a sharename that includes spaces or other non-alphabetic characters (e.g. "\\servername\other db's", or "\\servername\databases$", and the NAS device does not seem to be able to set up a sharename which includes these (although it is perfectly happy to deal with such characters at lower levels of the folder structure). This means that I cannot preconfigure the application to point in the right place.

Is this problem universal across all similar devices or is there anything I can do to overcome this? Obviously if you have a proper (Windows) server - which is what I am trying to emulate - then the spaces and other non-alpha characters work just fine. But I can't afford to go down that route.
0
Comment
Question by:JeremyHigginson
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
5 Comments
 
LVL 44

Expert Comment

by:Davis McCarn
ID: 35188832
Most versions of Linux don't like spaces or punctuation marks in file/folder names and; ironically, sometimes Windows hates them, too.  Until XP-SP3, both Wordpad and Notepad would often get confused by filenames with spaces..........
0
 

Author Comment

by:JeremyHigginson
ID: 35194359
...So I infer from your comment that the LinkStation uses Linux as its operating system, and this is the cause of the problem. Though it seems odd that the sharenames (effectively the root folders on the NAS?) have to comply with Linux naming conventions, but the remaining levels of the file structure don't - and these can happily use any characters that the client operating system can handle.

Should I therefore assume that there is no way round this problem short of buying a PC with Windows Server installed?
0
 
LVL 44

Accepted Solution

by:
Davis McCarn earned 1000 total points
ID: 35197658
Or simply use an old Windows computer with a 2nd hard drive.  Even a PIII-800Mhz can dish up data faster than a 100Mbs network.
0
 

Author Comment

by:JeremyHigginson
ID: 35202265
OK - I hadn't appreciated that I could perform the same feat on a Windows desktop PC. But I've dug out an old laptop, set up some shares with all the previously "forbidden" characters, created another hosts file which points at the new IP address of the laptop, and it works just fine with the <other db's>folder (space and apostrophe), but unfortunately not with the <databases$> folder, which for some reason is visible fine under a higher level share, but not as a "root" share. Never mind - i'm half way there and the "$" may be impossible to emulate without a proper edition of Windows server. Thanks for your help.
0
 
LVL 44

Expert Comment

by:Davis McCarn
ID: 35206890
Your welcome.  I had thought the use of $ was reserved for special strings anyway and shouldn't be allowed in an actual folder name.
0

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

The question appears often enough, how do I transfer my data from my old server to the new server while preserving file shares, share permissions, and NTFS permisions.  Here are my tips for handling such a transfer.
New style of hardware planning for Microsoft Exchange server.
This video teaches viewers how to encrypt an external drive that requires a password to read and edit the drive. All tasks are done in Disk Utility. Plug in the external drive you wish to encrypt: Make sure all previous data on the drive has been …
This Micro Tutorial will teach you how to reformat your flash drive. Sometimes your flash drive may have issues carrying files so this will completely restore it to manufacturing settings. Make sure to backup all files before reformatting. This w…
Suggested Courses

618 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question