Solved

Sharepoint 2010  Publishing - My Top Level Site shows up, but not the other site collections

Posted on 2011-03-21
4
722 Views
Last Modified: 2012-05-11
Hi
I have my sharepoint 2010 setup and I have the following access issues:

On the sharepoint server and another PC on the domain:
Works fine - http://pd3dserver6:2222/    (top level site)
Works fine - http://pd3dserver6:2222/sites/Template01    (site collection)

Through the web via www.pd3dportal.com
Works fine - directs to http://pd3dportal.com/SitePages/Home.aspx (top level site) asks for credentials, works fine)

BUT this DOESN'T work via the web:
http://pd3dportal.com/sites/Template01 

Am I doing something stupidly wrong?

I simply added a binding of port 80 to the site in IIS.

Thanks

-Andrew





0
Comment
Question by:simpsonator
  • 2
  • 2
4 Comments
 
LVL 15

Accepted Solution

by:
sharepointguru14 earned 500 total points
ID: 35185501
are you just trying to get rid of using servername:port and use FQDN on port 80 instead?

If so you will need to put a binding (host header) on port 80 for all ips that will be used for that web application in IIS.

Then you need to go into central administration and add/change your alternate access mappings so that SharePoint knows how to handle that new binding.
Alternate access mappings can be found in central administration under System Settings and then configure alternate access mappings.
Then select the web application you added the binding to. Then click on edit public urls and change the default to the host header address you used in IIS. If you may use other addresses (such as servername:port) after you click ok and are brought back to the screen of all mappings for that web app click on add internal address and put in the servername port address there.

Let me know if you have any questions
0
 

Author Comment

by:simpsonator
ID: 35185750
Hi
I'll try that tomorrow... but I'm trying to use www.pd3dportal.com as the web address which points to IP of the server, on all ports. I don't understand why it works on the top level site and not the site collection.
0
 
LVL 15

Expert Comment

by:sharepointguru14
ID: 35185774
Yep so the alternate access mappings you should the trick for you. The problem is that SharePoint doesn't know what that address is. It gets to the top level site because IIS takes the request and passes you to that top level site. When you click a link SharePoint is in the middle translating and it doesn't know it owns that address.
0
 

Author Closing Comment

by:simpsonator
ID: 35187724
Thanks!!!! I spent 3 hours messing with this late last night. I woke up this morning, sat with the laptop on the sofa, and 15minutes later it worked!
0

Featured Post

Courses: Start Training Online With Pros, Today

Brush up on the basics or master the advanced techniques required to earn essential industry certifications, with Courses. Enroll in a course and start learning today. Training topics range from Android App Dev to the Xen Virtualization Platform.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Possible fixes for Windows 7 and Windows Server 2008 updating problem. Solutions mentioned are from Microsoft themselves. I started a case with them from our Microsoft Silver Partner option to open a case and get direct support from Microsoft. If s…
A safe way to clean winsxs folder from your windows server 2008 R2 editions
This tutorial will walk an individual through the steps necessary to join and promote the first Windows Server 2012 domain controller into an Active Directory environment running on Windows Server 2008. Determine the location of the FSMO roles by lo…
This tutorial will walk an individual through the process of transferring the five major, necessary Active Directory Roles, commonly referred to as the FSMO roles to another domain controller. Log onto the new domain controller with a user account t…

776 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question