Solved

How to access shared workgroup folders remotely from a user on SBS 2003 Domain

Posted on 2011-03-21
16
674 Views
Last Modified: 2012-05-11
Heres the scenario.  We have a SBS 2003 with remote users.  We also have a NAS running Windows File Server 2008.  The NAS is not part of the domain, its on its own workgroup, and ofcourse the SBS is on a domain.  While in the office everyone can access the shared folders on the NAS with no problems at all.  When a user takes their laptop home and connects to the SBS 2003 they cannot access the shared folders that live on the NAS (which is on a workgroup, not the domain).  

I know there is a way to make it happen, I just cant recall it at the moment.  Any help would be great.
0
Comment
Question by:jtrabert
  • 8
  • 7
16 Comments
 
LVL 26

Expert Comment

by:Nick67
Comment Utility
'they cannot access the shared folders'
Just how does it go BANG!?

Access denied?
or drive letters not connecting?

Can they hit \\NASname\Sharedfolder ?
Can they hit \\10.0.0.1\SharedFolder or whatever the IP address of the NAS is?

Can they PING 10.0.0.1 or whatever the IP address of the NAS is?

Is everyone SOL or can admins access stuff?

How is it failing?

0
 

Author Comment

by:jtrabert
Comment Utility
Thanks for the quick reply.  It works great when everyone is at work.  After re-reading my question I think I should have worded it differently.

At work we have SBS 2003 with a domain called "Company"  all the users connect to the domain.  We also have a NAS running Windows file server 2008.  The NAS isnt on the domain, its on its own workgroup called "Office".  We have all the users access the NAS by mapping a shared drive to it.  So technically they are logging into the NAS through the guest login.  When the salesmen leave for the day and work from home in the evening theylll use their laptops to connect to the domain through VPN.  Now once they are connected to the domain, if they go to their mapped drives they cannot open them.  It'll say the drives are disconnected.
0
 
LVL 26

Expert Comment

by:Nick67
Comment Utility
That isn't necessarily insurmountable.  They can execute a login script batch file that will delete / remap their drives manually after connecting if need be.
Can they hit \\NASname\sharedfolder?
If they can, scripting the rest is easy.

Let me know
0
 

Author Comment

by:jtrabert
Comment Utility
Ill try it tonight, when I am home from work and remote in.  Ill update the post then, thanks!
0
 

Author Comment

by:jtrabert
Comment Utility
I just tried it a few minutes ago and I wasnt able to connect to the NAS.

I tried connecting to it through the NAS name and also the IP both didnt work.  It just returns a "The network path was not found".  

When Im connected from home to the work server that conenction is fine, but it wont even let me see the NAS.  Im not sure if I need to set up some kind of link from the server to the NAS since the NAS isnt part of the domain.  
0
 
LVL 26

Expert Comment

by:Nick67
Comment Utility
OK,

VPNing can be a funny thing.  Depending on how it is set up, the server may dish addresses from DHCP or it can set up it's own range.
The next thing to know is IP addressing.
When you are at work, what IP addresses does your machine, your server and your NAS have?
After you VPNed in, what address does the VPN server give you, and what address does it have?

Can you ping the NAS at work?
open the cmd window
ping NASname <enter>

Then from home, can you ping it?
0
 

Author Comment

by:jtrabert
Comment Utility
I appreciate all your help so far. The server is set for DHCP (although some PCs have static IPs) and we use a 10.1.10.X scheme.  

At work the server is 10.1.10.5, NAS is 10.1.10.26, and laptop is 10.1.10.76.  Now when I go home to test it out the laptop gets its IP address from my home router which is a 192.168.X.X scheme.  Going off of memory Im pretty sure I tried pinging it last night from home and it timed out, but Ill check again tonight.  As for VPN the way we are using it is lauching it from the icon that is  put there from the SBS.  The icon says "Connect to Small Business Server".  

As you can tell, this area isnt my strong point at all.
0
Better Security Awareness With Threat Intelligence

See how one of the leading financial services organizations uses Recorded Future as part of a holistic threat intelligence program to promote security awareness and proactively and efficiently identify threats.

 
LVL 26

Expert Comment

by:Nick67
Comment Utility
At home, do an ipconfig /all
You'll be getting a 192.168.x.x from your home server, but you'll also get something from the VPN.
What that is, is of interest if you can't ping the NAS.
I assume you can't ping anything but the server on the network.
But you know what they say about assume...
Ass u me
Ping other stuff besides the NAS when you are at home.
Is it as NAS thing, or as I suspect, an IP/VPN thing

Attached is the server properties page from the Routing and Remote Access MMC.
See if your server is dishing DHCP to VPN clients (good) or from a static pool (boo!, hiss!)
VPN.jpg
0
 

Author Comment

by:jtrabert
Comment Utility
Ill check everything out and update this post tonight when Im home from work and can test it, if there is anything else you think I should test at the same time just let me know if not Ill update tonight.  Once again thanks!
0
 

Author Comment

by:jtrabert
Comment Utility
I was able to test the IP and the setting you posted above.  The settings are as you suggested on the server.  When I did an ipconfig /all here are those settings:

 SS
A few things kinda concern me after looking at this info.  The first is that it shows DHCP set to "no", the DNS looks good, but the IP and Gateway are the same, is that normal?  And the Subnet is showing 255.255.255.255, when it should be 255.255.255.0 if Im correct.

Thanks again for your help.
0
 
LVL 26

Expert Comment

by:Nick67
Comment Utility
The spidey sense is tingling.
I recall some remote access connection settings being for "allow access only to this machine" vs "allow access to the network"
Maybe in Remote Access policies?

I'll have to research
Google those strings and see if you come across something.
If I find it first, I'll post back
0
 
LVL 26

Expert Comment

by:Nick67
Comment Utility
Another thing to take a swing at is re-running the Internet connection wizard-twice.
Change one minor setting on the first run -- and change it back on the second.
The wizard can be a flakey monster, but it HAS to set the main settings.

I'll keep poking
0
 
LVL 26

Accepted Solution

by:
Nick67 earned 500 total points
Comment Utility
I don't run SBS 2003 anymore.
I moved to an SBS 2008 machine.
The RRAS setup has changed heavily

The default gateway you're getting is the problem -- or a symptom of the problem
It limits access to just the server.
The other settings are ok.

Remote Access policies, or the properties of the VPN.
There's a checkbox in there someplace that is restricting access to just the server.
That's accomplished by assigning that default gateway.
Find that checkbox and you'll be good.
DHCP.jpg
0
 

Author Comment

by:jtrabert
Comment Utility
Sorry for the delay on getting back to you, I was away on business.  I will double check tonight for those settings.
0
 

Author Comment

by:jtrabert
Comment Utility
Easy Qlemo, I was out of the country on business.  I just got back on Friday.
0

Featured Post

IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

Let’s list some of the technologies that enable smooth teleworking. 
I recently attended Cisco Live! in Las Vegas, a conference that boasted over 28,000 techies in attendance, and a week of hands-on learning hosted by a solid partner with which Concerto goes to market.  Every year, Cisco displays cutting-edge technol…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're looking for how to monitor bandwidth using netflow or packet s…

763 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

6 Experts available now in Live!

Get 1:1 Help Now