?
Solved

Crystal Report 2011 TTX File not updating

Posted on 2011-03-21
6
Medium Priority
?
1,371 Views
Last Modified: 2012-05-11
I am using .NET 2008 with CR 2008, and am migrating reports from VB6. They all migated perfectly, and I decided to fix a few things. I added a field to my TTX definition, and used the DATABASE EXPERT to add the new TTX ( I gave it a different name since I've had this problem before). So I add the TTX (DETAILEXTRA2.TTX), and expand it and my new field is not there. I've tried with a 3rd, 4th, and a 5th file to no avail.

Then I quit and restarted VB, and created an entirely new report. ALL my DETAILEXTRA TTX files (now six of them) contain the newly added field. I added all six of them, and NONE of them have the newly added field. I'm quite confused...
0
Comment
Question by:JamesDBuskirk
  • 3
  • 2
6 Comments
 
LVL 101

Accepted Solution

by:
mlmcc earned 2000 total points
ID: 35185477
Did you try a VERIFY DATABASE on the existing reports?

Did you try a REFRESH on the databases from the database expert?

mlmcc
0
 

Author Comment

by:JamesDBuskirk
ID: 35185500
I had done the VERIFY DATABASE every time it didn't work. I hadn't done the REFRESH. I went into the Database Expert, then then removed all 6 recordsets from the right. Then i refreshed the list on the left, and added one of the new TTX files. It didn't work. Iv'e uploaded the source code to my PC at work, perhaps it will work there.
0
 

Author Comment

by:JamesDBuskirk
ID: 35185535
It didn't work on my office PC.
0
Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

 

Author Comment

by:JamesDBuskirk
ID: 35185872
I created one manually using the CREATE FILE button, and it worked. *sigh*

Admin, Go ahead and close this please. Thanks for the suggestions Mlmcc.
0
 
LVL 101

Assisted Solution

by:mlmcc
mlmcc earned 2000 total points
ID: 35185925
Try logging off the database then back on and open one of the reports.

mlmcc
0
 

Expert Comment

by:ems180
ID: 36004360
Im having same issue:
I did verify database, refresh on database and on TTX, I logged off and Logged on the server. No luck. I removed the connection and recreated the connection to the same TTX and nothing.
What am I missing here
0

Featured Post

Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Crystal Reports: 5 Tests for Top Performance It is complete, your masterpiece report.  Not only does it meet your customer’s expectations, it blows them out the water, all they want is beautifully summarised and displayed in a myriad of ways. …
Hello everyone, Hope you find this as helpful as we did. We have on the company I work for an application built in Delphi V with Crystal Reports 8. We all know that Crystal & Delphi can be temperamental sometimes and the worst thing is, nearly…
Get the source code for a fully functional Access application shell with several popular security features that Access VBA application developers desire, but find difficult or impossible to figure out how to code. You get the source code for managi…
If you are looking for an automated solution for backup single or multiple Office 365 user mailboxes to Outlook data file, then you can use Kernel Office 365 Backup & Restore tool. Go through the video to check out the steps to backup single or mult…
Suggested Courses

588 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question