Solved

Microsoft Exchange Server 2007 backup and replication is working but Symantec EV 8.0 SP4 is not archiving ?

Posted on 2011-03-21
19
1,386 Views
Last Modified: 2012-05-11
Hello All,

I am new to the EV world that is why I ask this question in this topic, the following error message is what I've found following the problem in my Exchange Server mailbox database partition build up:

From the Exchange Server 2007, the backup is all went fine (no transaction log build up) and also the CCR replication is working fine, buthow come EV failed by itself here ?

here's my understanding for this problem:

The EV server must be able to archive the Exchange Server 2007 mailbox so that the databasesize in my Exchange mailbox server can be reduced, therefore If the EV server not gets backed up (in which I do not know how and where to do it?) then it will not archive the Exchange server 2007 mailbox thus the Mailbox Database builds up ?

Thanks,

DG
There are 20667 savesets that have not yet been backed up or replicated for Vault Store 'Vaultstore1'. 
 There is a build-up of savesets that Enterprise Vault cannot confirm have been backed up or replicated.

Example symptoms: archive-pending items remain in mailboxes, leading to calls to your Help Desk from users; store sizes do not decrease, even though items have been archived.

There may be a problem with backups or replication.

Open in new window

0
Comment
Question by:jjoz
  • 11
  • 8
19 Comments
 
LVL 42

Assisted Solution

by:paulsolov
paulsolov earned 500 total points
ID: 35186001
this usually indicates that you have not backed up your EV Server or if backed up not cleared the archive bit.  EV typically archives the data but keeps a copy on the Exchange server until the EV Server is backed up and the archvie bit is reset.  This needs to be done via EV Agent or powershell scripts so that the EV Vaults, Index, and SQL DB are quiesced to cleanly backup the EV Server.  Once EV is backed up the items are deleted from Exchange
0
 
LVL 1

Author Comment

by:jjoz
ID: 35186118
ok, so in this case are we talking about backing up the EV server ?
once the VSS aware 3rd party backup software successfully run, then the EV will be working back to normal ?

it seems that there is correlation between the Exchange mailbox database archival process and then the EV server back up status it self. ?
cmiiw.
0
 
LVL 42

Expert Comment

by:paulsolov
ID: 35186150
How are you backing up the EV Server?  Is the archiving taking place at all..are you seeing the shortcuts in the mailboxes and the vaults growing?

Keep in mind it's not really VSS aware backup since it will not run the powershell scripts to put the EV into backup mode and put it back into backup mode when it's done.  You need to run EV Backup Agent (backup exec, or netbackup) or run EV Powershell scripts as part of your EV Server backup that will do it for you and take it out of backup mode when backup of EV Server is completed.
0
 
LVL 1

Author Comment

by:jjoz
ID: 35186215
Paul,

"EV into backup mode and put it back into backup mode when it's done"
is this a typo or something that i need to write from scratch (powershell) ? where can I get the sample script for that?
is that something that I need to put into the post/pre backup script field ?

How are you backing up the EV Server?   I'm using HP dataprotector (as this is a Vm and this old backup software is just there when I'm joining this new company).

Is the archiving taking place at all..are you seeing the shortcuts in the mailboxes and the vaults growing?
well I suppose yes it works normally in Storage Group 6 where I resides, I can browse the email back into 2006 all without problem.
But in the other Storage group it seems that the database is growing larger and larger everyday.
0
 
LVL 1

Author Comment

by:jjoz
ID: 35186273
ok, I've found Generating PowerShell Backup Commands.pdf from the Symantec site, is that the script that you mean ?
0
 
LVL 42

Assisted Solution

by:paulsolov
paulsolov earned 500 total points
ID: 35186278
That's the one

http://www.symantec.com/business/support/index?page=content&id=TECH75694


Make sure that HP Dataprotector is clearing the archive bit..if not then EV will not think it's backed up.


The reason you can browse the emails is that it's archiving them but not deleting the originals off of the mail server.  You probably have Pending items shortcuts instead of full blown shortcuts in Outlook.

Without using the powershell scripts the backups of EV may be crash consistent and perhaps corrupt.
0
 
LVL 1

Author Comment

by:jjoz
ID: 35186495
oh, I thought that as long as there is VSS backup in place then all is fine ?
ok, let me follow that guide and then will let you know again in this thread if it is working.

see the attachment on my inbox (it is sitting on Storage group 6 which is OK not growing as the other storage group).
EVMail2004.JPG
0
 
LVL 42

Expert Comment

by:paulsolov
ID: 35186540
That looks like the final shortcut after backup of ev server. Either way you need to backup using the scripts
0
 
LVL 1

Author Comment

by:jjoz
ID: 35186591
cool, it is good to know that by default EV backup must be supported with the pre and post backup script.
0
Threat Intelligence Starter Resources

Integrating threat intelligence can be challenging, and not all companies are ready. These resources can help you build awareness and prepare for defense.

 
LVL 1

Author Comment

by:jjoz
ID: 35194895
I thought this requirement was removed by our most recent version of EV?  We used to have these scripts in place yet removed them once a particular service pack for EV went in.

I'm using EV 8.0 SP4 so just wondering if this is still required ?
0
 
LVL 1

Author Comment

by:jjoz
ID: 35194910
http://www.symantec.com/business/support/index?page=content&id=TECH66742

because it says:

Microsoft -> Windows Server 2008 -> Enterprise (x86-32bit) SP2
Microsoft -> Windows Server 2008 -> Standard (x86-32bit) SP2
Microsoft -> Windows Server 2008 -> DataCenter (x86-32bit) SP2

while mine is SP4
0
 
LVL 42

Expert Comment

by:paulsolov
ID: 35195045
In previous versions (version 7.0 and back) there was a way to do this using reg entries.  This was no longer needed because now there are powershell cmdlets to do this. This is why you can right click on the site and put in backup mode.  The only difference if you're using 64 bit is that you still need to run the 32 bit powershell as the link describes.  32 bit Windows 2008 is not supported for EV per compatibiliyt matrix.
0
 
LVL 1

Author Comment

by:jjoz
ID: 35195531
I was just under the impression that it is no longer required, but then the article from: http://www.symantec.com/business/support/index?page=content&id=TECH66742

Enterprise Vault for Microsoft Exchange -> 8.0 -> 8.0 SP4 (still needed) but.....

Environment

Microsoft -> Windows Server 2003 -> Standard Server SP2
but mine is Enterprise ?

how about EV 9 does it still needs to do this ? or if the underlying OS is Windows Server 2008 does it needs this powershell script as well ?
0
 
LVL 42

Expert Comment

by:paulsolov
ID: 35195590
The backup process for EV8 up to SP5 is exactly the same as well as EV9. The only difference if you're using 64 bit OS (2003 or 2008) you need to point to the 32 bit Powershell, that's all..as states in the link.

Windows Server 2008 64-bit

"Symantec.EnterpriseVault.PowerShell.Snapin.dll" is a 32-bit PowerShell Snap-In, and the defaultPowershell.exe is the  64-bit version.  Attempting to run the previous commands would produce a warning
0
 
LVL 1

Author Comment

by:jjoz
ID: 35195651
ah cool so if I apply SP5 then I shouldn't need to create this script anymore ?
0
 
LVL 42

Accepted Solution

by:
paulsolov earned 500 total points
ID: 35195729
NO...you will need to use scripts for any version you will run, including EV9.  Otherwise you are not getting a valid backup.  There is no way for EV to know that you are doing a backup so at the same time you're backing up data it is still writing data to indexes and vaults that may cause corruption if you need to restore.  The scripts puts EV into backup mode to give you a clean backup
0
 
LVL 1

Author Closing Comment

by:jjoz
ID: 35195743
many thanks Paul
0
 
LVL 1

Author Comment

by:jjoz
ID: 35195764
it was an eye opener ! I didn't knew about this until I post this issue here, once again many thanks Paul !
0
 
LVL 42

Expert Comment

by:paulsolov
ID: 35195952
No problem.  If you're looking for any consulting services please contact me, my contact info is on my profile page
0

Featured Post

How does your email signature look on mobiles?

Do your employees use mobile devices to reply to emails? With mobile becoming increasingly important to the business world, it is in your best interest to make sure that your email signature looks great across all types of devices.

Join & Write a Comment

We are happy to announce a brand new addition to our line of acclaimed email signature management products – CodeTwo Email Signatures for Office 365.
This article explains in simple steps how to renew expiring Exchange Server Internal Transport Certificate.
This tutorial will walk an individual through configuring a drive on a Windows Server 2008 to perform shadow copies in order to quickly recover deleted files and folders. Click on Start and then select Computer to view the available drives on the se…
This tutorial will show how to configure a new Backup Exec 2012 server and move an existing database to that server with the use of the BEUtility. Install Backup Exec 2012 on the new server and apply all of the latest hotfixes and service packs. The…

757 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

23 Experts available now in Live!

Get 1:1 Help Now