Solved

Opening an Attachment in Outlook 2007 brings up warnings, How do I get rid of these warnings

Posted on 2011-03-21
26
676 Views
Last Modified: 2012-05-11
Hello Experts,

I have one client that has 12 PCs, All are Windows 7 x64 with Office 2007. Only one person has an issue where he opens an attachment such as a PDF and then when he tries to close the email message where that attachment comes from he gets a pop-up warning telling him that changes have been made to the PDF and that he will loose any changes if he proceeds. No matter what he chooses No or Yes he will get another warning.

I want to get rid of these pop-ups. He doesn't like them. He doesn't want them and he signs my checks :(

Any Ideas?

Also happens with word documents and does not happen on any other PCs.

Thanks,

Lasareath
 As soon as you try to close the email the attachment came from you get this warning No matter what choice you choose you will get this warning
0
Comment
Question by:Lasareath
  • 15
  • 4
  • 4
  • +1
26 Comments
 
LVL 9

Expert Comment

by:Scottyworld
Comment Utility
Hi,
Does this also happen when the same user logs onto another PC?
Does it happen when another user logs onto this PC.

Just want to determine if it's a PC issue or a user profile issue so I know what area to investigate
0
 

Author Comment

by:Lasareath
Comment Utility
Both very good suggestions. I will try them out and report back.

thanks

0
 
LVL 8

Expert Comment

by:Nivlesh
Comment Utility
seems like something is changing the files when you open them. Have you got antivirus installed that might be scanning the attachments locally on the pc?
0
 

Author Comment

by:Lasareath
Comment Utility
I have Vipre on all the PCs
0
 
LVL 8

Expert Comment

by:Nivlesh
Comment Utility
0
 

Author Comment

by:Lasareath
Comment Utility
Nivlesh,

that looks very promising. I'll try it out and let you know.

Thanks!

0
 
LVL 8

Expert Comment

by:Nivlesh
Comment Utility
sounds good. all the best
0
 

Author Comment

by:Lasareath
Comment Utility
I put this in a batch routine and it seems to do nothing.

http://getsatisfaction.com/sunbeltsoftware/topics/vipre_is_causing_outlook_error_with_acrobat_attachments

The errors still happen and they happen on 3 PCs so far with no matter who is logged in. I guess only the Boss was complaining about it.

I'm going to try and disable the outlook scanning and see if that helps.

But first I need to watch StarGate Universe ;)

Lasareath

0
 

Author Comment

by:Lasareath
Comment Utility
This is what i was trying to copy paste:

regsvr32 -u -s "C:\Program Files (x86)\Sunbelt Software\VIPRE\SBAMOutlook.dll"

That's what i put into a batch routine and it does nothing. I confirmed that's the location of the SBAMOutlook.dll file on the PC I was working on,


0
 

Author Comment

by:Lasareath
Comment Utility
Even with outlook scanning disabled and the whole email section disabled it still happens.

I will try and reboot and see if it still happens after the reboot.

After that I will remove Vipre and see if that helps.

0
 
LVL 8

Expert Comment

by:Nivlesh
Comment Utility
If it is Viper (which I highly suspect), it must be having hooks into Outlook (this is the normal way antivirus scanning works) and disabling it might not be removing the hooks, which might be the reason for the issue you are having. Yes removing it completely might be a way to test if it is infact Viper.

Stargate Universe.. love that show but havent watched for ages now
0
 

Author Comment

by:Lasareath
Comment Utility
Restart did nothing.

I removed Vipre and rebooted and still exactly same thing.

One machine in the office still has Office 2003 and it does the same thing.

I have one PC with Acrobat X Pro. I will test to see if that machine has same issue.

If you use outlook please test yourself. Open an email that has a PDF attachment, then open the attachment and then try to close the email. What happens?

I just tried it on this PC here at my house, Windows XP, Outlook 2007 and Acrobat 9.4 and that same thing happens. I have Vipre Also.

0
 
LVL 7

Expert Comment

by:shahzamm
Comment Utility
if the file is opened in edit mode (with acrobat) it will change properties of last opened stamp. if file is opened & you try to close the message. This is causing the message to pop up.

try with adobe reader installed only & opene attachment with that. see if it pops up.
same applies to word.
0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 

Author Comment

by:Lasareath
Comment Utility
It does the same thing with word.


0
 

Author Comment

by:Lasareath
Comment Utility
I removed Acrobat 9 Pro and Installed Acrobat Reader X and it does exactly the same thing!

I also rebooted and that made no change.

Outlook still thinks the PDF has been modified.

It must be Outlook. I guess it's time to get rid of Outlook! LOL, Yeah that's not going to happen.

 
0
 
LVL 7

Expert Comment

by:shahzamm
Comment Utility
actually this message pops up when we open a file do changes & save it in same location (outlook secure temp). when we clos ethe message it pops up
see if this helps. http://support.microsoft.com/default.aspx?scid=kb;en-us;967629&sd=rss&spid=11335
0
 
LVL 7

Expert Comment

by:shahzamm
Comment Utility
0
 

Author Comment

by:Lasareath
Comment Utility
I tried opening outlook this way:
Start>Run>Outlook.exe /noextensions
And it did nothing.

The URL given with the accepted answer is dead.

http://windowsitpro.com/article/articleid/100219/how-do-i-disable-com-add-ins-in-microsoft-outlook-2007.html



I also tried this with no luck:

In Windows XP, click Start, click Run, type regedit, and then click OK.
Locate and then select the following registry subkey:
HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Outlook\Options\General
On the Edit menu, point to New, and then click String Value.
Type ExtensionsToExcludeFromTracking, and then press ENTER:
Right-click ExtensionsToExcludeFromTracking, and then click Modify.
In the Value data box, type the extensions that you do not want to track, and then click OK.

0
 
LVL 7

Expert Comment

by:shahzamm
Comment Utility
what about openeing outlook in safe mode with outlook.exe /safe
this is what mentioned in dead thread.

if it worked then you need to remove the addin causing the problem.
0
 

Author Comment

by:Lasareath
Comment Utility
I'll try it later today when I'm going to their office.  

Thanks.  
0
 
LVL 9

Expert Comment

by:Scottyworld
Comment Utility
Have replicated this issue in Outlook 2003 and 2007, but it doesn't seem to be an issue in Outlook 2010
Not that it helps much, just thought you might want to know !
0
 
LVL 9

Accepted Solution

by:
Scottyworld earned 500 total points
Comment Utility
The reason this is happening is because when an attachment is opened from an open message, it is opened in read/write mode
There are a couple of solutions to this....

1) Enable the reading pane, then while viewing the message in the reading pane, open the attachment from there. This will open the attachment in read only mode, and hence will not give you the message box.

2) There is a registry change for Outlook 2007 (not sure if this works for 2003) that will force attachments to open in read only mode, even if you open the attachment from an open message (instead of the reading pane)
Go to the following registry key
HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\12.0\Outlook\Options\General
Create a new value as below
Value name: OpenAttachmentsReadOnly
Value Type: REG_DWORD
Value: 1
0
 

Author Comment

by:Lasareath
Comment Utility
@shahzamm

I did the outlook.exe /safe and it did nothing.

@Scottyworld

You are correct about the reading page. If you open the attachment using the reading page then you cannot receive the error message because you cannot close the email message. I can try and get my client to open the attachments that way.

I will try your registry change right now and I will report back.

Thanks!
0
 

Author Comment

by:Lasareath
Comment Utility
@Scottyworld

The only folder I have under HKEY_CURRENT_USER\Software\Policies\Microsoft\ is SystemCertificates

Should I create these sub folders: Office\12.0\Outlook\Options\General  ?



0
 

Author Comment

by:Lasareath
Comment Utility
@Scottyworld

WORKS!!!!!

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\12.0\Outlook\Options\General]
"OpenAttachmentsReadOnly"=dword:00000001


 OpenOutlookAttachmentsRead-Only.reg
0
 

Author Comment

by:Lasareath
Comment Utility
Only works for 2007.  That's what he uses so he's good.

0

Featured Post

Complete VMware vSphere® ESX(i) & Hyper-V Backup

Capture your entire system, including the host, with patented disk imaging integrated with VMware VADP / Microsoft VSS and RCT. RTOs is as low as 15 seconds with Acronis Active Restore™. You can enjoy unlimited P2V/V2V migrations from any source (even from a different hypervisor)

Join & Write a Comment

Check out this infographic on what you need to make a good email signature that will work perfectly for your organization.
If you don't know how to downgrade, my instructions below should be helpful.
The viewer will learn how to use the =DISCRINV command to create a discrete random variable, use this command to model a set of probabilities and outcomes in a Monte Carlo simulation, and learn how to find the standard deviation of a set of probabil…
The viewer will learn how to use a discrete random variable to simulate the return on an investment over a period of years, create a Monte Carlo simulation using the discrete random variable, and create a graph to represent the possible returns over…

728 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now