How do you tell Visual Studio 2010 to Connect to a SQL 2008 server running on port 11433

I am trying to connect to a SQL 2008 server that is running TCP on port 11433.  Visual Studio wants to connect to the server of 1433.  The two are just not seeing eye to eye.  How do I make VS 2010 connect on port 11433?
kwh3856Asked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
Rikin ShahConnect With a Mentor Microsoft Dynamics CRM ConsultantCommented:
can you try this connection string!

Data Source=190.190.200.100,1433;Network Library=DBMSSOCN;Initial Catalog=myDataBase;User ID=myUsername;Password=myPassword;
0
 
Rikin ShahMicrosoft Dynamics CRM ConsultantCommented:
I'm not sure with your problem, but if you can check the settings and 4th point (Enable Remote Connection) in below link.

see if this helps,
http://blog.sqlauthority.com/2009/05/21/sql-server-fix-error-provider-named-pipes-provider-error-40-could-not-open-a-connection-to-sql-server-microsoft-sql-server-error/
0
 
kwh3856Author Commented:
Great artical but still no luck.  I have multiple NICs in the SQL 2008 server and I tried changing the Port for the NIC in Configuration Manager -> SQL Server Network Configuration -> Protocols for MSSQLSERVER - TCP/IP -> Properties --> IP Addresses TCP Port on the IP Address of the NIC that I am trying to access.  I changed it from 11433 to 1433.  Rebooted the server and still no luck.  I checked the registry and saw the changed had been updated.  I made specific rule in the firewall for the port....NO Luck:)  

Any Ideas?
0
Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

 
Rikin ShahMicrosoft Dynamics CRM ConsultantCommented:
can you check with the 3rd point in "Server-related causes"

http://support.microsoft.com/kb/328306

and

http://support.microsoft.com/kb/328383
0
 
Carl TawnSystems and Integration DeveloperCommented:
How are you trying to connect from Visual Studio? Are you talking about your code, the Server Explorer, or something else?
0
 
Rikin ShahMicrosoft Dynamics CRM ConsultantCommented:
yes to server explorer.
- open your VS.NET project
- go to server explorer
- right-click on 'Data Connections'
- select 'Add Connection'
- Advanced...
- Data Source = "SERVER=servername;DATABASE=YourDataBaseName;Network=DBMSSOCN;Address=IP_Address,1433;UID=YourUID;PWD=YourPassword;"

try this if it works!

BTW, are you able to connect sql server through Management Studio?
0
 
chandra_darbhaCommented:
You should add an alias on the client machine which is (where the VS is) connecting to the SQL Server in SQL Server Configuration Manager -> Aliases.

Thanks,
Chandra
0
 
kwh3856Author Commented:
I am trying to connect through Server Explorer Data Connections
0
 
Rikin ShahMicrosoft Dynamics CRM ConsultantCommented:
Is this what you were looking for?
0
 
kwh3856Author Commented:
rikin,
I tried that and it responded with invalid connection string.
0
 
kwh3856Author Commented:
Rikin,
That was it.  My mistake initially was that I put Data Source x.x.x.x:11433 and I should have put x.x.x.x,11433.  Works like a champ now.

Thanks
Kenny
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.