Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 392
  • Last Modified:

CentOS network issue

Hi,

My centOS 5.5 server can ping the wireless router but not the laptops in the intranet. The laptops however can ping the server. All laptop and centOS server are assigned IP automatically.

Please help.

Thanks
0
wsyy
Asked:
wsyy
  • 5
  • 4
  • 3
1 Solution
 
upanwarCommented:
Which OS you are using in your laptops. If its Linux then stop the firewall by issuing below given command.

# iptables --flush

and try to ping your laptop.

If you are using the WIndows XP then disable the firewall from your network connection properties.

0
 
pilson66Commented:
In yout wireless router, you need to disable feature named like "Set AP isolated".
This feature prevents wireless clients communicate with each other.

Or, if you setup wireless router as "router", and connect intranet segment to WAN port  - you need to set router to "AP" (not routing) mode and connect intranet segment to one of LAN ports in riouter.

P.S. Sorry for my English.
0
 
pilson66Commented:
Also, in wireless routeryou need to disable DHCP server, to prevent conflicts with DHCP server in intranet segment.
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
wsyyAuthor Commented:
upanwar:

My laptops are using Windows 7. Do you think that is the reason?
0
 
wsyyAuthor Commented:
pilson66:

The network topology is this:

1. An adsl modem connected through PPoE to internet (outside network);
2. A wireless router connected to the modem;
3. A centOS server directly connected to one of the router's port;
4. A few laptops and desktops of Windows 7 OS connected to the router wirelessly.

I don't think I have firewall set up explicitly unless Windows 7 automatically does.

Also, I don't know why I have to stop DHCP internally since the laptops and desktops work fine, and the server can get internet as well. The only issue is that the CentOS server can't connect to the laptops and desktops while the laptops and desktops can ping it.

Thanks
0
 
upanwarCommented:
Disable the firewall on one of your desktop or laptop and test. It should work.
0
 
pilson66Commented:
Laptops connected through Wi-Fi? If yes - you need to disable feature named like "Set AP isolated".
This feature prevents wireless clients communicate with each other.
0
 
pilson66Commented:
Also
on CentOS: show "ifconfig" and "iptables-save"
on laptops: show "ipconfig /all"
0
 
wsyyAuthor Commented:
upanwar:

I just notice that the laptops have Windows Firewall on. Is this what you mean?
0
 
wsyyAuthor Commented:
I will check the solutions you guys recommended.

Please take a look at this post and help!

http://www.experts-exchange.com/OS/Unix/Q_26903551.html
0
 
upanwarCommented:
Yes, just disable that and check.
0
 
wsyyAuthor Commented:
Thanks great help!
0

Featured Post

Get free NFR key for Veeam Availability Suite 9.5

Veeam is happy to provide a free NFR license (1 year, 2 sockets) to all certified IT Pros. The license allows for the non-production use of Veeam Availability Suite v9.5 in your home lab, without any feature limitations. It works for both VMware and Hyper-V environments

  • 5
  • 4
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now