new citrix presentation server 4.0 is returning internal ip address when launching desktop from outside the network

I'm setting up a new citrix presentation server 4.0 and the published desktop is not working from outside the network. I've setup nat on my firewall and set the alternate ip address through a command prompt, but the ica file still returns the internal ip. How do I make it work from the outside?
knfitzAsked:
Who is Participating?
 
Carl WebsterCommented:
I would delete the altaddr setting on the server (altaddr /? cuz I don't remember the command), reboot the server and reeneter the altaddr.

Read this article I wrote to make sure you everything setup properly:

http://dabcc.com/Webster/AltAddr
0
 
Carl WebsterCommented:
when you run altaddr from the command prompt on the new server, what does it return?
0
 
knfitzAuthor Commented:
it gives 2 columns, the default and the external ip.
0
Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

 
knfitzAuthor Commented:
Here's what I typed, is this correct?

altaddr /set 11.111.11.111

of course I used my actual ip but i didn't enter the external subnet. Did I do this part right? Is there a place in the citrix administration to enter external ips? this is a new install.
0
 
basrajCommented:
Can you try the address translation said in the third post?

http://www.brianmadden.com/forums/t/25630.aspx
0
 
Carl WebsterCommented:
altaddr /set 192.168.1.1 11.111.11.111 /v

192.168.1.1 is the internal IP of your server
0
 
knfitzAuthor Commented:
i don't know what the third post was talking about with the server side firewall settings. I tried using the altaddr like carl just said but I'm getting the same results. when I try to launch the dekstop it says there is no citrix metaframe server configured on the specified address and if the client is not installed then I save the ica file and it has the internal ip address in it. it works from inside the network but not the outside.
0
 
knfitzAuthor Commented:
Looks like we're closer. the ica file is now returning the public ip. But I'm still getting the error message from oustide the network. Are you sure I need to open up a port besides 443?
0
 
knfitzAuthor Commented:
Thank you, opening that port did it.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.