Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

SSRS Report Saved In Sharepoint Libary

Posted on 2011-03-22
5
Medium Priority
?
679 Views
Last Modified: 2012-05-11
Hi All

I am still new to SSRS And Report Builder i have created a report and saved it onto my sharepoint Library, however if a user clicks in the .rdl report file to view it they get the following error message

An error has occurred during report processing. (rsProcessingAborted)
Cannot create a connection to data source 'DataSource1'. (rsErrorOpeningConnection)
For more information about this error navigate to the report server on the local server machine, or enable remote errors

Its probably something i have missed can anybody help?

Thank You
0
Comment
Question by:pepps11976
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
5 Comments
 
LVL 3

Expert Comment

by:AndrewSkoraro
ID: 35191506
Try setting the connection properties of the data source in SharePoint.  Do this to the actual library item in SharePoint.
0
 

Author Comment

by:pepps11976
ID: 35191537
Ok This might be wear i am going wrong all i did was click save as in report builder and saved to a document libary, i am not ware of any data source created, where would this be?
0
 
LVL 3

Expert Comment

by:AndrewSkoraro
ID: 35199601
This would be in a library that has the SSRS data source content type.  It can be the same library as the report. Create a Shared Data source in report builder and save it (publish) to the document library. Once its there, you can edit its connection properties. You will need to use this data source in your report instead of an embedded one.
0
 

Author Comment

by:pepps11976
ID: 35199663
You only have the option to Use an Existing One Or Create an Embedded one in Report Designer.

So i have used the embedded one and i have found where it puts it in sharepoint, the only way that i can get it to work is by using The SA account where you select the radio button for stored credentials.

This cant be the right way to do this though
0
 
LVL 3

Accepted Solution

by:
AndrewSkoraro earned 2000 total points
ID: 35200216
Your system may not be setup to support passing through the users credentials (I.E: kerberos). I would recommend creating an account in SQL server that has read access to the stored procs or databases that your reports require. This way you dont use the SA account.



0

Featured Post

Ask an Anonymous Question!

Don't feel intimidated by what you don't know. Ask your question anonymously. It's easy! Learn more and upgrade.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This code started out as a fix for a customer that had incoming data that was hunderds of numbers and words long that was to fit in one column. The problem was that the customer did not want to split words or numbers when wrapping in the column. …
It is helpful to note: This is a cosmetic update and is not required, but should help your reports look better for your boss.  This issue has manifested itself in SSRS version 3.0 is where I have seen this behavior in.  And this behavior is only see…
In this video, Percona Solution Engineer Dimitri Vanoverbeke discusses why you want to use at least three nodes in a database cluster. To discuss how Percona Consulting can help with your design and architecture needs for your database and infras…
In response to a need for security and privacy, and to continue fostering an environment members can turn to for support, solutions, and education, Experts Exchange has created anonymous question capabilities. This new feature is available to our Pr…

604 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question