• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 550
  • Last Modified:

Error when accessing SSRS 2005 Report web site

Hi,

I have SSRS 2005 SP3 CU6 installed on Windows 2003 32bit IIS machine. When I try to open the ReportServer site (http://localhost:8001/reportserver) or Reports site (http://localhost:8001/reports), I am getting the below error:

HTTP Error 401.1 - Unauthorized: Access is denied due to invalid credentials.
Internet Information Services (IIS)

I have tried enabling NTLM also using ADSUtil. But no luck. Can someone help me on this?
0
Srinivas_Vengala
Asked:
Srinivas_Vengala
  • 4
  • 3
1 Solution
 
Daniel_PLDB Expert/ArchitectCommented:
Please verify NTFS permissions on SSRS folders, by default:
%ProgramFiles%\Microsoft SQL Server\MSSQL.\Reporting Services\ReportServer
%ProgramFiles%\Microsoft SQL Server\MSSQL.\Reporting Services\ReportManager

Check if groups like following have access (read, execute):
SQLServer2005ReportingServicesWebServiceUser$<servername>$<instancename>
SQLServer2005ReportServerUser$<servername$<instancename>


Recheck SSRS configuration in SSRS configuration manager.
0
 
Srinivas_VengalaAuthor Commented:
I have already checked and given those groups  (and the application pool and the SSRS service account directly also) update permissions on these folders. But no luck.
0
 
Daniel_PLDB Expert/ArchitectCommented:
Run following code in cmd:
 
cd C:\Inetpub\Adminscripts
cscript adsutil.vbs get w3svc/NTAuthenticationProviders

Open in new window


When output is like The parameter "NTAuthenticationProviders" is not set run following:
 
adsutil.vbs set w3svc/NTAuthenticationProviders "NTLM"

Open in new window

0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
Srinivas_VengalaAuthor Commented:
I have told already in my initial thread that I have enabled NTLM in this way. It didn't work for me.
0
 
Daniel_PLDB Expert/ArchitectCommented:
Is this fresh install or it just stopped from working? I can't recall your initial thread.
0
 
Srinivas_VengalaAuthor Commented:
It is a fresh install. It seems I had to forgot to provide the application pool account with ASP.NET permissions. Once I gave that, it worked.
0
 
Srinivas_VengalaAuthor Commented:
OK
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 4
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now