• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 619
  • Last Modified:

SMTP Service Causing High Internet Usage

Customer is complaining that the Internet is very slow.  After some troubleshooting, I have determined that SMTP is causing the issue.  The server is an SBS2003 running Exchange.  When pinging with the SMTP service started, the reply is 3000-4000ms.  When stoping the SMTP service, the ping reply drops down to a reasonable 20-40ms.  I checked the queue in System Manager but it is empty.  Any ideas?
0
ptsolutionsinc
Asked:
ptsolutionsinc
  • 4
  • 3
1 Solution
 
greenbug2002Commented:
is the SMTP Service actualy passing any traffic out the internet connection or is it slowing a proxy used for internet access by usisng CPU and memory if its the first option i would put a sniffer on the connection and see what is being sent second option try re-service packing exchange
0
 
ptsolutionsincAuthor Commented:
we dont have a proxy and and CPU usage is normal.  how do i put a sniffer on the connection?
0
 
MegaNuk3Commented:
It may be receiving a large message/s and you won't see that in the queue.

What are the message size limits? Hopefully 5Mb max 20Mb...

You can turn on SMTP protocol logging to see what is happening, but I would recommend setting message size limits if you have none.
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

 
ptsolutionsincAuthor Commented:
I have checked the message size limits and they were set to unlimited.  i changed to 20MB but the issue continues.  I followed Microsoft's Knowledgebase to enable SMTP protocol logging and MSExchangeTransport is already set to Maximum but the knowledgebase does not show how to access the logging.  where do I go to check this?
0
 
MegaNuk3Commented:
Should be under c:\windows\logfiles

Did you restart SMTP after setting the size limits?
0
 
ptsolutionsincAuthor Commented:
Yes, I did restart the SMTP service.  The c:\windows\logfiles folder does not exist.  I did however research other Experts-Exchange posts and found a post that helped me resolve the problem.  Not sure if there is a way to link this post to that post but the post is below.  The accepted solution is what helped me out.

http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/Q_26873983.html


alanhardisty:

If you block TCP Port 25 outbound on your firewall - the message flow should stop and then you can see the messages in the queue and delete the offending ones.  Then open port 25 back up again and problem solved.

When a message is being sent - the queue will appear empty - this is nothing unusual.
0
 
MegaNuk3Commented:
Thanks for the final solution, feel free to close the question.
0
 
ptsolutionsincAuthor Commented:
I researched other Experts-Exchange posts and found a post that helped me resolve the problem.  Not sure if there is a way to link this post to that post but the post is below.  The accepted solution is what helped me out.

http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/Q_26873983.html
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

  • 4
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now