Solved

Setting Apache to be visible on the Internet

Posted on 2011-03-22
7
402 Views
Last Modified: 2012-05-11
Hello,

could you help me with Apache2 configuration (on Ubuntu 10.04) to be visible on my public IP address? I'd like to know what to set and in which configuration files.

thank you
0
Comment
Question by:xRalf
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
7 Comments
 
LVL 4

Expert Comment

by:philetaylor
ID: 35192824
The apache2 configuration files are stored in /etc/apache2

The default installation (sudo apt-get install apache2) should listen on all IP addresses and serve pages from /var/www

The Ubuntu help site will give you more information for specific configuration options:

https://help.ubuntu.com/10.04/serverguide/C/httpd.html

Cheers

Phil
0
 
LVL 6

Author Comment

by:xRalf
ID: 35192926
My apache web server is working localy, but I need to be visible globally.
Please cite some particilar section related to my problem from the link you sent.
0
 
LVL 4

Expert Comment

by:philetaylor
ID: 35193151
The link I sent deals with basic configuration of Apache including how to set which IP addresses the server is listening on.

I would need more information to be able to accurately answer your question.

Does your server currently have a public IP address or an unconnected (10.x.x.x, 192.168.x.x, 172.16.x.x) address?

If it is unconnected then you must first create some sort of network address translation on your router to route http (port 80) requests to your Ubuntu server.

If the server has a public address then you will need to ensure that any firewall (including any software firewall running on the Ubuntu server) is allowing requests from the Internet to port 80.

Cheers

Phil
0
Turn Insights Into Action

You’ve already invested in ITSM tools, chat applications, automation utilities, and more. Fortify these solutions with intelligent communications so you can drive business processes forward.

With xMatters, you'll never miss a beat.

 
LVL 6

Author Comment

by:xRalf
ID: 35193456
>> I would need more information to be able to accurately answer your question.

That is not the problem. I will describe the details you need to know.

>> Does your server currently have a public IP address or an unconnected (10.x.x.x, 192.168.x.x, 172.16.x.x) address?

I don't know how to set it. I have public IP but don't know where to write it in configuration files.

>> If it is unconnected then you must first create some sort of network address translation on your router to route http (port 80) requests to your Ubuntu server.

This is already done in my router in port forwarding.

>> If the server has a public address then you will need to ensure that any firewall (including any software firewall running on the Ubuntu server) is allowing requests from the Internet to port 80.

I think that I don't use any software firewall but now can I find out if there is one blocking port 80?


0
 
LVL 4

Accepted Solution

by:
philetaylor earned 500 total points
ID: 35193525
If your router is using port forwarding then you should not need to enter the public IP within the Ubuntu server (the router will handle translating requests to the private (unconnected) address of the server.

I assume that the Ubuntu server can successfully access the Internet? try something like "ping www.google.com" if this is successful then outbound connections are working ok (which is half of the battle!)

Unless you have installed another software firewall on your Ubuntu server then the default is an iptables based one called ufw. This is disabled by default but if you have enabled it, then you will need to specifically allow access to port 80 using something like:

"sudo ufw insert 1 allow 80"

Cheers

Phil
0
 
LVL 6

Author Comment

by:xRalf
ID: 35196186
The ufw firewall is probably disabled.
$ sudo ufw status verbose
Status: inactive

I need that my webserver is working from the address that writes me whatismyip.com . So others can use it.
0
 
LVL 6

Author Closing Comment

by:xRalf
ID: 35432015
Thank you for troubleshooting. I mistyped my IP address in port forwarding.
0

Featured Post

[Webinar] How Hackers Steal Your Credentials

Do You Know How Hackers Steal Your Credentials? Join us and Skyport Systems to learn how hackers steal your credentials and why Active Directory must be secure to stop them. Thursday, July 13, 2017 10:00 A.M. PDT

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Over the last year I have answered a couple of basic URL rewriting questions several times so I thought I might as well have a stab at: explaining the basics, providing a few useful links and consolidating some of the most common queries into a sing…
If you've heard about htaccess and it sounds like it does what you want, but you're not sure how it works... well, you're in the right place. Read on. Some Basics #1. It's a file and its filename is .htaccess (yes, with a dot in the front). #…
If you're a developer or IT admin, you’re probably tasked with managing multiple websites, servers, applications, and levels of security on a daily basis. While this can be extremely time consuming, it can also be frustrating when systems aren't wor…
In this video we outline the Physical Segments view of NetCrunch network monitor. By following this brief how-to video, you will be able to learn how NetCrunch visualizes your network, how granular is the information collected, as well as where to f…

691 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question